Plex wont play movies

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex wont play movies

      Hi All
      Not been here in a long while, good to be back.
      My plex install has stopped playing movies in my movie library, either casting to chromecast or playing directly in the browser.

      I've uninstalled the plugin removed my library, reinstalled and rebuilt my libraries but still to no avail, has anyone else experienced similar?
      Any help much appreciated, sorry if this is a duplicate.
      HP N40L microserver | OMV 1.19 (Kralizec) | OMV extras 1.34 | kernel 3.16.0-0.bpo.4-amd64
    • Same Problem here as well

      RV shows working great but plex don't play movies

      Running OMV 3.0 and plexmediaserver 3.0
      NAS: Fractal Design Define R4 | Intel Xeon E3-1265L-v3 | Kernel: 4.18 | ASRock Rack E3C224-4L | 32GB ECC RAM | System: Crucial M500(250GB) | LSI 9260-8i - RAID0: 2x Samsung 850 EVO (250GB) + 2x Intel SSD (230G) | LSI 9270-8i - 6x WD Red 6 TB RAID5
    • I've got an N40L microserver with an AMD Turion II Neo N40L (1.5 Ghz) K625.
      I'm using the plex plugin which currently shows as plugin version: openmediavault-plexmediaserver 1.0.12
      In plex the version shown is 0.9.15.2
      I don't remember doing anything special for my setup re the AMD processor.

      Thanks for having a think, this one has me stumped as it was working and doesn't appear to be a full partition that the transcode directory uses.
      HP N40L microserver | OMV 1.19 (Kralizec) | OMV extras 1.34 | kernel 3.16.0-0.bpo.4-amd64
    • The plot thickens.
      I can play some of my movies, namely the blu rays MKV's I ripped using make mkv on my laptop.
      The ones I can't play were DVDs ripped using a headless ripper on the N40L, which uses handbrakeCLI.
      Tekkb you may have an excellent memory as I had to build hanbrakeCLI from source I think due to my Processor.

      Where it is weird is these MKV used to play just fine, if there is anything else I can add that might help debug let me know.

      P.S. Kodi plays them on my firestick from the SMB share so it's not a mega urgent problem, just odd that they have stopped working.

      P.P.S I could just upgrade my OMV to 2 to see if that helps...
      HP N40L microserver | OMV 1.19 (Kralizec) | OMV extras 1.34 | kernel 3.16.0-0.bpo.4-amd64
    • Sorry for the Long Wait for a reply.
      I run the flashmemory plugin and rebooted to see if it would fix the issue, so there is nothing datng back that far in the log.

      Plex plugin did an update to plex but that hasn't changed the issue.
      I will try re encoding my mkvs to h264 as other video with that codec seems to work fine, In the meantime Kodi plays them on my Amazon Fire Stick Just fine...
      HP N40L microserver | OMV 1.19 (Kralizec) | OMV extras 1.34 | kernel 3.16.0-0.bpo.4-amd64
    • I solved my error. Not enough space left on Hardisk ...

      on OMV 3.0 Plex database is stored on system disk... created a symlink and moved data base to a different disk and all is working fine :)
      NAS: Fractal Design Define R4 | Intel Xeon E3-1265L-v3 | Kernel: 4.18 | ASRock Rack E3C224-4L | 32GB ECC RAM | System: Crucial M500(250GB) | LSI 9260-8i - RAID0: 2x Samsung 850 EVO (250GB) + 2x Intel SSD (230G) | LSI 9270-8i - 6x WD Red 6 TB RAID5
    • I reencoded my collection to mkv containing h265 and ac3 sound and they all play fine, no idea if/how plex caused mkvs containing mpeg-4 video to stop working but that is what looks like happened.
      I doubt that this issue is specific to OMV.

      If no one else has a similar issue in OMV I can set the thread as resolved?
      HP N40L microserver | OMV 1.19 (Kralizec) | OMV extras 1.34 | kernel 3.16.0-0.bpo.4-amd64
    • @ryecoaaron
      The problem with the plex database not running from the data disk has been fixed in OMV 3.x. The fix will be in the plugin with openmediavault-plexmediaserver version 3.1.

      sed -i "s#${PLEX_HOME}#${DB_FOLDER}#" /etc/systemd/system/plexmediaserver.service

      Some people have complained that the data disk location is slow. They are not optimizing their database.
      When you are at the home location in the Plex UI click on the 3 dots to the right of "Libraries". Then click on optimize. It makes a big difference.

      PS- The Ubuntu upgrade packages that you can download from the Plex UI work fine now too!

      The post was edited 4 times, last by tekkb ().

    • Generally editing systemd unit files is not a good idea. They don't work identically to init files. There should be a defaults or environment file to change. Have you tried disabling (systemctl disable plexmediaserver.service) and then re-enabling the service to see if the changes persist?
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • It is persistent through disable and enable. It is also persistent through upgrades. You cannot control the Ubuntu package. If they do not provide a defaults or environment file this is the best solution. The unit file is loaded and changing it does not effect anything running until a systemctl daemon-reload. I don't think it is much different than an init file update-rc.d -f remove / update-rc.d defaults.

      Anyway, I tested it a lot yesterday. It is stable and works great. I should also note the service is stopped when changes are being made to the unit file by the mkconf file too.
    • digitalocean.com/community/tut…temd-units-and-unit-files

      If you wish to modify the way that a unit functions, the best location to do so is within the/etc/systemd/system directory. Unit files found in this directory location take precedence over any ofthe other locations on the filesystem. If you need to modify the system's copy of a unit file, putting a replacement in this directory is the safest and most flexible way to do this.


      Aaron, there is also something called "drop-in snippets" that can be used to override lines in the unit files.

      The post was edited 1 time, last by tekkb ().

    • You still don't want to edit the .service file with the plugin. Because it was changed, uninstalling the plugin won't remove it. This could cause other issues with this unit file still hanging around.

      I looked at the plex .deb. It has a default file and all of the environment variables look in the default file. Leaving the default file hanging around wouldn't hurt anything. The plugin should write the complete default file (/etc/default/plexmediaserver) instead of sed'ing the unit file. I did this with the calibre plugin.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • @ryecoaaron
      OK, I tested the /etc/default/plexmediaserver location. It did not work just as I suspected. They have not made changes yet that will work in systemd. A change in library path in the default file will not make adjustments to the unit file. I did a stand alone install. This did work in Wheezy but not Jessie.

      Uninstalling via the plugin section removes the plugin and the plexmediaserver package, the unit file and symlinks. The only thing I noticed that did not get removed was the plex user. I tested plex user with default and new data disk location with the change in the /etc/default/plexmediaserver. No go.... On reinstall the old plex user existing would cause a problem. Need to make sure this user is deleted on uninstall of plugin or do test if user exists in postinst and make sure home is /var/lib/plexmediaserver. Best to make sure it is deleted on uninstall.

      BTW, I searched plexmediaserver with the locate plugin. Some things came up, but they were already deleted. I had to do "updatedb" in command line before I saw everything was deleted in the plugin. It would be nice if there was a button in the locate plugin to do a "updatedb".

      PS- On the standalone install with no plugin the plex user did not delete on purging, as I expected.

      The post was edited 1 time, last by tekkb ().