How to install Seafile with MySQL and SSL

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • tinh_x7 wrote:

      updating seafile-server-latest symbolic link to /opt/seafile/seafile-server-5.1.3 ...
      You obviously didn't run the right script. This script does not automatically download and update to the newest version.
      You have to download and extract the new version, as @Zoki already said.

      For the upgrade, you have to run the seafile script of the new version, inside the new directory.
      In this case:

      ../seafile-server-5.1.4/upgrade/
      OMV 3.x | Banana PI (M1) | | | Seafile Server
      OMV 4.x | ShuttlePC SH55J2

      The post was edited 2 times, last by sieben ().

    • Hi,
      thanks for this guide.

      But I have a problem choosing the right directory for seafile-data.

      Brainfuck Source Code

      1. ---------------------------------
      2. This is your configuration
      3. ---------------------------------
      4. server name: Seafile
      5. server ip/domain: 192.168.178.46
      6. seafile data dir: /media/[UUID]/seafile/seafile-data
      7. fileserver port: 8082
      8. database: create new
      9. ccnet database: ccnet-db
      10. seafile database: seafile-db
      11. seahub database: seahub-db
      12. database user: root
      13. ---------------------------------
      14. Press ENTER to continue, or Ctrl-C to abort
      15. ---------------------------------
      16. Generating ccnet configuration ...
      17. done
      18. Successly create configuration dir /home/seafile/ccnet.
      19. Generating seafile configuration ...
      20. Directory /media/[UUID]/seafile/seafile-data cannot be created.
      21. Error: Failed to generate ccnet configuration
      Display All
      How can i get my data-directory on my harddrive and not on the system-SSD. There it puts all my data, when I upload something to my seafile
    • I love this community. I've been running OwnCloud 7 since it was released but I've been hearing that Seafile is much better. With no official support anytime near I decided to try Seafile on my VmWare server and no matter what Linux distro I used or guides online I just couldn't get it to work. Then I said hell I'll put it on OMV using your guide and there was not a single issue. Well there is one, for some reason even though I have a valid SSL Certificate from StartSSL the client fails to connect unless I check the box "do not verify certificate" which is odd. Oh well, it's working and now I can do testing.

      Thank you for the great work! Hopefully this is much easier to update than OwnCloud, which is really why I moved on.
    • tinh_x7 wrote:

      Let's Encrypt is better than StartSSL, and OMV has a plugin for it too.
      NextCloud has more features and friendlier than Seafile.
      Thanks tinh_x7! I'll give the Let's Encrypt plugin a try. Seafile appears to be much faster than my OwnCloud7 so far from my testing, though the newer NextCloud version probably has improvements. I'll give it a try and compare.
    • Keep in mind to stop seafile,
      extract the downloaded file with the specific user,
      use the upgrade script from the /upgrade directory from the previously extracted folder (e.g. upgrade_5.1_6.0.sh to upgrade from 5.1.3 to 6.0.3)
      check all file permissions
      start seafile.

      and your done.
      OMV 3.x | Banana PI (M1) | | | Seafile Server
      OMV 4.x | ShuttlePC SH55J2
    • to you nice mentors :)

      i would just like to share how i got around installing seafile on an odroid c2 (64 bit aarch8) which has failed as i mentioned on post 71 on this thread...


      1) installed omv 3.0.13 ISO for odroid c2, and run apt-get update , however there was an error .... NO_PUBKEY 7AA630A1EDEE7D73 that came out...
      I did not get the key and left it as it is, because, if i get the key with.

      apt-key adv --keyserver keyserver.ubuntu.com --recv EDEE7D73

      i could not install plugins anymore.

      Moreso, if I ran apt-get upgrade, it breaks the omv webui and i could not log-in.


      2) to get around the error no2 on seafile installation (the 64 bit/32 bit conundrum), i got the idea from here

      did this...

      dpkg --add-architecture armhf

      apt-get update


      3) a preferences file had to be written, because, the first time i tried this installation, omv broke again, so i copied this procedure from here

      did this...

      nano /etc/apt/preferences

      copy and paste then save this script...

      Source Code

      1. Package: *
      2. Pin: release n=jessie
      3. Pin-Priority: 600
      then..

      apt-get update



      4) i then installed libselinux for armhf(32bit) because the second time i tried installing seafile, i got an error...

      /seafile/seafile-server-1.6.0/seafile/bin/ccnet-init: error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory


      so then i tried this...

      apt-get install libselinux1:armhf

      then...

      apt-get update




      After which i continued with the rest of the tutorial on page 1 of this thread.....


      the only hitch i encountered this time was when i issued this from the tutorial...

      /etc/init.d/seafile-server restart


      i get this message from the terminal...


      sudo: unable to resolve host openmediavault


      don't know why,...

      so i tried the following anyway, and i don't know if it is correct...


      service seafile-server restart



      and wooooohooooo!!!!!! it wooooorks!!!!! :)


      thanks very much again!!!!!!
      Images
      • Screen Shot 2016-09-17 at 6.59.35 PM.png

        72.62 kB, 1,352×654, viewed 214 times

      The post was edited 3 times, last by imcv ().