Having trouble installing backports kernel 3.16.0-0.bpo.4-amd64 via OMV-Extras as well as manually

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Having trouble installing backports kernel 3.16.0-0.bpo.4-amd64 via OMV-Extras as well as manually

      Hello people,

      I am building a new server (based on ASrock N3700-ITX motherboard, 16GB RAM, Samsung 850 EVO 120GB OS HDD). Because of UEFI I first installed Wheezy 7.9 (netinst) and on top of that OMV (2.2.1). Now I'm not new to OMV, this is the second system I've built. But still I'm not a Linux/Debian expert command line ninja.

      OMV is running perfectly. But because I'm running "new" hardware I want to install backports kernel 3.16.0-0.bpo.4-amd64 for increased HW compatability.

      So first I installed OMV-Extras plugin, because this would be the most easy solution to install backports kernel. When I click on the kernel tab in OMV-Extras the "Install Backports kernel" button is not showing a kernel version number, which I found suspicious. When I click it the screen pops up, but nothing happens.

      Then I started trying to install it manually. I added "deb ftp.debian.org/debian/ wheezy-backports main non-free contrib" to /etc/apt/sources.list. Apt-get update is running fine, "apt-cache search linux-image" is showing the backports kernels. When I try to install the kernel via "apt-get -t wheezy-backports install linux-image-3.16.0-0.bpo.4-amd64" it shows an error that initramfs-tools is an older version and will not be updated. I tried updating initramfs-tools aswell, via same "apt-get -t wheezy-backports install" command, but then it says that I already have the latest version (0.9.3 or something, I believe).

      So does anybody know what I'm doing wrong ? All the commands I tried were ran as root. Or how can I fix OMV-Extras ?

      Off course I can provide more help/information when needed :)

      Thanks in advance.
    • I wouldn't add the backports repo in sources.list. There should already be a backports.list file in /etc/apt/sources.list.d/.

      So, do:
      apt-get update
      Then
      apt-get -t wheezy-backports install linux-base initramfs-tools=0.115~bpo70+1
      apt-get -t wheezy-backports install linux-image-3.16.0-0.bpo.4-amd64 linux-headers-3.16.0-0.bpo.4-amd64 firmware-linux firmware-linux-free
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!