System resumes directly after autoshutdown performs suspend

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • System resumes directly after autoshutdown performs suspend

      Hi,
      I have a clean installation of OMV and was trying to use Autoshutdown.
      I have configured it so it seems to init a suspend to RAM. But everytime it goes to sleep it seems to wakeup only a few seconds later. At least I am seeing new entries in the autoshutdown log. (See attachment)

      I want to wake the system up at some time of my choice, but not automatically this way ^^
      Are you having any idea on how to find out, what causes this auto-resume? Or maybe it's something else I am not seeing here...

      Cheers Maik
      Images
      • Ember Library Mediator.png

        260.69 kB, 1,996×982, viewed 295 times
    • I would make sure you are running the backports kernel (new, better suspend support) and I would check your bios/efi settings.
      omv 4.1.4 arrakis | 64 bit | 4.15 backports kernel | omvextrasorg 4.1.4
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Things having to deal with sleep/suspend/etc. Not saying something is wrong but just thought the settings should be checked.
      omv 4.1.4 arrakis | 64 bit | 4.15 backports kernel | omvextrasorg 4.1.4
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • OK, will check that.
      In the meanwhile I have used

      Source Code

      1. tail -f /var/log/pm-suspend.log


      while executing

      Source Code

      1. pm-suspend


      and it brings me the following. Seems like at 21:33:14 suspend was successful and 4 seconds later it gets awake. Or does the entry mean suspend action returned with code "awake" and it tries to resume?

      Source Code

      1. ...
      2. /usr/lib/pm-utils/sleep.d/99video suspend suspend: success.
      3. Running hook /etc/pm/sleep.d/autoshutdown-restart suspend suspend:
      4. root autoshutdown [2175]: hibernate/suspend: autoshutdown-script stop from /etc/pm/sleep.d/autoshutdown-restart
      5. autoshutdown stopping
      6. .
      7. .
      8. /etc/pm/sleep.d/autoshutdown-restart suspend suspend: success.
      9. So 6. Mär 21:33:14 CET 2016: performing suspend
      10. So 6. Mär 21:33:18 CET 2016: Awake.
      11. So 6. Mär 21:33:18 CET 2016: Running hooks for resume
      12. Running hook /etc/pm/sleep.d/autoshutdown-restart resume suspend:
      13. root autoshutdown [2195]: thaw/resume: autoshutdown-script restart from /etc/pm/sleep.d/autoshutdown-restart
      14. Restarting autoshutdown: /usr/local/bin/autoshutdown.sh
      15. There seems to be no running process of autoshutdown: /usr/local/bin/autoshutdown.sh
      16. .
      17. /etc/pm/sleep.d/autoshutdown-restart resume suspend: success.
      18. ...
      Display All
    • subzero79 wrote:

      Do you have a network card Realtek? If so, does it have WOL enabled ?

      the card can be checked with lspci -nn


      Source Code

      1. root@openmediavault:~# lspci -nn
      2. 00:00.0 Host bridge [0600]: Intel Corporation Device [8086:190f] (rev 07)
      3. 00:01.0 PCI bridge [0604]: Intel Corporation Device [8086:1901] (rev 07)
      4. 00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:1902] (rev 06)
      5. 00:14.0 USB controller [0c03]: Intel Corporation Device [8086:a12f] (rev 31)
      6. 00:16.0 Communication controller [0780]: Intel Corporation Device [8086:a13a] (rev 31)
      7. 00:17.0 SATA controller [0106]: Intel Corporation Device [8086:a102] (rev 31)
      8. 00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:a114] (rev f1)
      9. 00:1c.7 PCI bridge [0604]: Intel Corporation Device [8086:a117] (rev f1)
      10. 00:1d.0 PCI bridge [0604]: Intel Corporation Device [8086:a118] (rev f1)
      11. 00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:a148] (rev 31)
      12. 00:1f.2 Memory controller [0580]: Intel Corporation Device [8086:a121] (rev 31)
      13. 00:1f.3 Audio device [0403]: Intel Corporation Device [8086:a170] (rev 31)
      14. 00:1f.4 SMBus [0c05]: Intel Corporation Device [8086:a123] (rev 31)
      15. 03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 15)
      Display All


      WOL is enabled:

      Source Code

      1. root@openmediavault:~# sudo ethtool eth0
      2. Settings for eth0:
      3. Supported ports: [ TP MII ]
      4. Supported link modes: 10baseT/Half 10baseT/Full
      5. 100baseT/Half 100baseT/Full
      6. 1000baseT/Half 1000baseT/Full
      7. Supported pause frame use: No
      8. Supports auto-negotiation: Yes
      9. Advertised link modes: 10baseT/Half 10baseT/Full
      10. 100baseT/Half 100baseT/Full
      11. 1000baseT/Full
      12. Advertised pause frame use: Symmetric Receive-only
      13. Advertised auto-negotiation: Yes
      14. Link partner advertised link modes: 10baseT/Half 10baseT/Full
      15. 100baseT/Half 100baseT/Full
      16. 1000baseT/Full
      17. Link partner advertised pause frame use: Symmetric
      18. Link partner advertised auto-negotiation: Yes
      19. Speed: 1000Mb/s
      20. Duplex: Full
      21. Port: MII
      22. PHYAD: 0
      23. Transceiver: internal
      24. Auto-negotiation: on
      25. Supports Wake-on: pumbg
      26. Wake-on: g
      27. Current message level: 0x00000033 (51)
      28. drv probe ifdown ifup
      29. Link detected: yes
      Display All
    • I can speak for me, as I have also a Realtek card, this is "normal" behaviour. Shitty driver ? Probably. To the day I still don't know if this is a problem with the kernel module or the card blob firmware. I also haven't check upstreamif this has been patched so that I can backport it.

      If you can live without WOL, try to disable in bios and in the network setting in omv. See if it behaves properly.
      if you have a spare pcie slot, try and get and Intel card.
      i dont use auto shutdown , but my server goes to suspend at certain tIme, I have to schedule the job twice under two minutes for it to go down.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • subzero79 wrote:

      I can speak for me, as I have also a Realtek card, this is "normal" behaviour. Shitty driver ? Probably. To the day I still don't know if this is a problem with the kernel module or the card blob firmware. I also haven't check upstreamif this has been patched so that I can backport it.

      If you can live without WOL, try to disable in bios and in the network setting in omv. See if it behaves properly.
      if you have a spare pcie slot, try and get and Intel card.
      i dont use auto shutdown , but my server goes to suspend at certain tIme, I have to schedule the job twice under two minutes for it to go down.


      Will this still be a problem with OMV 3.x? Or might that be fixed there (newer drivers available...?)
      Autoshutdown would be great for a NAS Media Server running only when needed (wol) and suspending when not :(
      I will check tomorrow if disabling WOL in BIOS will have an effect on suspending.
    • barzille wrote:

      system


      If the system is shutdown, how is going to log?
      this is not a problem with something sending wol packets, is a bug in the card.
      Sometimes can happen if you have kodi, and you leave a movie paused overnight then the server is next day awake, because kodi sent wol package because it is instructed to do so.

      if you want log wol packets you have run tcpdump n the bridge switch interface in the router
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server