Failing to install OMV Extra plugins

  • OMV 3.x

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Failing to install OMV Extra plugins

    I'm trying to install plexmediaserver plugin, and am seeing some odd behaviour.

    I picked & installed OMV extras plugin. I turned-on plex. Everything seemed to install fine. Except, even after rebooting, I see no "plex" service.
    I only see this. Notice OMV-Extras.org installed, Plex activated, yet not "Plex" in services.




    Reading some threads here, and knowing that when I installed OMV 3.0, I only had one drive, which I repartioned after installation, I suspect that maybe something I did screwed the extras plugin setup? For example, when I go to "System Information", I get:

    Error #6000:
    exception 'OMVException' with message 'No filesystem backend exists for '34167f13-cfd5-4c1f-ac5b-9708071c2d18'' in /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc:226
    Stack trace:
    #0 [internal function]: OMVRpcServiceFileSystemMgmt->enumerateMountedFilesystems(Array, Array)
    #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('enumerateMounte...', Array, Array)
    #3 /usr/sbin/omv-engined(494): OMVRpc::exec('FileSystemMgmt', 'enumerateMounte...', Array, Array, 1)
    #4 {main}


    fdisk -l shows:

    Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: dos
    Disk identifier: 0x75454cdf
    Device Boot Start End Sectors Size Id Type
    /dev/sda1 * 2048 102402047 102400000 48.8G 83 Linux
    /dev/sda2 3876857854 3907028991 30171138 14.4G 5 Extended
    /dev/sda3 102402048 3876855807 3774453760 1.8T 83 Linux
    /dev/sda5 3876857856 3907028991 30171136 14.4G 82 Linux swap / Solari
    Partition 3 does not start on physical sector boundary.
    Partition table entries are not in disk order.

    If I install plexmedia server manually (ssh + apt-get install), then I get plex working fine. But really would be nice to get it working through OMV. I'm learning a lot of this stuff here, so I'm not ruling out any stupidity on my part that I can't remember!

    Any tips / thoughts ?
    Images
    • Screen Shot 2016-03-16 at 9.35.59 PM.png

      57.55 kB, 350×396, viewed 950 times