Help samba sharing with windows

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Help samba sharing with windows

      Hi,I've installed omv2.2.1 in my raspberry and I'm trying to set up samba in the OMV WebGUI (I'm under wifi and ethernet cable lan with pc and also raspberry, I can access under ssh) :

      Source Code

      1. #======================= Global Settings =======================
      2. [global]
      3. workgroup = WORKGROUP
      4. server string = %h server
      5. dns proxy = no
      6. log level = 0
      7. syslog = 0
      8. log file = /var/log/samba/log.%m
      9. max log size = 1000
      10. syslog only = yes
      11. panic action = /usr/share/samba/panic-action %d
      12. encrypt passwords = true
      13. passdb backend = tdbsam
      14. obey pam restrictions = yes
      15. unix password sync = no
      16. passwd program = /usr/bin/passwd %u
      17. passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *pas$
      18. pam password change = yes
      19. socket options = TCP_NODELAY IPTOS_LOWDELAY
      20. guest account = nobody
      21. load printers = no
      22. disable spoolss = yes
      23. printing = bsd
      24. printcap name = /dev/null
      25. unix extensions = yes
      26. wide links = no
      27. create mask = 0777
      28. directory mask = 0777
      29. use sendfile = yes
      30. aio read size = 16384
      31. aio write size = 16384
      32. null passwords = no
      33. local master = yes
      34. time server = no
      35. wins support = no
      36. #======================= Share Definitions =======================
      37. [Videoteca]
      38. path = /media/01D1400460B1FFE0/Videoteca/
      39. guest ok = no
      40. read only = no
      41. writeable = yes
      42. browseable = yes
      43. inherit acls = yes
      44. inherit permissions = yes
      45. ea support = yes
      46. store dos attributes = yes
      47. printable = no
      48. create mask = 0777
      49. force create mode = 0777
      50. directory mask = 0777
      51. force directory mode = 0777
      52. hide dot files = no
      53. valid users = "Davide","pi",@"gpio",@"indiecity",@"pi",@"spi"
      54. invalid users =
      55. read list = "Davide","pi",@"gpio",@"indiecity",@"pi",@"spi"
      56. write list = "Davide","pi",@"gpio",@"indiecity",@"pi",@"spi"
      Display All

      but in windows 8 I can't see files in the volume .../Videoteca/.
      Windows 8 "understands" that the volume is not empty but I can't see or read files.. help
      Images in the Attachments.
      I also tried to set the folder <public>, and readable by everyone(Administrators:read/write Users:read/write Others:read/write) but the problem remains.
      Images
      • 1.JPG

        36.34 kB, 592×412, viewed 344 times
      • 2.JPG

        57.42 kB, 765×485, viewed 309 times
      • 3.JPG

        57.39 kB, 740×409, viewed 288 times
      • 4.JPG

        51.98 kB, 736×514, viewed 335 times
      • 5.JPG

        37.11 kB, 666×335, viewed 302 times
      • 6.JPG

        25.45 kB, 764×220, viewed 292 times
      • 7.JPG

        116.52 kB, 1,085×738, viewed 302 times

      The post was edited 3 times, last by falena ().

    • Yes I know but it (ext4 or ext3) would require a day's work..

      Source Code

      1. ​root@raspberrypi:~# ls -la /media/01D1400460B1FFE0/Videoteca
      2. total 12
      3. drwxrwxrwx 1 root root 0 Jul 9 2015 .
      4. drwxrwxrwx 1 root root 12288 Dec 6 19:16 ..
      5. root@raspberrypi:~# cat /etc/fstab
      6. proc /proc proc defaults 0 0
      7. /dev/mmcblk0p1 /boot vfat defaults 0 2
      8. /dev/mmcblk0p2 / ext4 defaults,noatime,nodiratime 0 1
      9. # a swapfile is not a swap partition, so no using swapon|off from here on, use dphys-swapfile swap[on|off] for that
      10. # >>> [openmediavault]
      11. UUID=fa36508a-b3c4-4499-b30a-711dd5994225 /media/fa36508a-b3c4-4499-b30a-711dd5994225 ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
      12. /dev/disk/by-uuid/01D1400460B1FFE0 /media/01D1400460B1FFE0 ntfs defaults,nofail 0 2
      13. # <<< [openmediavault]
      14. root@raspberrypi:~#
      Display All
    • I asked you to post ls -la to see the permissions on the folder and above. Both are wide open to everyone bit there are no contents in that folder, did you chopped the output?
      The folder is empty, what do you expect in widows then?
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • The folder is not empty, I shared the folder correctly? Must I put manually /dev/sda1/ ? (If I select "Videoteca" from tree, it writes "/Videoteca")
      PS output is not chopped
      Images
      • 1.JPG

        38.07 kB, 939×231, viewed 219 times
      • 2.JPG

        71.58 kB, 1,068×642, viewed 237 times

      The post was edited 1 time, last by falena ().

    • TThere are no contents in the folder videoteca as you posted here the results of the directory contents of that folder.
      Go there to the folder in cli and examine it by yourself. If you want to share the whole drive create shared folder with a slash(/) instead of a folder name in path
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server