Sickbeard permissions

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Sickbeard permissions

      Hi,

      I'm installing sickbeard.
      I'm configuring it to search my tv shows. That's ok. It found it.

      But when I try to search an episode. I have an error "Problem setting permissions or writing file to: /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d/seedbox/torrents/Homeland.S03E01.FRENCH.LD.HDTV.XviD-MiND.torrent"


      My system:
      OMV 2.2.2
      2 x 3TB WD REDSnapraid + AUFS (An another disk of 3TB go to WD, it was KO :( )

      a4e489c6-f650-4663-ba6d-74dc0e14b23d : Disk Data of aufs

      I can't configure sickbeard with the pool. I don't know why. Probably an another problem with permissions.
    • Let's see if I understand correctly.
      /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d
      is the AUFS mountpoint where your 2 WD RED are pooled?

      For what I can guess, your torrent client is configured in blackhole mode, right?


      Can you ssh on your server and give us the output of the following command :

      Source Code

      1. ls -al /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d/seedbox/torrents

      Use pastebin to post the output.

      I can't configure sickbeard with the pool. I don't know why. Probably an another problem with permissions.


      You mean the root directory for sickbeard? What repo are you using? You might consider using a more recent/active fork like sickrage or sickgear.
    • Let's see if I understand correctly./media/a4e489c6-f650-4663-ba6d-74dc0e14b23d
      is the AUFS mountpoint where your 2 WD RED are pooled?


      No, /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d is the data of aufs

      Source Code

      1. http://pastebin.com/usCM5dhJ



      The pool is /media/7737fd82-2283-45db-a9c9-9d8efe0078d3/

      Source Code

      1. http://pastebin.com/EUsVj5Vv


      I put here the same command for this folder.

      ​For what I can guess, your torrent client is configured in blackhole mode, right?


      I just want download the torrent in blackhole mode. I push the torrents after to my torrent client.

      You mean the root directory for sickbeard? What repo are you using? You might consider using a more recent/active fork like sickrage or sickgear.


      I use this github.com/SickRage/SickRage.git

      The post was edited 1 time, last by Jesse ().

    • Ok, thats effectively a permissions problem on the first path. Your directories are owned by root:root, and so only root as write access.Could you pastebin the result of this command

      Source Code

      1. cat /etc/fstab

      so I can fully help you out.


      Source Code

      1. # /etc/fstab: static file system information.
      2. #
      3. # Use 'blkid' to print the universally unique identifier for a
      4. # device; this may be used with UUID= as a more robust way to name devices
      5. # that works even if disks are added and removed. See fstab(5).
      6. #
      7. # <file system> <mount point> <type> <options> <dump> <pass>
      8. # / was on /dev/sdb1 during installation
      9. #UUID=7c18b68b-d5ed-4e47-92c2-d90f80b5e0f5 / ext4 errors=remount-ro 0 1
      10. UUID=7c18b68b-d5ed-4e47-92c2-d90f80b5e0f5 / ext4 noatime,nodiratime,errors=remount-ro 0 1
      11. # swap was on /dev/sdb5 during installation
      12. #UUID=509c56dc-d345-49f7-855e-46bc625b38b0 none swap sw 0 0
      13. /dev/sda1 /media/usb0 auto rw,user,noauto 0 0
      14. /dev/sdb1 /media/usb1 auto rw,user,noauto 0 0
      15. /dev/sdb2 /media/usb2 auto rw,user,noauto 0 0
      16. /dev/sdb5 /media/usb3 auto rw,user,noauto 0 0
      17. # >>> [openmediavault]
      18. UUID=92e9708e-952d-468d-9384-4c37403576c6 /media/92e9708e-952d-468d-9384-4c37403576c6 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
      19. UUID=a4e489c6-f650-4663-ba6d-74dc0e14b23d /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
      20. UUID=b0b8c166-3284-4724-bff2-3843146f1713 /media/b0b8c166-3284-4724-bff2-3843146f1713 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
      21. UUID=dc04934f-2933-4248-a7a4-a1eb807d60d3 /media/dc04934f-2933-4248-a7a4-a1eb807d60d3 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
      22. none /media/7737fd82-2283-45db-a9c9-9d8efe0078d3 aufs br:/media/92e9708e-952d-468d-9384-4c37403576c6=rw:/media/a4e489c6-f650-4663-ba6d-74dc0e14b23d=rw:/media/b0b8c166-3284-4724-bff2-3843146f1713=rw,sum,create=mfs 0 0
      23. /media/7737fd82-2283-45db-a9c9-9d8efe0078d3/videos/animes /export/animes none bind 0 0
      24. /media/7737fd82-2283-45db-a9c9-9d8efe0078d3/videos/films /export/films none bind 0 0
      25. /media/7737fd82-2283-45db-a9c9-9d8efe0078d3/videos/series /export/series none bind 0 0
      26. # <<< [openmediavault]
      Display All

      I try to connect with my user but. I can't access nothing

      Thanks for you help.
    • Ok, I get it know.
      First, I strongly suggest you to change your aufs for a mergerfs pool. mergerfs is more recent and active, and more reliable.

      Then for it to work properly, permissions are to be corrected.
      You may have to do this for the other 2 drives that are pooled in aufs (/media/92e9708e-952d-468d-9384-4c37403576c6
      and /media/b0b8c166-3284-4724-bff2-3843146f1713[/code]

      Following commands are to be executed as root.
      First we will correct ownership to root:users, as it should be for all your data drive for OMV to work correctly.

      Source Code

      1. chown -R root:users /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d

      This change ownership recursively (-R flag)

      Then we will fix permissions as follow :

      Source Code

      1. find /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d -type d -exec chmod 775 '{}' \;
      2. find /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d -type d -exec chmod g+s '{}' \;
      3. find /media/a4e489c6-f650-4663-ba6d-74dc0e14b23d -type f -exec chmod 664 '{}' \;

      1st : Directories are set to rwx for root, rwx for group users and rx only for others.
      2nd : We set the groupuid bit for all directories, to ensure that future files are owned by group users.
      3rd :Files are set to rwx for root, rw for group users and r only for others.