Audio Stuttering when Harddrive spins up

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Audio Stuttering when Harddrive spins up

      Hello everybody,

      first sorry for my bad englisch, i try my best and hope you can understand my problem.
      I hope when i write in english more people can help me...

      First my system specs:
      Asrock N3150-ITX
      2x 4GB Kingston KVR16LS11/4
      1x SanDisk SSD 64GB
      1x 1TB WD Green
      2x 4TB WD Red
      Cougar 350W ATX

      Software: OMV 2.2.2 with installed Backport Kernel
      NoRaid

      So on my small 1TB WD Green my music is located. On the other WD Red's i have saved movies and so on..
      I access my nas via my Win10 PC.

      I often listen to music with Foobar which is configured to access my nas smb shares.
      So far so good , everything is fine. My other hd's spindown after 30 minutes, if there is no need. Again this is fine, too.

      Now when i access one hd which is in sleep mode and simultaneously listen to music , my music hangs for 3-4 seconds.
      This is reproducible.

      What i have tried to fix this:

      - Music saved on an other harddrive - doesn't fix
      - Access from an other PC with Win10 - same problem, music hangs for 3-4 seconds on this pc
      - changed LAN cable - doesn't fix
      - direct connection to nas from my pc, normaly my pc is connected to my switch - doesn't fix
      - tried the same with an amd fm1 system ( mainboard + cpu + ram ). the rest of the components i used from my system ( see above ) - same problems exists even on my amd system ?? wtf ??

      you see i tried many options without success...

      But when i now spinup my hds over the omv webinterface with "extplorer plugin" while i'm listen to music i have no music lags.

      So there must be something wrong with the samba plugin... but why others doesn't have these lags, only me ?

      In the other german forums no one can help me.
      This is very disappointing.

      I hope someone can understand my "english" ( sorry i'm from germany ;) ) and can help ?

      Many thanks in advance!
    • I don't think there is anything wrong other than maybe the drive. Some drives spin up faster than others. Also, I think most drives spin up when people are searching for music, the drive spins up. So, they never hear it. You probably only have this happen once each time you listen?? Is it that big of a deal? Don't spin down your drive if it is that big of an issue.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • i think you don't understand me.

      the hd which i play music from is always on. the other hds going in sleep if no need.
      and if i wake one of this sleeping hds, my music and network connection hangs for 3-4 seconds.
      this don't happen if wake the hds directly over the omv webinterface and not over a smb file share.
      so i think samba does something which causes the lags when the hds spin up.

      yes for sure i could deactivate the spin off for all hds to solve this "problem" , but then power consumption and noise rises when all hds running all the time ?
      In all guides i have read it would be prefered to set a spindown time for the hds , so other people must have the problem, too ?

      Sorry again for my english , i hope you understand me.
      Thanks for your help.
    • That makes more sense. It isn't samba causing the problem. Sounds like the system pauses/freezes for a few seconds while the drive is starting up. I have never had this happen. Maybe it is a driver issue? I would try the backports kernel (there is a button in omv-extras). If you are already running the backports kernel, you could try an even newer kernel that people build in other threads on this forum.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • but why the system doesnt pauses / freezes when spinup a drive directly over the webinterface of omv ?
      it only happen when wake a drive over the file explorer of windows .

      thats why i think samba causes the problems ...
      i already run the backport kernel but i will look in the forum for a newer kernel and try it.

      another question: its possible to access a nfs share from a windows client ?
    • I have no idea why it does that. Like I said, I haven't heard of anyone else having this issue.

      Pretty sure you can access nfs shares from kodi running on windows. I doubt you can from anything else though.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Ok after some testing i can figure out that it's a windows problem.
      if i hear music and wake my sleeping hds with my android smartphone over smb , music doesnt hang and network traffic doesnt stop .

      so i know with omv is everything ok , but i dont know how i can fix the problem with windows ....
    • jacky wrote:

      i dont know how i can fix the problem with windows ....

      Replace with Linux :)
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • The sacrifice we make :) Music is more important than games. You can play steam on linux. Using Linux Mint wouldn't take many Google searches :)
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Wanted to resurrect this (found via google) as I am experiencing a similar problem today.

      Have a bunch of drives mapped in Win10 using SMB just because it's an easy way to work with my downloads from my server. Drives spin down after 30 minutes but even after I have recently accessed them, when jumping between SMB shares, I get micro-freezes of around 3-5 seconds before the drive can be read. If I play music from a different drive (not even one of the two I am switching between on OMV) the music freezes during this time as well.

      So it's almost like it's not just the 2 drives I'm switching between (again, using SMB shares in Windows) that are freezing, but the entire server (or at least, the entire SMB process) hat is freezing for those few seconds before the song kicks in again.

      It's very weird, and I can't help but think there is a setting somewhere to resolve this, but darned if I know. Using OMV4.