[solved] USB 3.0 slow write speed

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [solved] USB 3.0 slow write speed

      Hello

      I´m running omv on a odroid-xu4 and have two USB 3.0 3TB external hard drives connected. One of the disks has a extrem slow write speed (9MB/s). The other one is totally fine.

      Used commands for the read/write measuring:
      write: dd if=/dev/zero of=tempfile bs=1M count=1024 conv=fdatasync,notrunc
      read: echo 3 | sudo tee /proc/sys/vm/drop_caches
      dd if=tempfile of=/dev/null bs=1M count=1024

      disk-1
      • type: external USB 3.0 3Tb
      • manufacturer: Western Digital
      • purchased: 2009
      • ext4
      • write: 9Mb/s
      • read: 98MB/s
      disk-2
      • type: external USB 3.0 3Tb
      • manufacturer: Seagate
      • purchased: 2016
      • ext4
      • write: 109Mb/s
      • read: 104MB/s

      One year ago I used disk-1 with ntfs on a windows machine. The write speed back then was fine.
      I have absolutely no idea what the problem could be, as disk-2 is working as expected.

      Looking forward on your suggestions.
      mopmop


      [IMG:USB 3.0 read/write speed]
    • The usb to sata controller that WD external uses must have an driver issues with the XU4 kernel. That is a really old USB3 drive that was produced shortly after the standard was released.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!