No directory, loggin in with HOME=/ - This account is currently not available

    • OMV 2.x
    • No directory, loggin in with HOME=/ - This account is currently not available

      Hey, I'm trying to run OMV on my rPi but I'm having problems with logging in. I have downloaded "omv_2.2.1_rpi2_rpi3.img.gz" from " Pi images/" and installed it to my SD card using win32diskimager.

      When I boot the pi and get to the login screen I enter the default user and password and then it displays

      No directory, loggin in with HOME=/
      This account is currently not available

      Then returns to the login screen again. Ive tried wiping the SD card and reinstalling but it still loops back to the log in. Am I missing a step or doing something wrong with the install process?
    • What is the default user? I think the only user I left on the system is root. If the pi user is still on it, don't use it.
      omv 4.1.4 arrakis | 64 bit | 4.15 backports kernel | omvextrasorg 4.1.3 plugins source code and issue tracker -

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • This is how I faced, and solved the issue:

      1. My raspberry pi would boot up.
      2. On the screen it would ask for a user name and password.
      3. I would type in username = admin password = openmediavault, which is the default for the installation.
      4. When I would hit enter, some output would come on the screen but I would be stuck with the login prompt again.
      5. On noticing closely, I found the same 'No directory.... HOME' issue.
      6. I tried a few different login and passwords, including root, this did not work.
      7. On closer inspection I noticed that above the password prompt, the output said:
      Connect to this IP address (not exact text)
      eth04: 169.XX.XX.XX

      A. What you will realise is, the IP address should be 192.168.XXX.XXX
      B. I checked the ethernet cable, and sure enough it was disconnected from the raspberry pi.
      C. Once the ether cable was connected, again I noticed, that the IP address was the same. 169.XXX.XXX
      D. I looked around and saw that my switch, was not connected to the router (Ooops!)
      E. Once we connected the switch to the router, the IP address changed to a 192.168.XXX.XXX
      F. To check if the IPaddress has changed you need to type in admin+openmediavault into the password prompt and wait for new output.

      I hope this helps the next person who is stuck. I have put the same answer here as well:
      New pi user, having issue booting omv