"Something wicked happened resolving 'packages.openmediavault.org:http

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • "Something wicked happened resolving 'packages.openmediavault.org:http

      Hi, I am new to OMV.

      I tried apt-get update and get the error: "Something wicked happened resolving 'packages.openmediavault.org:http' (-5 - No address associated with hostname)"

      In another thread I read to check with "ping -c4 google.com". I get "ping: unknown host google.com".

      I have a router cascade in my network because I offer a seperate network for another flat. DHCP is working, I receive an IP from the DHCP router. I wrote the wrong IP from another router) in the DNS field, first. I now entered the right one and applied the settings, but it is still not working.

      I suspect there might be a problem with the repo address but this repo is not in the /etc/apt/sources.list

      Do I have to change it somewhere else?

      Any help?

      I use OMV 2.2.2

      Cheers,
      Ben
    • This is a DNS issue. Try entering 8.8.8.8 in the dns field and try it.
      omv 4.1.6 arrakis | 64 bit | 4.16 backports kernel | omvextrasorg 4.1.6
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Thanks, I put

      Source Code

      1. 8.8.8.8
      in the DNS-field but now if I try to execute

      Source Code

      1. apt-get update
      it cannot get the lock for

      Source Code

      1. /var/lib/apt/lists/
      . I had this issue several times now after chaning stuff in the web GUI.

      Anyhow, the ping still does not find the host

      Source Code

      1. google.com
      .

      Are you shure this is the right input for the DNS-Server-field? Maybe I have to put my main router in there and then 8.8.8.8 into the next one?
    • It should work if your network is working correctly. The apt lock is because OMV is trying to self update.
      omv 4.1.6 arrakis | 64 bit | 4.16 backports kernel | omvextrasorg 4.1.6
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • I cannot reach the web GUI no more and my router sais the OMV is not any more in the DHCP client list. It is probable that you suggested the wrong field. I guess DNS should be the main router and then 8.8.8.8 might be the second entry, called something like Name server. Now it's not connecting to the network any more. Or is it possible that OMV crashed? I was copying a lot of files parallel from two servers to the new OMV RAID.
    • thanks for the reply! I cannot ping google from the OMV server. I can ping it from a PC that is in the same network. I have a router cascade and port forwardings to my other server, a synology. But since the ping works from my PC it should not make a difference. So it must be within the OMV server settings, right? I have DHCP activated and got the same IP every time now, although it is not a reserved one on the router. In the OMV settings the IP, netmask and gateway are greyed out with DHCP chosen. Strangely, however, the grey IP adress I see is a different one from the one I use to access the server. It is 192.168.11.170 while I use the web GUI and samba over 192.168.11.102. Maybe I should change from DHCP to a fixed IP.
    • thanks for the reply!

      root@omv:~# cat /etc/network/interfaces
      # The loopback network interface
      auto lo
      iface lo inet loopback

      # eth0 network interface
      auto eth0
      allow-hotplug eth0
      iface eth0 inet dhcp
      dns-nameservers 192.168.11.1
      dns-search omvlocal
      pre-down ethtool -s $IFACE wol g
      iface eth0 inet6 manual
      pre-down ip -6 addr flush dev $IFACE

      Router client list shows 192.168.11.102, the IP i use to access it, not the one OMV displays in the GUI.
    • I put "8.8.8.8" into "search domains", and let "DNS server" stay at the gateway which is "192.168.11.1".

      brings me to this:

      root@omv:~# cat /etc/network/interfaces
      # The loopback network interface
      auto lo
      iface lo inet loopback

      # eth0 network interface
      auto eth0
      allow-hotplug eth0
      iface eth0 inet dhcp
      dns-nameservers 192.168.11.1
      dns-search 8.8.8.8
      pre-down ethtool -s $IFACE wol g
      iface eth0 inet6 manual
      pre-down ip -6 addr flush dev $IFACE

      Still no ping to google.com