Samsung SSD 850 EVO & FPDMA Queued & exception Emask 0x10 SAct errors

    • OMV 2.x
    • Resolved
    • Samsung SSD 850 EVO & FPDMA Queued & exception Emask 0x10 SAct errors

      I have a new Samsung 850 EVO 120GB drive with EMT02B6Q (factory installed).
      I was getting lots of FPDMA Queued errors which led me to the ubuntu ncq trim thread and issues with Samsung firmware documented in a number if locations.

      I found the solution to the above with the following settings:

      GRUB
      libdata.force=1.00:noncq (add your drive to the linux cmd line)

      FSTAB
      # / was on /dev/sda1 during installation
      UUID=22099637-548b-4155-908f-85de42371452 / ext4 noatime,nodiratime,data=ordered,discard,barrier=1,errors=remount-ro 0 1
      # swap was on /dev/sda5 during installation
      UUID=f1ec1c08-e6cc-4020-82a4-84f857dfd83e none swap sw,noatime,data=ordered,barrier=1,discard 0 0
      tmpfs /tmp tmpfs defaults,noatime,nosuid,mode=1777 0 0

      rc.local
      echo deadline > /sys/block/sda/queue/scheduler
      echo 1 > /sys/block/sda/queue/iosched/fifo_batch

      The above solved the FPDMA Queued errors and I was left with the below.

      In addition, i was getting lots of errors below.
      ata1.00: exception Emask 0x10 SAct 0x0 SErr 0x400000 action 0x6 frozen
      ata1.00: irq_stat 0x08000000, interface fatal error
      ata1: SError: { Handshk }
      ata1.00: failed command: WRITE DMA EXT
      ata1.00: cmd 35/00:00:b8:f9:47/00:04:09:00:00/e0 tag 11 dma 524288 out
      res 50/00:00:b7:f9:47/00:00:09:00:00/e0 Emask 0x10 (ATA bus error)

      The drive was new and the 6Gb/s cables were new as well.
      They were Delock Sata Flex 6Gb/s and rated for 6Gb/s but i found the cable very thin compared to other 6Gb/s cables.

      I replaced them with the standard black thick 6Gb/s cable that comes with most mother boards , and problem was solved.

      As i have PlexMediaServer, MySQL and tomcat application (OpenKM) running,
      i am wondering if there is anything else i have missed to remove from the SSD drive?

      For the first issue:

      The post was edited 1 time, last by gwaitsi ().