failed login after upgrade openmediavault:amd64 from 2.2.2 to 2.2.3

    • OMV 2.x
    • Update
    • failed login after upgrade openmediavault:amd64 from 2.2.2 to 2.2.3

      Hi,

      last 27 April I have update Openmediavaut from 2.2.2 to 2.2.3 after that i have proble of log from web gui.
      i I call the url using fqdn after the post of username and password i get an error of "software error" "wrong username or password" but if I use IP address same username and password all works fine, what has changed and why this problem?
      Anyone have fond this?

      here the log of webgui in the two scenario


      USING FQDN for web gui


      Source Code

      1. root@nas:/var/log/nginx# tail -f openmediavault-webgui_error.log openmediavault-webgui_access.log
      2. ==> openmediavault-webgui_error.log <==
      3. ==> openmediavault-webgui_access.log <==
      4. ::ffff:192.168.1.100 - - [10/May/2016:00:27:24 +0200] "GET / HTTP/1.1" 200 1027 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      5. ::ffff:192.168.1.100 - - [10/May/2016:00:27:24 +0200] "GET /js/omv/util/i18nDict.js HTTP/1.1" 304 0 "http://nas.fiorenzics.lan/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      6. ::ffff:192.168.1.100 - - [10/May/2016:00:27:32 +0200] "GET /extjs/packages/ext-theme-gray/resources/images/grid/invalid_line.gif HTTP/1.1" 200 815 "http://nas.fiorenzics.lan/extjs/packages/ext-theme- gray/resources/ext-theme-gray-all.css" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      7. ::ffff:192.168.1.100 - - [10/May/2016:00:27:36 +0200] "GET /images/exclamation.svg HTTP/1.1" 200 759 "http://nas.fiorenzics.lan/css/omv.css" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 ( KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      8. ::ffff:192.168.1.100 - - [10/May/2016:00:27:42 +0200] "POST /rpc.php HTTP/1.1" 200 79 "http://nas.fiorenzics.lan/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ 50.0.2661.94 Safari/537.36"
      9. ::ffff:192.168.1.100 - - [10/May/2016:00:27:44 +0200] "-" 400 0 "-" "-"
      10. ::ffff:192.168.1.100 - - [10/May/2016:00:27:44 +0200] "-" 400 0 "-" "-"
      11. ::ffff:192.168.1.100 - - [10/May/2016:00:27:44 +0200] "-" 400 0 "-" "-"
      12. ::ffff:192.168.1.100 - - [10/May/2016:00:27:44 +0200] "-" 400 0 "-" "-"
      13. ::ffff:192.168.1.100 - - [10/May/2016:00:27:44 +0200] "-" 400 0 "-" "-"
      Display All



      USING IP ADDRESS INSTEAD OFF FQDN ADDRESS

      Source Code

      1. ::ffff:192.168.1.100 - - [10/May/2016:00:28:51 +0200] "GET / HTTP/1.1" 200 1027 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      2. ::ffff:192.168.1.100 - - [10/May/2016:00:28:51 +0200] "GET /js/omv/util/i18nDict.js HTTP/1.1" 304 0 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      3. ::ffff:192.168.1.100 - - [10/May/2016:00:28:52 +0200] "GET /images/header_logo.svg HTTP/1.1" 200 40577 "http://192.168.1.70/css/omv.css" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTM L, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      4. ::ffff:192.168.1.100 - - [10/May/2016:00:28:52 +0200] "GET /extjs/packages/ext-theme-gray/resources/images/form/text-bg.gif HTTP/1.1" 200 819 "http://192.168.1.70/extjs/packages/ext-theme-gray/resour ces/ext-theme-gray-all.css" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      5. ::ffff:192.168.1.100 - - [10/May/2016:00:28:52 +0200] "GET /images/password-trigger.png HTTP/1.1" 200 2635 "http://192.168.1.70/css/omv.css" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 ( KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      6. ::ffff:192.168.1.100 - - [10/May/2016:00:28:52 +0200] "GET /extjs/packages/ext-theme-gray/resources/images/form/trigger.gif HTTP/1.1" 200 2936 "http://192.168.1.70/extjs/packages/ext-theme-gray/resou rces/ext-theme-gray-all.css" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      7. ::ffff:192.168.1.100 - - [10/May/2016:00:28:54 +0200] "POST /rpc.php HTTP/1.1" 200 78 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2 661.94 Safari/537.36"
      8. ::ffff:192.168.1.100 - - [10/May/2016:00:28:54 +0200] "GET / HTTP/1.1" 200 3041 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      9. ::ffff:192.168.1.100 - - [10/May/2016:00:28:54 +0200] "GET /extjs/packages/ext-theme-gray/resources/ext-theme-gray-all.css HTTP/1.1" 304 0 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      10. ::ffff:192.168.1.100 - - [10/May/2016:00:28:54 +0200] "GET /css/omv.css HTTP/1.1" 304 0 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0 .2661.94 Safari/537.36"
      11. ::ffff:192.168.1.100 - - [10/May/2016:00:28:54 +0200] "GET /extjs/ext-all.js HTTP/1.1" 304 0 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome /50.0.2661.94 Safari/537.36"
      12. ::ffff:192.168.1.100 - - [10/May/2016:00:28:55 +0200] "GET /js/ext-overrides.js HTTP/1.1" 304 0 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chr ome/50.0.2661.94 Safari/537.36"
      13. ::ffff:192.168.1.100 - - [10/May/2016:00:28:55 +0200] "GET /js/js-overrides.js HTTP/1.1" 304 0 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chro me/50.0.2661.94 Safari/537.36"
      14. ::ffff:192.168.1.100 - - [10/May/2016:00:28:55 +0200] "GET /js/omv/util/i18nDict.js HTTP/1.1" 304 0 "http://192.168.1.70/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36"
      15. ......
      Display All

      AND GOING ON

      The post was edited 1 time, last by WastlJ ().

    • Yes i am sure, I have chnaged browser, and computer cleaned cache and all is the same.

      From logs I have posted it is clear that something was wrong when I all web gui using fqdn url.

      I have lost to say I have 2 network interface in bonding, but all works fine before the upgrade. I really do not understant what the upgrade change to take this side effect.

      Thanks
    • Please have a look into /var/log/syslog and post the messages logged during the login action.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • netexpress wrote:

      From logs I have posted it is clear that something was wrong when I all web gui using fqdn url.

      It is hard to read logs from a phone.

      If it works from an IP address, sounds more like a network issue than an OMV issue.
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!