Owncloud - Can't activate after switching to ZFS

    • OMV 2.x
    • Owncloud - Can't activate after switching to ZFS

      Hello Guys,

      Yesterday i decided to upgrade my OMV-System from EXT4 Raid (3 x 5TB WD-Red) to ZFS RAID-Z1.
      Everything worked pretty well. Actually i am transfering my Backup back to my NAS.

      There is just one big Problem.
      Before switching to ZFS i used Owncloud.
      I deinstalled it before removing my old Raid. Now, after installing it again i cant activate it with its Datalocation on my ZFS Raid.

      Source Code

      1. Fehler #3003:
      2. exception 'OMVException' with message 'Failed to get configuration (xpath=//system/shares/sharedfolder[uuid='31d335b3-0909-4610-9d58-34546dfa8c6f'])' in /usr/share/openmediavault/engined/module/owncloud.inc:195
      3. Stack trace:
      4. #0 [internal function]: OMVModuleOwnCloud->setSharedFolderFacl(Array)
      5. #1 /usr/share/php/openmediavault/module.inc(146): call_user_func_array(Array, Array)
      6. #2 /usr/share/openmediavault/engined/module/owncloud.inc(65): OMVModuleAbstract->execTasks('setfacl')
      7. #3 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleOwnCloud->applyConfig()
      8. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      11. #7 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      12. #8 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      13. #9 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      14. #10 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      15. #11 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      16. #12 {main}
      Display All


      I already reinstalled it, but the Error stays.

      Any Suggestions?


      Thanks and good Morning
      Christian

      PS: Systeminformation:
      Version 2.2.3, Kernel 3.16.0
      All Updates done
    • I don't use owncloud but owncloud doesn't seem to like your shared folder. If you are using the plugin, you may have to switch to manually installed or a docker. The plugin is not supported anymore and will not be available in OMV 3.x
      omv 4.0.11 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!