[SOLVED] Can't Mount NFS Share on Client

    • [SOLVED] Can't Mount NFS Share on Client

      I'm using OMV-0.4.15 and having trouble mounting the NFS share on my Ubuntu 12.10 client. I can browse to the share using the "nfs://IP" method, but cannot mount using fstab or by hand via the CLI.

      Here is my /etc/exports from OMV:

      Source Code

      1. # /etc/exports: the access control list for filesystems which may be exported
      2. # to NFS clients. See exports(5).
      3. /export/files 192.168.1.0/24(rw,no_subtree_check,insecure)
      4. # NFSv4 - pseudo filesystem root
      5. /export 192.168.1.0/24(ro,fsid=0,root_squash,no_subtree_check,hide)


      I'm not sure where the second (NFSv4) comes from because the only share I've created (via OMV gui) is for the "/export/files" share.

      Here is the entry from the /etc/fstab on the client. I have tried numerous options (insecure, defaults, etc.), but the all return the "mount.nfs: Unknown error 521" error.

      Source Code

      1. 192.168.1.7:/files /mnt/NAS_Files01 nfs soft,intr,rsize=8192,wsize=8192 0 0 # created 21 Jan 2013


      I've also tried changing the fs type to nfs4, same error. As I said, works when browsing but can't mount it. What options do I need to set on the client for this to automount?

      Thanks.