Seafile Installation

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Seafile Installation

      Hi Guys,

      I managed to run all steps through the really good guide; How to install Seafile with MySQL and SSL but know I face the following problem when calling the IP OMVIP:8000/ I get 502 bad Gateway -- nginx/1.2.1.

      What went wrong I don't have any idea but the problem started after I created the server in nginx before I could call the server WEB GUI.

      Maybe some input from you what I can do to find the reason?

      regards
      openalf
    • I doesn't matter what port you use in the nginx server settings, it doesn't have to be 8444 it can be anything you like. When you open Seafile in your browser use the port you chose for nginx and not the default seafile port 8000.
      You can also not use SSL by disabling it in the nginx server settings and just use another port like 90 instead of the default http port 80. Remember you cant have both OMV and seafile running on the same ports.

      Your seafile should be accessible with an address similar to these https://yoorOMVIP:8444or http://yourOMVIP:90. If you are connecting remotely then you may need to open these ports in you firewall.

      If you are using the default ports HTTP 80 or HTTPS 443 then you don't have use them in your browser, just use the IP without the port

      The post was edited 1 time, last by baldman ().

    • I did the below steps but when I try to SAVE I get an error.

      Do I have to change something in the below code or just copy/paste?

      Source Code

      1. ​location / {
      2. fastcgi_pass 127.0.0.1:8000;
      3. fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
      4. fastcgi_param PATH_INFO $fastcgi_script_name;
      5. fastcgi_param SERVER_PROTOCOL $server_protocol;
      6. fastcgi_param QUERY_STRING $query_string;
      7. fastcgi_param REQUEST_METHOD $request_method;
      8. fastcgi_param CONTENT_TYPE $content_type;
      9. fastcgi_param CONTENT_LENGTH $content_length;
      10. fastcgi_param SERVER_ADDR $server_addr;
      11. fastcgi_param SERVER_PORT $server_port;
      12. fastcgi_param SERVER_NAME $server_name;
      13. fastcgi_param REMOTE_ADDR $remote_addr;
      14. fastcgi_param HTTPS on;
      15. fastcgi_param HTTP_SCHEME https;
      16. access_log /var/log/nginx/seahub.access.log;
      17. error_log /var/log/nginx/seahub.error.log;
      18. fastcgi_read_timeout 36000;
      19. }
      20. location /seafhttp {
      21. rewrite ^/seafhttp(.*)$ $1 break;
      22. proxy_pass http://127.0.0.1:8082;
      23. client_max_body_size 0;
      24. proxy_connect_timeout 36000s;
      25. proxy_read_timeout 36000s;
      26. proxy_send_timeout 36000s;
      27. send_timeout 36000s;
      28. }
      Display All
      Images
      • Auswahl_006.png

        15.36 kB, 715×194, viewed 161 times
      • Auswahl_007.png

        44.87 kB, 402×519, viewed 174 times
      • Auswahl_008.png

        18.89 kB, 718×413, viewed 173 times
    • I don't have Seafile currently running on my server so I cant compare settings. I can however see that you have port 8000 set as your SSL port in your nginx server settings. You cant use port 8000 for SSL as its seafiles default port. You need to change that to another port number like 8444 or 8443. Then access Seafile using the new port eg https://OMVIP:8444
    • Rather than debug that server I would delete it and re create a new one. I don't mean delete everything and start again, I just mean delete that Nginx server/settings and re create it. Also restart the Nginx service or reboot OMV would be a good bet.

      ​You could also try disabling the "force SSL" setting and see if you access Seafile without SSL eg; http instead of https.
    • I did have some similar errors when I wrote the guide but I cant remember why or how I fixed them. Sorry. If it were me I would probably start again fresh or at least retrace my steps and make sure everything is correct. Possibly even reinstall Seafile. Do you have another test machine you could re try the setup on?

      There is a couple of Seafile config files you could check too but I cant remember where they located, you might need to change the IP address in one of them manually possibly.
      A quick google says these are the config files:
      ccnet.conf: contains the LDAP
      settingsseafile.conf: contains settings for seafile daemon and fileserver.
      seahub_settings.py: contains settings for Seahub

      The post was edited 2 times, last by baldman ().

    • Well I come to the point where I'm in doubt, you mentioned in the guide the below script:

      Source Code

      1. ​# Change the value of "user" to your linux user nameuser=root# Change the value of "script_path" to your path of seafile installation# usually the home directory of $userseafile_dir=/root/seafilescript_path=${seafile_dir}/seafile-server-latestseafile_init_log=${seafile_dir}/logs/seafile.init.logseahub_init_log=${seafile_dir}/logs/seahub.init.log


      Do I need to change the values here? Or can I keep user=root? Do I have to rename some other values? Maybe that's here where I did a mistake because I only c/p anything without any change.
    • I checked twice all areas and I'm fine with it; I guess that I do have all values set as in the script.

      Source Code

      1. ​/root/seafile
      2. /root/seafile/seafile-server-5.0.4/seahub/thirdpart/wsgidav/addons/seafile
      3. /root/seafile/seafile-server-5.0.4/seafile
      4. /root/seafile/seafile-server-5.0.4/seafile/lib64/python2.6/site-packages/seafile


      Source Code

      1. ​root@NAS:~/seafile# ls -l
      2. total 28
      3. drwx------ 3 root root 4096 May 22 23:18 ccnet
      4. drwx------ 2 root root 4096 May 22 23:18 conf
      5. drwxr-xr-x 2 root root 4096 May 20 16:40 installed
      6. drwxr-xr-x 2 root root 4096 May 20 19:58 logs
      7. drwxr-xr-x 2 root root 4096 May 22 23:18 pids
      8. drwxrwxr-x 6 500 500 4096 Jan 13 11:00 seafile-server-5.0.4
      9. lrwxrwxrwx 1 root root 20 May 20 17:52 seafile-server-latest -> seafile-server-5.0.4
      10. drwxr-xr-x 3 root root 4096 May 20 17:52 seahub-data


      When I run:

      Source Code

      1. ​root@NAS:~/seafile# update-rc.d seafile-server defaults
      2. perl: warning: Setting locale failed.
      3. perl: warning: Please check that your locale settings:
      4. LANGUAGE = (unset),
      5. LC_ALL = (unset),
      6. LC_PAPER = "da_DK.UTF-8",
      7. LC_ADDRESS = "da_DK.UTF-8",
      8. LC_MONETARY = "da_DK.UTF-8",
      9. LC_NUMERIC = "da_DK.UTF-8",
      10. LC_TELEPHONE = "da_DK.UTF-8",
      11. LC_IDENTIFICATION = "da_DK.UTF-8",
      12. LC_MEASUREMENT = "da_DK.UTF-8",
      13. LC_TIME = "da_DK.UTF-8",
      14. LC_NAME = "da_DK.UTF-8",
      15. LANG = "de_DE.UTF-8"
      16. are supported and installed on your system.
      17. perl: warning: Falling back to the standard locale ("C").
      18. update-rc.d: using dependency based boot sequencing
      Display All


      How can I fix that error?