Can't mount new EXT4 partition

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't mount new EXT4 partition

      Hello,

      So here's the background and my problem. I had a 3TB USB3.0 hard drive with a single EXT4 partition that was attached to a Linux-based embedded device (router). I attached this hard disk to OMV some time ago and the partition mounted. The were some sort of warning in the interface, but I can't remember what it was. Anyway, the partition was mounted and got mounted at each reboot since. For all intents and purposes it functioned properly, the only problem being that when I select it in the interface the "Unmount" button is not active so I can't seem to unmount it. The umount command doesn't work either. But that's not the main issue.

      I wanted a new partition on this drive, so I booted off a GParted Live USB stick and resized the old partition and created a new one of 1TB. All went well, or so I thought. First time when I booted into OMV it went OK, but once in the interface I attempted to mount the new /dev/sdc2 partition. It failed with this error:

      Error #6000:
      exception 'OMVException' with message 'Failed to mount 'febf09f0-2618-47fc-a80d-cdaf6b6d4f89': mount: wrong fs type, bad option, bad superblock on /dev/sdc2,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail or so
      ' in /usr/share/openmediavault/engined/module/fstab.inc:90

      dmesg | tail shows:

      [ 337.648757] EXT4-fs (sdc2): couldn't mount RDWR because of unsupported optional features (400)
      [ 1141.372193] EXT4-fs (sdc2): couldn't mount RDWR because of unsupported optional features (400)

      The next time I rebooted OMV it got stuck at this:
      /dev/sdc2 has unsupported feature(s): metadata_csum
      e2fsck: Get a newer version of e2fsck!
      fsck died with exit status 8

      Then something about repairing the file system manually and entering an administrator shell or pressing CONTROL-D to resume boot. Pressing CTRL-D resumes the boot process and OMV boots normally, but the same issue remains: cannot mount /dev/sdc2 from the interface.

      I booted from GParted Live again and performed a file system check. It finished OK, but had the same problem at OMV boot. I then went into GParted Live and deleted the partition. OMV booted without errors. I then used SSH with X forwarding to run gparted directly from OMV with the HDD attached, thinking that maybe GParted Live uses a newer version with unsupported EXT4 features.

      I created the new partition again and got an error about not being able to update the kernel and then the gparted interface got stuck. I had to kill it, but the new partition did appear in the OMV interface. However, the same problem as before: cannot mount it, same error. Rebooted OMV and it's stuck again at fsck with the same error.

      The first partition on the drive /dev/sdc1 appears to work properly. It mounts automatically, but still has the old problem: can't unmount it from the interface.

      Any ideas? At this point I'm tired of searching all sorts of Linux websites and trying various suggestions, so maybe one of you has encountered this. I just want a second EXT4 partition on this drive! Creating partitions and mounting them is not supposed to be so complicated!

      The post was edited 1 time, last by Skello ().

    • Well several suggestions, Fs drivers are shipped as kernel modules so you can try to update to backports kernel to see if it allows mounting. If it doesn't then just use gparted for partitioning and NOT FORMATTING. Let Omv format the partition.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Thanks for answering subzero79.

      I have tried the backports kernel, but no luck. Still can't mount it. I used GParted Live to remove the partition and then create it as unformatted, but for some reason it still formats it as ext4 and assigns the previous label. I then selected "cleared" instead of "unformatted" as file system. OMV doesn't see it under "File Systems," but another problem is that if I hit "Create" I can't select any HDD from the "select a device" dropdown list. For a brief second it shows like the dropdown list is loading, then it doesn't even open anymore.
    • I finally solved it!

      I figured I need to solve the inability to unmount the primary /dev/sdc1 partition first. I stopped NFS, Transmission and anything else that was using that partition, but could not delete the shared folder configured on it. It simply didn't have the active delete button. So I figured "OK then, I'll edit the shared folder and assign it to a different partition temporarily." Once I did that, the Unmount button appeared for /dev/sdc1 and I could unmount the partition without a problem.

      Next I fired up local gparted through SSH with X forwarding and didn't get any error anymore about the partitions on that drive being locked. I created the second EXT4 partition, with a label and it worked without a hitch. After a few seconds it appeared in the OMV interface and I could mount it without any problem.