clamav high cpu utilization

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • clamav high cpu utilization

      I have been having this issue for some time, but am finally getting round to post it.

      It seems after some days (not sure how many), something happens with clamd and it stays at 40% cpu utilization.
      It does not do this when initially started, so i guess it is after running from some scheduled times.

      shows as user root, /usr/sbin/clamd -c /etc/clamav/clamd.conf -pid=/var/run/clamav/clamd.pid 41% CPU 10% MEM

      as i say, when initially started, everything is normal. i tried changing the user to clamav in the config and some other parameters, but it seems to get reset to defaults each time.
    • So i have checked this now a number of times.

      after a fresh start, before the first virus scan. no cpu utilisation is taken by clamd.
      after the first scheduled scan is complete, the cpu utilization stays at 45% or there about.

      It also seems to ignore the global settings which still shows via the webmin interface i.e. i have recursion level set to 25, but it only loads 16.....

      Fri Jun 10 16:44:13 2016 -> Limits: Global size limit set to 104857600 bytes.
      Fri Jun 10 16:44:13 2016 -> Limits: File size limit set to 26214400 bytes.
      Fri Jun 10 16:44:13 2016 -> Limits: Recursion level limit set to 16.
      Fri Jun 10 16:44:13 2016 -> Limits: Files limit set to 10000.
      Fri Jun 10 16:44:13 2016 -> Limits: MaxEmbeddedPE limit set to 10485760 bytes.

      any ideas

      The post was edited 1 time, last by gwaitsi ().

    • I've just discovered also, that any time the plugin screen is saved, it overwrites the clamd.conf values
      i.e. MaxDirectoryRecursion 15

      if i modify directly in clamd.conf MaxDirectoryRecursion 25, it is reset back to 15.

      if i enter MaxDirectoryRecursion 25 as an Extra Option it actually create two lines in the clamd.conf
      MaxDirectoryRecursion 15
      MaxDirectoryRecursion 25
    • You have to set the environment variable OMV_CLAMAV_CLAMD_MAXDIRECTORYRECURSION in /etc/default/openmediavault and rebuild the config with

      Source Code

      1. # omv-mkconf clamav


      to apply your override.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit