Unable to install subsonic PlugIn

    • OMV 2.x
    • Unable to install subsonic PlugIn

      Dear all,

      after some time, I wanted to expand my OMV installation to better suit my needs. To do so, I wanted to install the subsonic-PlugIn.
      From the PlugIn-panager, I was only told that it couldn't be installed due to problems with dependencies.
      When trying to install via Putty, I receive the following console output:

      Source Code

      1. sudo apt-get install openmediavault-subsonic
      2. [sudo] password for deub275:
      3. Paketlisten werden gelesen... Fertig
      4. Abhängigkeitsbaum wird aufgebaut.
      5. Statusinformationen werden eingelesen.... Fertig
      6. Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
      7. Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
      8. Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
      9. nicht erstellt wurden oder Incoming noch nicht verlassen haben.
      10. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
      11. Die folgenden Pakete haben unerfüllte Abhängigkeiten:
      12. openmediavault-subsonic : Hängt ab von: ffmpeg soll aber nicht installiert werden
      13. E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete..
      Display All


      So seemingly it is FFMPEG wich is a problem, but when trying to install this package, I receive:

      Source Code

      1. deub275@OMV:~$ sudo apt-get install ffmpeg
      2. Paketlisten werden gelesen... Fertig
      3. Abhängigkeitsbaum wird aufgebaut.
      4. Statusinformationen werden eingelesen.... Fertig
      5. Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
      6. Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
      7. Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
      8. nicht erstellt wurden oder Incoming noch nicht verlassen haben.
      9. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
      10. Die folgenden Pakete haben unerfüllte Abhängigkeiten:
      11. ffmpeg : Hängt ab von: libavcodec53 (>= 7:0.10.8~) soll aber nicht installiert werden oder
      12. libavcodec-extra-53 (>= 7:0.10.8~) soll aber nicht installiert werden
      13. Hängt ab von: libavdevice53 (>= 7:0.10.8~) soll aber nicht installiert werden
      14. Hängt ab von: libavfilter2 (>= 7:0.10.8~) soll aber nicht installiert werden
      15. Hängt ab von: libavformat53 (>= 7:0.10.8~) soll aber nicht installiert werden
      16. E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
      Display All


      Finally, I am able to track the dependency problem down to this package:

      Source Code

      1. deub275@OMV:~$ sudo apt-get install libavcodec53
      2. Paketlisten werden gelesen... Fertig
      3. Abhängigkeitsbaum wird aufgebaut.
      4. Statusinformationen werden eingelesen.... Fertig
      5. Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
      6. Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
      7. Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
      8. nicht erstellt wurden oder Incoming noch nicht verlassen haben.
      9. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
      10. Die folgenden Pakete haben unerfüllte Abhängigkeiten:
      11. libavcodec53 : Hängt ab von: libx264-120 ist aber nicht installierbar
      12. E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
      Display All


      So what can I do to get subsonic running on my system?
      Any help or hint is very appreciated...

      Br, Gilhin.

      P.S.:

      As I saw multiple questions on this:

      Source Code

      1. ​deub275@OMV:~$ cat /etc/apt/sources.list
      2. #
      3. # deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140426-13:35]/ squeeze contrib main non-free
      4. # deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140426-13:35]/ wheezy main
      5. #deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140426-13:35]/ squeeze contrib main non-free
      6. #deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140426-13:35]/ wheezy main
      7. deb http://ftp.de.debian.org/debian/ wheezy main
      8. deb-src http://ftp.de.debian.org/debian/ wheezy main
      9. deb http://security.debian.org/ wheezy/updates main contrib non-free
      10. deb-src http://security.debian.org/ wheezy/updates main contrib non-free
      11. # wheezy-updates, previously known as 'volatile'
      12. deb http://ftp.de.debian.org/debian/ wheezy-updates main contrib non-free
      13. deb-src http://ftp.de.debian.org/debian/ wheezy-updates main contrib non-free
      14. #Test
      15. #deb http://ftp.debian.org/debian sid main
      Display All
    • Did you install anything from the sid repo (bad idea)? It is probably blocking due to newer versions of some sid package if you did.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Yes, I installed the complete libc6 package (libc6 libc6-dev libc6-dbg).
      I did so, because my installation attempts of ffmpeg showed an outdated libc6 package.
      So, from my point of view, this shouldn't be the problem, as I was unable to install both ffmpeg and tge subsonic plugin before installing the newer libc6 package.
      Or am I thinking into the wrong direction?
    • libc6 is one of the most dangerous packages to upgrade especially to sid. Most of the multimedia packages are very specific on which library versions they need. That is definitely causing the problem.

      None of the plugins require installing anything from sid or upgrading libc6. Personally, I would reinstall since it is easier than downgrading libc6.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Volker says OMV 3 is ready but unfortunately, the omv-extras plugins are not all finished due to lack of time (and help).
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • aufs is ready because it is in the unionfilesystem plugin BUT I would switch to mergerfs if you plan to use the backports kernel (no aufs module in it).

      autoshutdown won't take too long to port. It was next on my list once I am done with snapraid.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • unionfilesystems plugin is ported and up to date (I use it too).

      omv-extras plugin is ported and quite a few are ported. Some of the big ones that aren't ported yet (or not finished) are snapraid, docker, and zfs
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Some of the big ones that aren't ported yet (or not finished) are snapraid, docker, and zfs​


      That is definetely no dealbreaker for me, as I use exactly none of these plugins.
      So I'll start to make a backup of my data right away.
      One final thing: Is there a description how to install OMV 3 on a plain Debian 8 - I just found a way to upgrade...
    • Source Code

      1. echo "deb http://packages.openmediavault.org/public erasmus main" > /etc/apt/sources.list.d/openmediavault.list
      2. apt-get update
      3. apt-get install openmediavault-keyring postfix
      4. apt-get update
      5. apt-get install openmediavault
      6. omv-initsystem
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Just to bring this issue to an end and to document the final solution.
      I tried to use the OMV 3 ISO, upgraded to the latest version (3.0.22) and installed the OMV-extras Plugin. After simply enabling the OMV extras testing repo as well, I was unable to login via the GUI, I received an error saying "Failed to connect to socket: Connection refused".
      I finally decided to stay with a 2.X version, which is currently reinstalled and running smoothly.
      Thank you for your support!