Do have problems with nginx configuration

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Do have problems with nginx configuration

      Hi all,

      I hope that somebody is able to give me some hints how I can get Nginx under control.
      Like to use it in relation to my seafile installation.

      In my mailbox I get the following warnings/errors:

      Source Code

      1. ​PID changed Service nginx Date: Sat, 11 Jun 2016 16:03:48 Action: alert Host: NAS.local Description: process PID changed from 2469 to 9460Your faithful employee,Monit


      Source Code

      1. ​PID changed Service php5-fpm Date: Sat, 11 Jun 2016 16:06:48 Action: alert Host: NAS.local Description: process PID changed from 2548 to 10497


      Source Code

      1. ​Does not exist Service nginx Date: Sat, 11 Jun 2016 16:06:49 Action: restart Host: NAS.local Description: process is not runningYour faithful employee,Monit


      Source Code

      1. ​Execution failed Service nginx Date: Sat, 11 Jun 2016 16:07:19 Action: alert Host: NAS.local Description: failed to startYour faithful employee,Monit


      Source Code

      1. ​After I made a restart I get the following error:2016/06/12 12:34:14 [error] 2613#0: *53 directory index of "/media/4fcfda30-31ac-49ad-8d8c-d84723cbe1af/SeaFile-Data//" is forbidden, client: ::ffff:192.168.88.30, server: , request: "GET / HTTP/1.1", host: "192.168.88.50:8080"


      I have actually no clue how I get that error scenario under control.

      best regards
      Alfons
    • Your title is misleading. The plugin works fine when it is configured correctly.

      The last error message is because you don't have the auto index set or you don't have an index.php/index.html page.
      omv 4.1.4 arrakis | 64 bit | 4.15 backports kernel | omvextrasorg 4.1.3
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • openalf wrote:

      Actually I give up don't like half of my short life to get Seafile working.


      Actually, ou are getting closer. At least, you were able to save some configuration for nginx without getting an error message. If you set the switch Autoindex to on you will see some files. (not that you wuld recognise those).

      If this works, you can start wit hpart 4 of the Seafile tutorial.
    • Openalf, I do feel sorry for you, you have tried patiently and politely to get help and help has been given but maybe not enough. I can help a little more but I'm not sure how much help I will be as I only have a little knowledge in some areas :)

      Firstly, I noticed above you have a forbidden directory ("/media/4fcfda30-31ac-49ad-8d8c-d84723cbe1af/SeaFile-Data//" is forbidden). I'm not sure if this has anything to do with it but during the Seafile installation it says to append another folder onto that data directory for the seafile data eg /media/4fcfda30-31ac-49ad-8d8c-d84723cbe1af/SeaFile-Data/DATA From what I remember it doesn't work without that extra sub folder. As for the two trailing slashes I don't think you need them.

      Secondly, Can you do Part 4 of the guide again and post screen shots of all the settings you have, the ones above don't look right to me. I can only read English but in comparison to what I have they look wrong... Unless that's not a seafile server in those images.

      The post was edited 2 times, last by baldman ().

    • Just tried once more to get part 4 configured, but it still doesn't work. I changed also the path but still I do get errors and what hurts me most I haven't any clue where I can find where things goes wrong. Maybe the attached screen shot's gives some idea what I'm doing wrong.
      Images
      • Auswahl_010.png

        25.53 kB, 1,008×354, viewed 199 times
      • Auswahl_011.png

        13.55 kB, 575×404, viewed 201 times
    • Your Default (SSL) should be enable as a default.

      Your Seafile-Data is not require to be created prior the installation.
      If you have created the Seafile-Data as the instructions instructed, then paste that path when it prompts you.
      Otherwise, just manually type in: /media/UUID/www/.... hit Enter.

      For you case, delete the folder you have, then re-create the Seafile-data.
      And if you want to use that, then select it /media/4fc....../Seafile-Data/

      The Seafile data is tricky, if you move it to another location after the installation, it may not work even you update to the correct path.
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10

      The post was edited 1 time, last by tinh_x7 ().

    • Honestly I think I have somehow destroyed my seafile installation and like to un install again. Then start from the scratch again. I did the former installation into /root/seafile, how can I delete the seafile installation so I can start from scratch again? Should I use Purge and will this also give me the right to create a new password?
    • You can sudo or login as root and do this: rm -r seafile....
      Ensure you stop the nginx service for Seafile before do this.

      Seafile is nice, and easy to use, but it lack some features such as antivirus, and external storage mounting that NextCloud (owncloud) has.
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10

      The post was edited 1 time, last by tinh_x7 ().

    • Well I did uninstall seafile; but before I start the new installation I like to understand if I should create a new folder or should I place it under /root/seafile? I also belive that I don't need to make a new configuration for mysql? What else should I think about before doing the installation. Don't get me wrong I'm not lazy but I feel that I should discuss those steps before I go ahead again.
    • Well if you're doing a new installation from the new updated guide then don't create any folders etc. just start at the top and it should create everything as you go. The new guide will automate the user and database setup. I imagine you can use your old database but I haven't done it that way so I'm not sure. You can delete the databases and start again if you want to.