Filesystem missing after hardware upgrade

    • OMV 2.x
    • Filesystem missing after hardware upgrade

      Hi all,

      Completed a hardware upgrade and added a further 2 drives but when I got everything back up and running one filesystem is now missing.

      I've tried Gparted but it won't read..

      I've tried omv-mkconf fstab and some other solutions from other threads but no luck as yet!

      Usually I'd scrap and rewrite but this is a 4tb drive full of data :(

      I ran blkid and found something which looks a bit strange the one UUID with TYPE = SWAP..unless that's linked to the boot drive.

      Source Code

      1. /dev/sdb1: LABEL="Filestore" UUID="01aa919c-3909-4db8-a6ce-12a8249ca23c" TYPE="ext4"
      2. /dev/sdd1: UUID="927413c4-d2ea-4b58-8fab-dbf4f23e3e8a" TYPE="ext4" LABEL="MoviesTwo"
      3. /dev/sde1: LABEL="Delta4Tera" UUID="3073ecec-7ba2-43a2-acee-ba4bafa87533" TYPE="ext4"
      4. /dev/sdf1: LABEL="Music" UUID="080ac573-5c9f-45ec-b8cd-993ccfa83509" TYPE="ext4"
      5. /dev/sdh1: LABEL="Echo15Tera" UUID="bbe9a6b6-4bf3-46b1-bb77-c91a12517c4d" TYPE="ext4"
      6. /dev/sdg1: LABEL="Foxtrot1Tera" UUID="6824b405-4630-4dab-a35e-b426b78a1349" TYPE="ext4"
      7. /dev/sda1: LABEL="OMV" UUID="7fc1bc94-762f-46c2-8358-2b93e13307f0" TYPE="ext4"
      8. /dev/sda5: UUID="7eb557f0-923c-4d15-87da-67da42fb2223" TYPE="swap"

      Any help much appreciated.
      • Capture.JPG

        74.28 kB, 1,129×444, viewed 366 times
    • are all disks shown at physical disk section?

      if not is time to open the case an make sure every drive is plugged tight correctly, Sata (disk and mainboard) and power, maybe some connector is loose.

      Check also if all disks are being displayed at BIOS.

      If after that they still don't show make sure cables are in good shape, try to swap them for the disks that are not detected.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • Thanks.. seems a partition is there.

      Source Code

      1. root@soconas:~# fdisk -l /dev/sdc
      2. WARNING: GPT (GUID Partition Table) detected on '/dev/sdc'! The util fdisk doesn't support GPT. Use GNU Parted.
      3. Disk /dev/sdc: 4000.8 GB, 4000785948160 bytes
      4. 256 heads, 63 sectors/track, 484501 cylinders, total 7814035055 sectors
      5. Units = sectors of 1 * 512 = 512 bytes
      6. Sector size (logical/physical): 512 bytes / 4096 bytes
      7. I/O size (minimum/optimal): 4096 bytes / 4096 bytes
      8. Disk identifier: 0x00000000
      9. Device Boot Start End Blocks Id System
      10. /dev/sdc1 1 4294967295 2147483647+ ee GPT
      11. Partition 1 does not start on physical sector boundary.
      12. root@soconas:~#
      Display All

      Pastebin :

    • [ 1.525376] sdc: unknown partition table

      Don't know what happened there, the system is clearly not reading the partition and fs signature. So game over there.

      Have you attempted a fsck.ext4 -p /dev/sdc1

      Also check the smart values of the disk, so that is in good condition and no bad blocks.

      Another exercise boot systemrescuecd see if the partition is recognized there?
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • Thanks! Have tried that now... says non-existent. But noticed from blkid it's listed as /dev/sda5 so tried that also, below.

      Source Code

      1. root@soconas:~# fsck.ext4 -p /dev/sdc1
      2. fsck.ext4: No such file or directory while trying to open /dev/sdc1
      3. Possibly non-existent device?
      4. root@soconas:~# blkid
      5. /dev/sdb1: LABEL="Filestore" UUID="01aa919c-3909-4db8-a6ce-12a8249ca23c" TYPE="ext4"
      6. /dev/sdd1: UUID="927413c4-d2ea-4b58-8fab-dbf4f23e3e8a" TYPE="ext4" LABEL="MoviesTwo"
      7. /dev/sde1: LABEL="Delta4Tera" UUID="3073ecec-7ba2-43a2-acee-ba4bafa87533" TYPE="ext4"
      8. /dev/sdf1: LABEL="Music" UUID="080ac573-5c9f-45ec-b8cd-993ccfa83509" TYPE="ext4"
      9. /dev/sdh1: LABEL="Echo15Tera" UUID="bbe9a6b6-4bf3-46b1-bb77-c91a12517c4d" TYPE="ext4"
      10. /dev/sdg1: LABEL="Foxtrot1Tera" UUID="6824b405-4630-4dab-a35e-b426b78a1349" TYPE="ext4"
      11. /dev/sda1: LABEL="OMV" UUID="7fc1bc94-762f-46c2-8358-2b93e13307f0" TYPE="ext4"
      12. /dev/sda5: UUID="7eb557f0-923c-4d15-87da-67da42fb2223" TYPE="swap"
      13. root@soconas:~# fsck.ext4 -p /dev/sda5
      14. /dev/sda5 is mounted.
      15. e2fsck: Cannot continue, aborting.
      16. root@soconas:~#
      Display All

      I loaded up systemrescuecd using testdisk which worked. After analysing I was able to find the partition and browse it's contents - everything was there.

      I then followed next step and wrote the partition table which completed successfully, after reboot same issue though still not seeing it...super weird!
    • sda5 is swap partition from the os disk, nothing to do there. Also you cannot run fsck on mounted disks.

      Weird that testdisk didn't work. I would reformat the disk, but before try to recover as much data you can from there using photorec or extundelete.

      You can try also manual method using
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • Yep. These are all good.

      It's just so weird that the drive was working fine until I removed and did the upgrade.

      Using Gdisk I'm getting errors now that say : "Warning! Secondary partition overlaps the last partition by 2106 blocks. You need to delete this partition or resize."

      Using Testdisk I do a full scan and get: "Check the harddisk size, HD jumper settings, Bios"...

      I'm checking all these again now in BIOS.