[SOLVED] MiniDLNA Problems

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [SOLVED] MiniDLNA Problems

      I have just completed a command line upgrade from 2.7.4 to 0.4.16, prior to starting the upgrade I uninstalled all my plugins. The upgrade went ok it seems, the system is up and I can see my shares etc.
      From the the GUI I have installed the plugin "omvplugins.org 2.2.1"
      Next was MiniDLDA, but I am having problems with that. DLNA appears in the GUI tree on the left and when I check the box on the configuration page to enable and save I get the following error:

      Error #2003:
      exception 'OMVException' with message 'Invalid method parameter: Array is not an object.' in /usr/share/php/openmediavault/rpc.inc:293
      Stack trace:
      #0 /var/www/openmediavault/rpc/minidlna.inc(114): OMVRpc->validateParams('MiniDLNARpc::se...', Array)
      #1 /var/www/openmediavault/rpc/minidlna.inc(153): MiniDLNARpc->_validate('MiniDLNARpc::se...', Array)
      #2 [internal function]: MiniDLNARpc->set(Array)
      #3 /usr/share/php/openmediavault/rpc.inc(265): call_user_func_array(Array, Array)
      #4 /usr/share/php/openmediavault/rpc.inc(98): OMVRpc::exec('MiniDLNA', 'set', Array)
      #5 /var/www/openmediavault/rpc.php(44): OMVJsonRpcServer->handle()
      #6 {main}

      I am unable to add a share in the dialogue box at the bottom of the configuration page
      also, the DLNA icon shows in the menu tree to the left but when I look at the plugins page it shows not installed. Can't remove it, errors when i try to re-install it. Please help!
    • Re: MiniDLNA Problems

      "tekkbebe" wrote:

      What are contents of this files /etc/apt/sources.list.d/omv-plugins-org-fedaykin.list ????
      Here is what should be in the file:

      deb packages.omv-plugins.org fedaykin main


      Also with minidlna the plugin is seperate from the minidlna package. Did you install both?


      That file didn't exist. My son just helped me add it, followed the rest of your instructions and it seems to be fine now. Not sure where I went wrong in the upgrade process?

      Thanks very much for your help!
    • Re: [RESOLVED] MiniDLNA Problems

      @tekkbebe

      You said that minidlna and the plugin must both be installed. I can't get that to work since upgrading to fedaykin. If I install minidlna first, I get the following error:

      Source Code

      1. trying to overwrite '/etc/default/minidlna', which is also in package minidlna 1.0.25


      If I try to install the plugin first, then minidlna will give the same error for the same file. Also, although I can Remove the plugin, I can't Purge it--it gives errors when trying to remove the minidlna user and group.

      The minidlna plugin was working fine prior to upgrading to fedaykin. Prior to upgrading I tried to uninstall the plugin via the gui. It showed the error in trying to remove the minidlna user and group, but the plugin then showed as not installed. I proceeded with the upgrade and tried to reinstall the plugin and it has not worked since. The plugin installs and appears in the gui (as long as minidlna is not installed first), but obviously won't work without minidlna itself installed. I just can't get both packages to play nice together.

      Can I fix this without reinstalling OMV?
    • Re: [RESOLVED] MiniDLNA Problems

      In the OMV web-gui go to /system/plugins and on right uninstall openmediavault-minidilana (that is the plugin).

      then in command line via root ssh session (Putty):

      apt-get --purge remove minidlna


      Then go back to plugins section. You should have minidlna (package) and openmediavault-minidlna. Put a check
      in both of them and install.
    • Re: [SOLVED] MiniDLNA Problems

      I have never seen both packages (minidlna and openmediavault-minidlna) in the plugin list, either before or after upgrading to fedaykin. All that is listed regarding DLNA in my plugin list is "openmediavault-minidlna 1.0.23-cvs20111203-static-4" which is NOT currently installed.

      Is this even the current version? All of the other plugins seems to start with "0.4". I can "apt-get purge minidlna" without an error, and If I

      apt-get remove openmediavault-minidlna

      it says package not installed, but if I

      apt-get purge openmediavault-minidlna

      then it exits with an error when trying to remove the omv user (I assume it means omv user minidlna)--it says user not found.

      Something is clearly out of sync, but I don't know how to fix it.

      Note, the omvpluginsorg current version shows as "openmediavault-omvpluginsorg 0.4.1+0~1355675019.3~1.gbpe45741" if that is helpful.
    • Re: [SOLVED] MiniDLNA Problems

      I installed omv-plugins,org via the gui, so I am not sure how it got to be wrong now.

      If I try the instructions on your post, the wget (as copy & pasted) command results in:

      Source Code

      1. --2013-02-23 08:53:06-- http://packages.omv-plugins.org/pool/main/o/openmediavault-omvpluginsorg/openmediavault-omvpluginsorg_0.4~10.gbp5bae63_all.deb
      2. Resolving packages.omv-plugins.org (packages.omv-plugins.org)... 37.200.98.204
      3. Connecting to packages.omv-plugins.org (packages.omv-plugins.org)|37.200.98.204|:80... connected.
      4. HTTP request sent, awaiting response... 200 OK
      5. Length: 12048 (12K) [application/octet-stream]
      6. openmediavault-omvpluginsorg_0.4~10.gbp5bae63_all.deb: Permission denied
      7. Cannot write to `openmediavault-omvpluginsorg_0.4~10.gbp5bae63_all.deb' (Permission denied).
    • Re: [SOLVED] MiniDLNA Problems

      OK, go to here in OMV web-gui:

      /system /OMV-Plugins.org then on right make sure stable is checkmarked and then click on ok.

      the go to command line ssh via putty and do:

      apt-get update
      apt-get upgrade

      then look in plugins and see if you have any minidlna that is not installed. still i want results of that grep command from my last post.
    • Re: [SOLVED] MiniDLNA Problems

      That took a minute (lots of updates to the system). The results of your command are:

      Source Code

      1. ii openmediavault 0.4.24 Open network attached storage solution
      2. ii openmediavault-forkeddaapd 0.4.2 OpenMediaVault forked-daapd (DAAP server) plugin
      3. ii openmediavault-keyring 0.2 GnuPG archive keys of the OpenMediaVault archive
      4. pc openmediavault-minidlna 1.0.23-cvs20111203-static-4 OpenMediaVault miniDLNA (DLNA server) plugin
      5. ii openmediavault-omvpluginsorg 0.4.1+0~1355675019.3~1.gbpe45741 OMV-Plugins.org Package Repositories for OpenMediaVault


      Stable is checked (not Donald or Glass), I then used the "check" command on the plugins page, and the only plugin available re minidlna is the openmediavault-minidlna (same as before). There is not separate package for minidlna alone. Even though openmediavault-minidlna appears in the results above, it shows as NOT installed in OMV. Perhaps because the "apt-get purge openmediavault-minidlna" never exited cleanly?
    • Re: [SOLVED] MiniDLNA Problems

      I have been using the same install of OMV since practically the beginning, and upgrading as I go. I had a problem with plugins when I went from 0.2 to 0.3, so I decided to remove all plugins before going from 0.3 to 0.4. I think the problem began there. When uninstalling the minidlna plugin, the dialog showed an error (I think it was unable to remove the minidlna user and group). However, when the page refreshed, it showed the minidlna plugin as not installed, so I went ahead with the OMV upgrade to 0.4. I have not been able to get minidlna working ever since.

      Can I comment the lines in the postrm script that try to remove the OMV user and group so the apt-get purge command can complete?
    • Re: [SOLVED] MiniDLNA Problems

      ok, problem most likely start cuz you didn't uninstall old plugins before you upgraded. This one however never upgraded and now we have to deal with it. Don't jump the gun cuz we could make mistake. Give me a bit. Check this folder for me and tell me if the new plugin is on your machine. Do this:

      cd /var/cache/apt/archives
      ls -la

      look thru there and tell me if a .4 openemediavault-minidlna package is there but has not installed....
    • Re: [SOLVED] MiniDLNA Problems

      (corrected the type in the path var not vat)

      No, there is only:

      Source Code

      1. -rw-r--r-- 1 root root 976720 Feb 19 15:26 openmediavault_0.4.24_all.deb
      2. -rw-r--r-- 1 root root 14938 Jan 22 14:58 openmediavault-forkeddaapd_0.4.2_all.deb
      3. -rw-r--r-- 1 root root 3268 Jan 25 12:41 openmediavault-keyring_0.2_all.deb
      4. -rw-r--r-- 1 root root 12020 Dec 16 11:24 openmediavault-omvpluginsorg_0.4.1+0~1355675019.3~1.gbpe45741_all.deb