Unable to install Plex

    • OMV 2.x
    • Resolved
    • Unable to install Plex

      Hi,

      I set up OMV2 and I'm trying to install Plex but it doesn't work. Installing other plugins is working fine so far.

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. >>> *************** Error ***************
      5. Failed to execute command 'export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-plexmediaserver 2>&1': Reading package lists...
      6. Building dependency tree...
      7. Reading state information...
      8. Some packages could not be installed. This may mean that you have
      9. requested an impossible situation or if you are using the unstable
      10. distribution that some required packages have not yet been created
      11. or been moved out of Incoming.
      12. The following information may help to resolve the situation:
      13. The following packages have unmet dependencies:
      14. openmediavault-plexmediaserver : Depends: python but it is not going to be installed
      15. E: Unable to correct problems, you have held broken packages.
      16. <<< *************************************
      17. >>> *************** Error ***************
      18. Failed to execute command 'export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-plexmediaserver 2>&1': Reading package lists...
      19. Building dependency tree...
      20. Reading state information...
      Display All


      Anyone got an idea?

      Update: I get the same error message trying to install the CouchPotato plugin.

      The post was edited 1 time, last by Denne ().

    • If you don't have python on your system, a python app like couchpotato won't work.

      What is the output of:

      dpkg -l | grep -E "python|openm"
      uname -a
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Yes but isn't python3 "enough"?

      Here is the output

      Source Code

      1. root@NAS:~# dpkg -l | grep -E "python|openm"
      2. ii openmediavault 2.2.5 all Open network attached storage solution
      3. ii openmediavault-docker-gui 0.2.21 amd64 OpenMediaVault plugin for Docker
      4. ii openmediavault-keyring 0.4 all GnuPG archive keys of the OpenMediaVault archive
      5. ii openmediavault-nzbget 1.6 all command-line based binary newsgrabber for nzb files
      6. ii openmediavault-omvextrasorg 2.13.2 all OMV-Extras.org Package Repositories for OpenMediaVau lt
      7. ii openmediavault-sensors 1.0.23 all Provides a cpu temperature monitor
      8. ii openmediavault-snapraid 1.5 all snapraid plugin for OpenMediaVault.
      9. ii openmediavault-sonarr 1.1 all OpenMediaVault Sonarr(NzbDrone) plugin
      10. ii openmediavault-unionfilesystems 2.3 all Union filesystems plugin for OpenMediaVault.
      11. ii python-apt-common 0.8.8.2 all Python interface to libapt-pkg (locales)
      12. ii python3 3.2.3-6 all interactive high-level object-oriented language (def ault python3 version)
      13. ii python3-apt 0.8.8.2 amd64 Python 3 interface to libapt-pkg
      14. ii python3-minimal 3.2.3-6 all minimal subset of the Python language (default pytho n3 version)
      15. ii python3.2 3.2.3-7 amd64 Interactive high-level object-oriented language (ver sion 3.2)
      16. ii python3.2-minimal 3.2.3-7 amd64 Minimal subset of the Python language (version 3.2)
      Display All


      Source Code

      1. ​root@NAS:~# uname -a
      2. Linux NAS 3.16.0-0.bpo.4-amd64 #1 SMP Debian 3.16.7-ckt25-2~bpo70+1 (2016-04-12) x86_64 GNU/Linux
    • Did you uninstall python2? A lot of the plugins use python2 and they are not always compatible with python3.
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • No. I tried to install nzbhydra from git and it this was the first time that it occurred to me that there must be something wrong with python because I couldn't run it.
      I tried installing python via apt-get but I couldn't. I thought maybe it was intended that way and used the docker container of nzbhydra instead.

      How can I get python2 back?
    • Try this:

      rm /etc/apt/sources.list.d/python-2.7.list
      apt-get update
      apt-get purge python*

      Then install these packages with apt-get:

      Source Code

      1. ii libpython2.7 2.7.3-6+deb7u3 amd64 Shared Python runtime library (version 2.7)
      2. ii python 2.7.3-4+deb7u1 all interactive high-level object-oriented language (default version)
      3. ii python-apt-common 0.8.8.2 all Python interface to libapt-pkg (locales)
      4. ii python-cups 1.9.48-1.1 amd64 Python bindings for CUPS
      5. ii python-daemon 1.5.5-1 all library for making a Unix daemon process
      6. ii python-lockfile 1:0.8-2 all file locking library for Python
      7. ii python-lxml 2.3.2-1+deb7u1 amd64 pythonic binding for the libxml2 and libxslt libraries
      8. ii python-minimal 2.7.3-4+deb7u1 all minimal subset of the Python language (default version)
      9. ii python-support 1.0.15 all automated rebuilding support for Python modules
      10. ii python2.7 2.7.3-6+deb7u3 amd64 Interactive high-level object-oriented language (version 2.7)
      11. ii python2.7-minimal 2.7.3-6+deb7u3 amd64 Minimal subset of the Python language (version 2.7)
      12. ii python3 3.2.3-6 all interactive high-level object-oriented language (default python3 version)
      13. ii python3-apt 0.8.8.2 amd64 Python 3 interface to libapt-pkg
      14. ii python3-minimal 3.2.3-6 all minimal subset of the Python language (default python3 version)
      15. ii python3.2 3.2.3-7 amd64 Interactive high-level object-oriented language (version 3.2)
      16. ii python3.2-minimal 3.2.3-7 amd64 Minimal subset of the Python language (version 3.2)
      Display All