Windows cannot access SMB/CIFS share

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Windows cannot access SMB/CIFS share

      Hi guys,

      I have been running a NAS server with shares on plain Debian and decided to move to OMV2.1.
      However I am running into a bit of difficulty in setting op the SAMBA shares...

      The share is browsable under windows, but I do not get asked for a username or password, and get greeted with "Windows cannot access..."

      Could someone give me someone tell me what could be the issue?

      I've dumped the output of the most relevant command below:

      root@openmediavault:/etc/samba# cat smb.conf
      Display Spoiler

      #======================= Global Settings =======================
      [global]
      workgroup = WORKGROUP
      server string = %h server
      dns proxy = no
      log level = 1
      syslog = 1
      log file = /var/log/samba/log.%m
      max log size = 1000
      syslog only = yes
      panic action = /usr/share/samba/panic-action %d
      encrypt passwords = true
      passdb backend = tdbsam
      obey pam restrictions = yes
      unix password sync = no
      passwd program = /usr/bin/passwd %u
      passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
      pam password change = yes
      socket options = TCP_NODELAY IPTOS_LOWDELAY
      guest account = nobody
      load printers = no
      disable spoolss = yes
      printing = bsd
      printcap name = /dev/null
      unix extensions = yes
      wide links = no
      create mask = 0777
      directory mask = 0777
      use sendfile = yes
      aio read size = 16384
      aio write size = 16384
      null passwords = no
      local master = yes
      time server = no
      wins support = no

      #======================= Share Definitions =======================
      [david]
      path = /media/b815c7ef-3280-4f67-b063-6c4773bc5cb3/david/
      guest ok = no
      read only = no
      browseable = yes
      inherit acls = no
      inherit permissions = yes
      ea support = no
      store dos attributes = no
      printable = no
      create mask = 0755
      force create mode = 0644
      directory mask = 0755
      force directory mode = 0755
      hide dot files = yes
      valid users = "david"
      invalid users =
      read list =
      write list = "david"


      root@openmediavault:/media/b815c7ef-3280-4f67-b063-6c4773bc5cb3# ls -l
      Display Spoiler
      -rw------- 1 root root 7168 jun 24 22:24 aquota.group
      -rw------- 1 root root 7168 jun 24 22:24 aquota.user
      drwx--S--- 15 david root 4096 jun 19 14:19 david


      root@openmediavault:/media/b815c7ef-3280-4f67-b063-6c4773bc5cb3# getfacl david
      Display Spoiler
      # file: david
      # owner: david
      # group: root
      # flags: -s-
      user::rwx
      group::---
      other::---



      Thanks for having a look!
    • See the single dot? That's the permission on the current folder listing. even though samba runs as privileged user (root) is still has difficulties acceding restricted folders, don't know why.
      Try this

      chmod 755 /media/uuidnumber/
      chown root:root /media/uuidnumber

      replace uuidnumber number for your folder. Then try access again.
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server