TVheadend OMV 3, how?

    • OMV 3.x
    • See: tvheadend.org/projects/tvheadend/wiki/AptRepository
      And (old) guide: Tvheadend Setup and Config

      In command line this would be:

      Shell-Script

      1. apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61
      2. echo "deb https://dl.bintray.com/tvheadend/deb jessie stable" >> /etc/apt/sources.list.d/tvheadend.list
      3. apt-get update
      4. apt-get install tvheadend
      But I'm sure this can be done in the webgui and this is probably the way you want to go, if you are looking for a "newbie guide".

      The post was edited 1 time, last by Steini ().

    • Steini wrote:

      See: tvheadend.org/projects/tvheadend/wiki/AptRepository
      And (old) guide: Tvheadend Setup and Config

      In command line this would be:

      Shell-Script

      1. apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61
      2. echo "deb https://dl.bintray.com/tvheadend/deb jessie stable" >> /etc/apt/sources.list.d/tvheadend
      3. apt-get update
      4. apt-get install tvheadend
      But I'm sure this can be done in the webgui and this is probably the way you want to go, if you are looking for a "newbie guide".
      Thanks! Get this error;

      got the webgui to work and it finds my hd homerun but it won't search. I dont even create a system log?

      Shell-Script

      1. root@openmediavault:/# apt-get install tvheadend
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. Recommended packages:
      6. xmltv-util
      7. The following NEW packages will be installed:
      8. tvheadend
      9. 0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
      10. Need to get 0 B/3708 kB of archives.
      11. After this operation, 13.9 MB of additional disk space will be used.
      12. perl: warning: Setting locale failed.
      13. perl: warning: Please check that your locale settings:
      14. LANGUAGE = "nb_NO:nb:no_NO:no:nn_NO:nn:da:sv:en",
      15. LC_ALL = (unset),
      16. LC_CTYPE = "UTF-8",
      17. LANG = "nb_NO.UTF-8"
      18. are supported and installed on your system.
      19. perl: warning: Falling back to a fallback locale ("nb_NO.UTF-8").
      20. locale: Cannot set LC_CTYPE to default locale: No such file or directory
      21. locale: Kan ikke saette LC_ALL til forvalgt lokale: Ingen slik fil eller filkatalog
      22. Forhåndsoppsetter pakker ...
      23. Selecting previously unselected package tvheadend.
      24. (Reading database ... 40563 files and directories currently installed.)
      25. Preparing to unpack .../tvheadend_4.0.9-6~g668d3e7~jessie_amd64.deb ...
      26. Unpacking tvheadend (4.0.9-6~g668d3e7~jessie) ...
      27. Processing triggers for man-db (2.7.0.2-5) ...
      28. Processing triggers for systemd (215-17+deb8u4) ...
      29. Setting up tvheadend (4.0.9-6~g668d3e7~jessie) ...
      30. locale: Cannot set LC_CTYPE to default locale: No such file or directory
      31. locale: Kan ikke saette LC_ALL til forvalgt lokale: Ingen slik fil eller filkatalog
      32. Processing triggers for systemd (215-17+deb8u4) ...
      33. Creating index of upgradeable packages ...
      34. Creating index of openmediavault plugins ...
      35. N: Ignoring file 'tvheadend' in directory '/etc/apt/sources.list.d/' as it has no filename extension
      36. root@openmediavault:/#
      Display All

      The post was edited 1 time, last by eikum ().

    • Sorry, I had a typo in there. The apt-source file should have the extension .list
      you can correct this by

      Source Code

      1. mv /etc/apt/sources.list.d/tvheadend /etc/apt/sources.list.d/tvheadend.list
      However, you installed the Jessie version of tvheadend which is 4.0.9 If you are fine with that, leave it. The other repo should install you version 4.1.

      As I don't have nor use tvheadend I can't help you with your problem. Maybe ask directly the tvheadend guys?
      tvheadend.org/projects/tvheadend/wiki
      docs.tvheadend.org
    • Hi,

      i tried to install omv3 on a new usb-stick for testing it. And omv Works fine.
      But after installieng TVheadend and rebooting it does not start. Has anyone the same Problem
      and can help me with mine.

      THX
      Cooler Master Elite 110
      ASRock Q1900-ITX
      GeIL Green SO-DIMM 2x2GB, DDR3L-1333
      3x Western Digital WD green 3TB
      1x 60GB BOOT-SSD
      be quiet! System Power 7 300W