NFS mounts, but "Permission Denied" on the client ?

    • OMV 3.x
    • NFS mounts, but "Permission Denied" on the client ?

      Hello everybody !
      I'm using openmediavault for a few months now, first openmediavault v2.x, it used to work fine, and then I got the "Wonderful" idea to make my NAS an "HTPC/NAS", so i decided to install Debian Wheezy, and then openmediavault on top of it, everything was fine except the fact that almost every program I was trying to install were programs with no more updates, no more support, and for some of them "Kodi", I never found how to install it, I was locked by old libraries into the system like libc6...

      Then I decided to upgrade my system to Debian Jessie, (I did a backup on my PC, usb keys, external hard drives...), and I did a fresh install (Formatting all the disks...) and i Installed openmediavault v3.0.x, and... I have a lot of problems with it, lot of omv-extras plugins are not working, some are buggy ... (I know it's testing ^^) but with Jessie I was able to install all the programs I wanted to, like Kodi (The most important for me),

      Okay, there are external programs, not maintained by openmediavault itself, so we need to wait that the developers works on their programs to be working with the new omv.

      But now I'm trying to setup a NFS share on my NAS to share files between my Linux devices (I tried Samba but on my Linux devices it's pretty slow... and there are some disconnections...) NFS was working fine on omv2 and was usefull to do easy file sharing between linux devices...

      Now on omv3.0, i have some problems, I can mount my shared folders, but then, when I try to go on the folder, i'm getting an error : "Permission Denied", and I do not understand why because the mounting of the folder is working well...

      [Blocked Image: http://image.noelshack.com/minis/2016/30/1469538188-20160726-142418-hdr-1.png]

      and the first command (we can't see the end on the picture) is

      Source Code

      1. sudo mount -t nfs -o rw 192.168.1.119:/Maxime ~/test




      Have a great Day, Thank you !


      EDIT :
      First af all I changed the path to " /export/SharedDirectory"

      After few tests... I got some weird problems :
      Now on the RPI, I can Access one of the three shared folders (ONLY when i am logged as root) (the two others : Permission Denied), I can make a Folder in it, then on my Windows PC, i can see the created folder but can't go in it (Do not have the permissions)...

      I think that there are severals problems, some on the NAS, Bad configuration ? Bugs ?
      and permissions problems on my RPI pi, and my other devices, an "ls -al" give me the user root to the shared folders, then as superuser I can do what i want to do (creating files, directories...) (only the one of the shared directories, the others : Permission denied, even logged as root)...

      but the root mount can't be changed !? When i try do mount without being root, it says me "You need to be root to do that", and when the mount is configured in the /etc/fstab, the folders are automatically mounted as root !?



      EDIT 2 : Hmmm, I think I understand some things now, but i didn't solve all the problems,

      So, To have an access to the shared Directory (with my RPI pi) , for the moment, I need to have the option (on the server) no_root_squash (If I understood correctly, this option means that the client machine has the same root privileges to the shared folder as the server machine, is this right ?)
      Without this option, i can't do anything, Permissions denied (regular user or root...)

      There I can mount (as root), I don't know how to mount the directory as a regular user, "normally" via terminal "mount bla bla..." but tells me "You need to be root" or @boot via fstab, (automatically root ?)

      I can do what I want with a regular user (pi) only if I "chmod 777" the shared directory, then I can undo what i did with my Windows Computer via smb (no permissions error)


      My question is now, How can I mount (and use :P ) the shared directories, without being root, without the no_root_squash option, without using chmod 777 for giving the right at "everybody" ? :?:

      Thanks :D

      The post was edited 2 times, last by maxou2600 ().

    • I have what may be a related problem

      Since upgrading my desktop to Ubunto 16.04 I can't access my NFS Shares on OMV from this machine other than as super user.

      Shares mount OK as before and permission are 777 so I should be able to access as non-root users - Error message I get on terminal is "Operation not permitted" and in Nautilus "You do not have the permissions necessary to view the contents of “photoproject”." So it looks like a permission problem, but I can't see how this can be with permission as set:

      drwxrwsrwx 3 nobody 4294967294 4096 Jul 25 18:23 photoproject

      Guess it might be due to a change in the way Ubunto reacts to the "nobody" UID or "4294967294" GID. I don't now if there has been such a change, but they have not previously given me any problems.

      I have tried to align the user and group with a user "omv" created on my desk top UID 999 by setting options in omv as "all_squash,subtree_check,secure,anonuid=999" for this share, but this does not appear to have any effect (I have rebooted my desktop to ensure mounts refreshed). Sill show shares UID and GID as above - Independently of this issue I quite like to sort this out and it might help with this issue.

      Other shares have options as default and they behave the same just "subtree_check,secure"

      I can access the shares as root and I can also access the shares from another machine still running Ubunto 15.04

      I'm on Vers 1.19 (Kralizec) with Linux 3.2.0-4-amd64 Kernel

      There is also some evidence that the problem is intermittent as I briefly got access to another share that have previously been similarly unavailable.

      Thanks
    • I got same problem here with OMV 3.0.30..Also with SMB/CIFS...
      I set up a shared folder for SMB and also for NFS. Permissions in NFS are for IP range 192.168.178.0/24 but i get no access to the folder.. I use it with snapraid and mergerfs..
      MSI B-250-DS3H-G4560 | some RAM | someTB WD red (snapraid) | OMV 4.x (latest) | DD Cine S2 V6.5

      The post was edited 1 time, last by Ruschi ().

    • I want to add to this and say that in my case, one of my shares work without problems. And the other gets the permission denied problem. I have tried to replicate the working share with the non-working share, but the result remains the same; permission denied.
      I will say that this problem is an OMV issue. I want to guess that it has to be an outcome of how OMV interacts with the OS. Is there anyone here who does not have NFS working on a vanilla OMV? This could be helpful to learn if there are differences.