Plex plugin installation fails

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • I was able to get plex to install by following these instructions:

      1) apt-get purge openmediavault-plexmediaserver plexmediaserver
      2) rm -rf /var/lib/plexmediaserver/
      3) userdel plex
      4) groupdel plex

      Then...

      5) apt-get install openmediavault-plexmediaserver

      And I'm not sure 5 is necessary but I did do it. Anyways now the service fails to start. Here is the log file:

      Source Code

      1. May 29 17:24:52 sklobeOMV systemd[1]: Starting Plex Media Server for Linux...
      2. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS=6': /etc/default/plexmediaserver
      3. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_MAX_STACK_SIZE=3000': /etc/default/plexmediaserver
      4. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_TMPDIR=/tmp': /etc/default/plexmediaserver
      5. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_USER=plex': /etc/default/plexmediaserver
      6. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS=6': /etc/default/plexmediaserver
      7. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_MAX_STACK_SIZE=3000': /etc/default/plexmediaserver
      8. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_TMPDIR=/tmp': /etc/default/plexmediaserver
      9. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_USER=plex': /etc/default/plexmediaserver
      10. May 29 17:24:52 sklobeOMV systemd[1]: Started Plex Media Server for Linux.
      11. May 29 17:24:52 sklobeOMV systemd[1]: plexmediaserver.service: main process exited, code=exited, status=255/n/a
      12. May 29 17:24:52 sklobeOMV systemd[1]: Unit plexmediaserver.service entered failed state.
      13. May 29 17:24:57 sklobeOMV systemd[1]: plexmediaserver.service holdoff time over, scheduling restart.
      14. May 29 17:24:57 sklobeOMV systemd[1]: Stopping Plex Media Server for Linux...
      Display All
    • cahooa wrote:

      I was able to get plex to install by following these instructions:

      1) apt-get purge openmediavault-plexmediaserver plexmediaserver
      2) rm -rf /var/lib/plexmediaserver/
      3) userdel plex
      4) groupdel plex

      Then...

      5) apt-get install openmediavault-plexmediaserver

      And I'm not sure 5 is necessary but I did do it. Anyways now the service fails to start. Here is the log file:

      Source Code

      1. May 29 17:24:52 sklobeOMV systemd[1]: Starting Plex Media Server for Linux...
      2. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS=6': /etc/default/plexmediaserver
      3. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_MAX_STACK_SIZE=3000': /etc/default/plexmediaserver
      4. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_TMPDIR=/tmp': /etc/default/plexmediaserver
      5. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_USER=plex': /etc/default/plexmediaserver
      6. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS=6': /etc/default/plexmediaserver
      7. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_MAX_STACK_SIZE=3000': /etc/default/plexmediaserver
      8. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_TMPDIR=/tmp': /etc/default/plexmediaserver
      9. May 29 17:24:52 sklobeOMV systemd[1]: Ignoring invalid environment 'export PLEX_MEDIA_SERVER_USER=plex': /etc/default/plexmediaserver
      10. May 29 17:24:52 sklobeOMV systemd[1]: Started Plex Media Server for Linux.
      11. May 29 17:24:52 sklobeOMV systemd[1]: plexmediaserver.service: main process exited, code=exited, status=255/n/a
      12. May 29 17:24:52 sklobeOMV systemd[1]: Unit plexmediaserver.service entered failed state.
      13. May 29 17:24:57 sklobeOMV systemd[1]: plexmediaserver.service holdoff time over, scheduling restart.
      14. May 29 17:24:57 sklobeOMV systemd[1]: Stopping Plex Media Server for Linux...
      Display All
      This also worked for me with not doing step 5 and just reinstalling through the web gui
    • zllibengood wrote:

      This also worked for me with not doing step 5 and just reinstalling through the web gui

      cahooa wrote:

      Ok so I was able to fix this. I uninstalled Plex through the OMV plug in manager. Then through SSH did steps 1 through 4 above. Then instead of step 5 I reinstalled plex through the OMV plugin manager. Plex seems to be working now.
      This worked for me too! Man, OMV community is the best!
    • dasein wrote:

      zllibengood wrote:

      This also worked for me with not doing step 5 and just reinstalling through the web gui

      cahooa wrote:

      Ok so I was able to fix this. I uninstalled Plex through the OMV plug in manager. Then through SSH did steps 1 through 4 above. Then instead of step 5 I reinstalled plex through the OMV plugin manager. Plex seems to be working now.
      This worked for me too! Man, OMV community is the best!
      New to OMV, been using is for a day or so. Great job on it, loving it!
      Also this worked beautifly thankyou.
    • i tried these steps but still get




      1. Failed to execute XPath query '//services/plexmediaserver'.
      2. Error #0:exception 'OMV\Config\DatabaseException' with message 'Failed to execute XPath query '//services/plexmediaserver'.' in /usr/share/php/openmediavault/config/database.inc:78Stack trace:#0 /usr/share/openmediavault/engined/module/plexmediaserver.inc(58): OMV\Config\Database->get('conf.service.pl...')#1 /usr/share/openmediavault/engined/rpc/services.inc(56): OMVModulePlexMediaServer->getStatus()#2 [internal function]: OMVRpcServiceServices->getStatus(Array, Array)#3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getStatus', Array, Array)#5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 1)#6 {main}



      im on omv 3.0.89




      From the install



      1. Selecting previously unselected package plexmediaserver.
      2. (Reading database ... 89136 files and directories currently installed.)
      3. Preparing to unpack plexmediaserver_1.9.4.4325-1bf240a65_amd64.deb ...
      4. Unpacking plexmediaserver (1.9.4.4325-1bf240a65) ...
      5. Setting up plexmediaserver (1.9.4.4325-1bf240a65) ...
      6. Created symlink from /etc/systemd/system/multi-user.target.wants/plexmediaserver.service to /lib/systemd/system/plexmediaserver.service.
      7. Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      8. dpkg: error processing package plexmediaserver (--install):
      9. subprocess installed post-installation script returned error exit status 1
      10. Processing triggers for systemd (215-17+deb8u7) ...
      11. Processing triggers for mime-support (3.58) ...
      12. Errors were encountered while processing:
      13. plexmediaserver
      14. systemctl status plexmediaserver.service
      15. â plexmediaserver.service - Plex Media Server for Linux
      16. Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
      17. Active: failed (Result: start-limit) since Tue 2017-10-17 12:36:53 BST; 5min ago
      18. Process: 18592 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=1/FAILURE)
      19. Oct 17 12:36:47 systemd[1]: plexmediaserver.service: control process exited, code=exited status=1
      20. Oct 17 12:36:47 systemd[1]: Failed to start Plex Media Server for Linux.
      21. Oct 17 12:36:47 systemd[1]: Unit plexmediaserver.service entered failed state.
      22. Oct 17 12:36:53 systemd[1]: plexmediaserver.service holdoff time over, scheduling restart.
      23. Oct 17 12:36:53 systemd[1]: Stopping Plex Media Server for Linux...
      24. Oct 17 12:36:53 systemd[1]: Starting Plex Media Server for Linux...
      25. Oct 17 12:36:53 systemd[1]: plexmediaserver.service start request repeated too quickly, refusing to start.
      26. Oct 17 12:36:53 systemd[1]: Failed to start Plex Media Server for Linux.
      27. Oct 17 12:36:53 systemd[1]: Unit plexmediaserver.service entered failed state.

      The post was edited 1 time, last by madnlooney ().