Plex plugin installation fails

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex plugin installation fails

      Good morning,

      I have used Plex plugin for several days without issue on OMV 3.0.30. Yesterday a update showed up: plexmediaserver (1.0.3.2461-35f0caa). After installation, Plex
      didn't work anymore. Max76 in this forum discovered same issue. Not being as smart, I tried to delete and re-install Plex plugin. But installation fails:

      Display Spoiler
      Reading package lists...
      Building dependency tree...
      Reading state information...
      The following extra packages will be installed:
      git git-core git-man liberror-perl plexmediaserver
      Suggested packages:
      git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk
      gitweb git-arch git-cvs git-mediawiki git-svn
      Recommended packages:
      patch
      The following NEW packages will be installed:
      git git-core git-man liberror-perl openmediavault-plexmediaserver
      plexmediaserver
      0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
      Need to get 0 B/104 MB of archives.
      After this operation, 239 MB of additional disk space will be used.
      WARNING: The following packages cannot be authenticated!
      openmediavault-plexmediaserver
      Authentication warning overridden.
      Selecting previously unselected package liberror-perl.
      (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 49520 files and directories currently installed.)
      Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
      Unpacking liberror-perl (0.17-1.1) ...
      Selecting previously unselected package git-man.
      Preparing to unpack .../git-man_1%3a2.1.4-2.1+deb8u2_all.deb ...
      Unpacking git-man (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package git.
      Preparing to unpack .../git_1%3a2.1.4-2.1+deb8u2_amd64.deb ...
      Unpacking git (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package git-core.
      Preparing to unpack .../git-core_1%3a2.1.4-2.1+deb8u2_all.deb ...
      Unpacking git-core (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package plexmediaserver.
      Preparing to unpack .../plexmediaserver_1.0.3.2461-35f0caa_amd64.deb ...
      Unpacking plexmediaserver (1.0.3.2461-35f0caa) ...
      Selecting previously unselected package openmediavault-plexmediaserver.
      Preparing to unpack .../openmediavault-plexmediaserver_3.5_all.deb ...
      Unpacking openmediavault-plexmediaserver (3.5) ...
      Processing triggers for man-db (2.7.0.2-5) ...
      Processing triggers for systemd (215-17+deb8u4) ...
      Processing triggers for mime-support (3.58) ...
      Processing triggers for openmediavault (3.0.30) ...
      Restarting engine daemon ...
      Setting up liberror-perl (0.17-1.1) ...
      Setting up git-man (1:2.1.4-2.1+deb8u2) ...
      Setting up git (1:2.1.4-2.1+deb8u2) ...
      Setting up git-core (1:2.1.4-2.1+deb8u2) ...
      Setting up plexmediaserver (1.0.3.2461-35f0caa) ...
      adduser: Warning: The home directory `/var/lib/plexmediaserver' does not belong to the user you are currently creating.
      OK
      Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      dpkg: error processing package plexmediaserver (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault-plexmediaserver:
      openmediavault-plexmediaserver depends on plexmediaserver; however:
      Package plexmediaserver is not configured yet.

      dpkg: error processing package openmediavault-plexmediaserver (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      plexmediaserver
      openmediavault-plexmediaserver

      >>> *************** Error ***************

      <<< *************************************

      >>> *************** Error ***************

      <<< *************************************

      >>> *************** Error ***************


      After closing teh installation window I get error message : Failed to execute XPath query '//services/plexmediaserver'.

      Hope for your support to get Plex up and running again. Thanks in advance.
      HP Microserver Gen8 - 16GB RAM - 1x Kingston 30 GB SSD - 4x 3TB WD Red / Raid 5 with BTRFS fs - OMV 3.0.9x bare metal - Synology DS214 with 1x 4TB WD Red for rsync backup
    • Does not help, unfortunately. You could repair the installed plugin, but I'm not even able to install. I can rename
      the /etc/default/plexmediaserver.prev but no success.
      HP Microserver Gen8 - 16GB RAM - 1x Kingston 30 GB SSD - 4x 3TB WD Red / Raid 5 with BTRFS fs - OMV 3.0.9x bare metal - Synology DS214 with 1x 4TB WD Red for rsync backup
    • @ryecoaaron 2 files were renamed with the installation of the new package. This is the problem.....

      /etc/default/plexmediaserver.prev
      needs to be:
      /etc/default/plexmediaserver

      /etc/systemd/system/plexmediaserver.service.prev
      needs to be:
      /etc/systemd/system/plexmediaservice.service

      Then...
      systemctl daemon-reload

      and then it works again......

      The post was edited 1 time, last by tekkb ().

    • Aaron, they added a unit file at /lib/systemd/system/plexmediaserver.service with the new package. It is identical to the file at /etc/systmed/system/plexmedia.service. Only need 1 unit file and the prev removed from the default file and the override file. I removed the plugin and it removed the plexmediaservice package. The only thing that did not get removed /etc/systemd/system/plexmediaserver.service (the old unit file) and the plex user.

      Thinking about this.... how best to remedy.


      They still have not fixed their unit file. I bitched on their forums over a month ago about this!

      The post was edited 1 time, last by tekkb ().

    • @ryecoaaron This package for jessie really needs a debian folder and more info to setup. The ubuntu package will not setup for OMV as desired. It is missing contol file for dependencies and a conffiles file.

      The .prev on the /etc/default/plexmediaserver file is the only one causing the problem. If there is some way in systemd the package needs to be adjust so this .prev is not add on the default file. The one on the old unit file is ok.

      Trying to figure out how to do this in systemd.

      The post was edited 1 time, last by tekkb ().

    • Update failed with an Error 1 (dpkg --configure), at apt-get upgrade today.

      I solved the problem, first i delete plexmediaserver and the omv-plugin with
      apt-get remove plexmediaserver openmedievault-plexmediaserver

      then

      apt-get clean
      apt-get install plexmediaserver

      But the error 1 still exist, with an problem in systemctl

      I renamed the files liked tekkb

      tekkb wrote:

      @ryecoaaron 2 files were renamed with the installation of the new package. This is the problem.....

      /etc/default/plexmediaserver.prev
      needs to be:
      /etc/default/plexmediaserver

      /etc/systemd/system/plexmediaserver.service.prev
      needs to be:
      /etc/systemd/system/plexmediaservice.service

      mv /etc/systmed/system/plexmedia.service.prev /etc/systmed/system/plexmedia.service
      mv /etc/default/plexmediaserver.prev /etc/default/plexmediaserver

      Then i configure the paket plexmediaserver
      dkpg --configure plexmediaserver

      and to the end install the plugin
      apt-get install openmediavault-plexmediaserver


      Hopefully it helps somebody

      That works fine for me at OMV 3.0.30
      (sorry for my bad englisch)
    • Hello everybody!

      I followed the describtion by Masseter...

      Masseter wrote:

      Update failed with an Error 1 (dpkg --configure), at apt-get upgrade today.

      I solved the problem, first i delete plexmediaserver and the omv-plugin with
      apt-get remove plexmediaserver openmedievault-plexmediaserver

      then

      apt-get clean
      apt-get install plexmediaserver

      But the error 1 still exist, with an problem in systemctl

      I renamed the files liked tekkb

      tekkb wrote:

      @ryecoaaron 2 files were renamed with the installation of the new package. This is the problem.....

      /etc/default/plexmediaserver.prev
      needs to be:
      /etc/default/plexmediaserver

      /etc/systemd/system/plexmediaserver.service.prev
      needs to be:
      /etc/systemd/system/plexmediaservice.service
      mv /etc/systmed/system/plexmedia.service.prev /etc/systmed/system/plexmedia.service
      mv /etc/default/plexmediaserver.prev /etc/default/plexmediaserver

      Then i configure the paket plexmediaserver
      dkpg --configure plexmediaserver

      and to the end install the plugin
      apt-get install openmediavault-plexmediaserver


      Hopefully it helps somebody

      That works fine for me at OMV 3.0.30
      (sorry for my bad englisch)
      ... but the result of the command 'dpkg --configure plexmediaserver' is an error:
      (translation from German...)
      plexmediaserver (1.0.3.2461-35f0caa) will be configured
      OK
      Error to execute operation: file exists
      dpkg: error ... plexmediaserver (--configure)
      Sub-process installed post-installation-script returns error '1'
      Error while processing: plexmediaserver

      I activated and deactivated the plugin several times (as advised by tekkb)... still getting the error 'Failed to execute XPath query '//services/plexmediaserver''.

      Hope for your advice

      The post was edited 1 time, last by tom.smith ().

    • dpkg list is:

      ii openmediavault 3.0.30 all Open network attached storage solution
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-omvextrasorg 3.3.5 all OMV-Extras.org Package Repositories for OpenMediaVault
      iU openmediavault-plexmediaserver 3.6 all OpenMediaVault Plex Media Server plugin
    • Do this and then try to install the plugin again:
      apt-get purge openmediavault-plexmediaserver
      apt-get purge plexmediaserver
      userdel plex

      Then delete the plexmediaserver folder on your data drive, which ever one you put it on.

      Then reinstall the plugin from the plugin section in OMV's Web GUI. Do not do it from command line.