rsync over nfs makes omv unresponsive/crash

    • Resolved
    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • rsync over nfs makes omv unresponsive/crash

      Hi there,
      after I finished the OMV installation, I tried to start a initial upload of my multimedia files.
      It is about 1,5TB, so I thought it would be smart to use rsync and nfs to achieve that. But after a few files ( ~ 1 GB in sum) I "lost" the nas.
      rsync on clientside stops or hangs without a error message. The Webinterface is no longer accessible and even ping says : icmp_seq=203 Destination Host Unreachable

      I tried to get out some info from the logs, but no luck.

      rsync is called via rsync -r --ignore-existing -P Videos/ nas/video/
      Permissions seems to be ok, i can write and delete on the mounted share

      Perhaps you have some ideas ?

      Thanks in advance
    • update:

      If i run rsync over ssh, standard options:
      rsync -r --ignore-existing --progress Videos nas@nas:/media/<uuid>/shared/video/

      it seems to work, .... setting ssh options for better performance: rsync -e "ssh -T -c arcfour -o Compression=no -x" -r --ignore-existing --progre.... produces the error described above

      with standard ssh: 734,359,552 100% 27.90MB/s 0:00:25
      with performance: 733,581,312 100% 79.54MB/s 0:00:08

      So if rsync eats up all the bandwith, working on a 1Gb LAN, why does the nas not come back to network ?
    • Finally, i found a solution :) ... to make it short, I installed kernel backports via omv-extras, everything works fine.

      In Detail:
      I'm using a ARock N3150-ITX Board and figured out, if i switch the LAN-Bandwith in my fritzbox settings (there is a option for 100Mbs (Greenmode) and 1GBs (Powermode)) to 100MBs, eveythings works fine, switching back to 1GBs, causes the networkdevice to stop working with out a message or notification. So I suppose it is network-driver related.