Plex does not download posters for TV shows

    • OMV 3.x
    • @mnui

      Interesting. I'm facing the same Problem since yesterday evening. I've installed OMV (v2.1.1 with kernel 3.16) brand new on my System. Therefore I*ve also installed PMS via plugin-manager (extra repo). First I thought I did something wrong within the "agent Settings" and therefore I've deleted the series-library (not the folder with all the series inside) within PMS and made a new one. Before I made some changes of the Agent but it didn't work.
      So I guess there's something with the PMS-package or a bug or I don't know. Maybe thetvdb changed something so PMS is not working proberly.

      @tekkb
      In my case it's for sure not a problem of the naming. The seasons I named exactly like they are on thetvdb.com. And trust me, I guess that I've installed PMS this year at least 20 times and didn't have any issues so far.

      The interesting is, that I've installed OMV v3.0.31 some days ago (with kernel 4.6.0) and also installed PMS via plugin-manager. I made new libraries (like I do them always the same way). There I didn't have any problems with the series.

      But PMS says that there's an update available (for me as plex pass member). Maybe this fix the issue and we just have to wait till we get the new package via ninthgate.
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware

      OMV-Server-SW: Debian Stretch with backports-Kernel (always up-to-date), OMV v4 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.2.x), Docker with PlexMediaServer, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • There might be an update for plex pass members but the Ubuntu download version from the plex web site is still 1.0.3.2461 (same as in omv-extras mirror).
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • No, sorry. I just clicked on the shown update link and could download PMS v1.1.0.2611. So there's a newer version, but it doesn't help me because I can't install it on OMV2. For converting this package into a wheezy package I don't have the know-how ?(
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware

      OMV-Server-SW: Debian Stretch with backports-Kernel (always up-to-date), OMV v4 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.2.x), Docker with PlexMediaServer, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • I understand that there is a newer version for plex pass members but we don't put the plexpass version in the mirror. Converting the package isn't easy.
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • what about ninthgate.se. The packages that they offer there, are these plex pass or the "normal" free version of PMS?
      Thanks in advance
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware

      OMV-Server-SW: Debian Stretch with backports-Kernel (always up-to-date), OMV v4 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.2.x), Docker with PlexMediaServer, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • He has both packages in that repo and the omv-extras plex repo is a manually updated mirror of ninthgate. How would he have a newer version of free plex than the one on plex's home page?
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I think this is a plex issue, here is the agent log

      Source Code: com.plexapp.agents.thetvdb.log

      1. 2016-08-19 22:16:02,009 (301c) : DEBUG (networking:161) - Fetching 'http://127.0.0.1:32400/services/tmdb?uri=%2Ffind%2F162281%3Fexternal_source%3Dtvdb_id' from the HTTP cache
      2. 2016-08-19 22:16:02,036 (301c) : INFO (logkit:16) - Unable to get unique TMDb match for TVDB id 162281
      3. 2016-08-19 22:16:02,036 (301c) : INFO (logkit:16) - Looking for tmdb_series_url: /tv/None
      4. 2016-08-19 22:16:02,053 (301c) : DEBUG (networking:166) - Requesting 'http://127.0.0.1:32400/services/tmdb?uri=%2Ftv%2FNone'
      5. 2016-08-19 22:16:02,829 (301c) : ERROR (networking:219) - Error opening URL 'http://127.0.0.1:32400/services/tmdb?uri=%2Ftv%2FNone'
      6. 2016-08-19 22:16:02,831 (301c) : INFO (logkit:16) - Error fetching JSON from The Movie Database: http://127.0.0.1:32400/services/tmdb?uri=%2Ftv%2FNone
      7. 2016-08-19 22:16:02,832 (301c) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/162281/actors'
      8. 2016-08-19 22:16:03,286 (301c) : WARNING (data:179) - Error decoding with simplejson, using demjson instead (this will cause a performance hit) - Expecting value: line 42 column 7 (char 899)
      9. 2016-08-19 22:16:03,288 (301c) : DEBUG (preferences:258) - Loaded preferences from DefaultPrefs.json
      10. 2016-08-19 22:16:03,289 (301c) : DEBUG (preferences:178) - Loaded the user preferences for com.plexapp.agents.thetvdb
      11. 2016-08-19 22:16:03,319 (301c) : DEBUG (networking:166) - Requesting 'https://meta.plex.tv/tv_e/162281/vultus+five/1977'
      12. 2016-08-19 22:16:09,048 (301c) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/162281/episodes?page=1'
      13. 2016-08-19 22:16:10,084 (301c) : INFO (logkit:16) - No media for season 0 episode 1 - skipping population of episode data
      14. 2016-08-19 22:16:10,091 (301c) : DEBUG (threadkit:234) - Starting a parallel task set named UpdateEpisodes with 40 tasks
      15. 2016-08-19 22:16:10,094 (1534) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/episodes/2199861'
      16. [....]
      17. 2016-08-19 22:16:19,210 (1534) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/episodes/2200241'
      18. 2016-08-19 22:16:33,775 (2090) : INFO (logkit:16) - Content Error (<urlopen error [Errno 10060] Impossibile stabilire la connessione. Risposta non corretta della parte connessa dopo l'intervallo di tempo oppure mancata risposta dall'host collegato>) -
      19. 2016-08-19 22:16:33,775 (2090) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/episodes/2200081'
      20. 2016-08-19 22:16:35,766 (301c) : DEBUG (threadkit:244) - Parallel task set UpdateEpisodes ended
      21. 2016-08-19 22:16:35,769 (301c) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/162281/images'
      22. 2016-08-19 22:16:35,769 (2090) : CRITICAL (core:574) - Exception in task thread (most recent call last):
      23. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\runtime.py", line 296, in _start
      24. obj._exec()
      25. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\runtime.py", line 243, in _exec
      26. self._result = self._f(*self._args, **self._kwargs)
      27. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\TheTVDB.bundle\Contents\Code\__init__.py", line 890, in UpdateEpisode
      28. additionalHeaders={'Accept-Language': lang})
      29. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\api\parsekit.py", line 97, in ObjectFromString
      30. return self._core.data.json.from_string(string, encoding)
      31. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\data.py", line 177, in from_string
      32. return simplejson.loads(jsonstring, encoding)
      33. File "C:\Program Files (x86)\Plex\Plex Media Server\Exts\simplejson\__init__.py", line 488, in loads
      34. return _default_decoder.decode(s)
      35. File "C:\Program Files (x86)\Plex\Plex Media Server\Exts\simplejson\decoder.py", line 370, in decode
      36. obj, end = self.raw_decode(s)
      37. File "C:\Program Files (x86)\Plex\Plex Media Server\Exts\simplejson\decoder.py", line 389, in raw_decode
      38. return self.scan_once(s, idx=_w(s, idx).end())
      39. TypeError: expected string or buffer
      40. 2016-08-19 22:16:36,275 (301c) : ERROR (networking:219) - Error opening URL 'https://tvdb2.plex.tv/series/162281/images'
      41. 2016-08-19 22:16:36,275 (301c) : INFO (logkit:16) - Content Error (HTTP Error 404: Not Found) -
      42. 2016-08-19 22:16:36,275 (301c) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/162281/images'
      43. 2016-08-19 22:16:36,792 (301c) : ERROR (networking:219) - Error opening URL 'https://tvdb2.plex.tv/series/162281/images'
      44. 2016-08-19 22:16:36,793 (301c) : CRITICAL (core:574) - Exception in the update function of agent named 'TheTVDB', called with guid 'com.plexapp.agents.thetvdb://162281?lang=it' (most recent call last):
      45. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\api\agentkit.py", line 1065, in _update
      46. agent.update(obj, media, lang, **kwargs)
      47. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\TheTVDB.bundle\Contents\Code\__init__.py", line 1088, in update
      48. self.processExtras(xml, metadata.seasons[season_num], lang, ivaNormTitle)
      49. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\api\parsekit.py", line 96, in ObjectFromString
      50. check_size(string, max_size)
      51. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\api\parsekit.py", line 22, in check_size
      52. if len(data) > max_size:
      53. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\networking.py", line 254, in __len__
      54. self.load()
      55. File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-35f0caa\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\networking.py", line 181, in load
      56. f = self._opener.open(req, timeout=self._timeout)
      57. File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 410, in open
      58. response = meth(req, response)
      59. File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 523, in http_response
      60. 'http', request, response, code, msg, hdrs)
      61. File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 448, in error
      62. return self._call_chain(*args)
      63. File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 382, in _call_chain
      64. result = func(*args)
      65. File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 531, in http_error_default
      66. raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
      67. HTTPError: HTTP Error 404: Not Found
      Display All
      OMV 4.1.9 64 - 4.17 backport kernel
      Intel J3160 - 8 GB Ram (2x4)
    • So I made a test. I've removed PMS installed via omv-extra repo and installed PMS again via ninthgate repo. The result is was just the same. No posters. So Igues the problem has something to do with PMS and thetvdb. Unfortunately I can't install the latest version to test if it solves the problem
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware

      OMV-Server-SW: Debian Stretch with backports-Kernel (always up-to-date), OMV v4 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.2.x), Docker with PlexMediaServer, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • Huberer wrote:

      So I made a test. I've removed PMS installed via omv-extra repo and installed PMS again via ninthgate repo. The result is was just the same.
      That is because they are the exact same file.
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I know but just to be sure that this issue has nothing to do with the repo installer. So it looks like the issue is somewhere between PMS and thetvdb.
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware

      OMV-Server-SW: Debian Stretch with backports-Kernel (always up-to-date), OMV v4 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.2.x), Docker with PlexMediaServer, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • So, just for information. On ninthgate.se there's a new PMS-package available (v.1.1.0.2611) and with this package posters under series are working again. :thumbsup:
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware

      OMV-Server-SW: Debian Stretch with backports-Kernel (always up-to-date), OMV v4 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.2.x), Docker with PlexMediaServer, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2