Error when attempting to wipe disks

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Error when attempting to wipe disks

      Apologies, I am new to OMV, and I have seen a similar thread elsewhere but it is marked resolved and none of the advice seemed to fix my issue! I have three 2TB drives (two are formatted with Ext 4, one with NTFS). However, when I try to wipe the drives I get the following:

      Failed to execute command 'export LANG=C; blockdev --rereadpt '/dev/sdb' 2>&1': BLKRRPART: Device or resource busy

      and on clicking "show details" the following:

      Error #4000:exception 'OMVException' with message 'Failed to execute command 'export LANG=C; blockdev --rereadpt '/dev/sdb' 2>&1': BLKRRPART: Device or resource busy' in /usr/share/openmediavault/engined/rpc/diskmgmt.inc:328Stack trace:#0 [internal function]: OMVRpcServiceDiskMgmt->wipe(Array, Array)#1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('wipe', Array, Array)#3 /usr/sbin/omv-engined(500): OMVRpc::exec('DiskMgmt', 'wipe', Array, Array, 1)#4 {main}

      What should I do to fix this (if you would also explain why it resolves the issue I'd appreciate it, just so that I can learn from this experience). None of the disks hold any data.

      My system is: ZOTAC ZBOX CI323 nano running OMV 2.1

      Thanks!
    • Hi,

      I am jumping on this existing thread rather than creating a new one. I'm a new user and suffering the same problem. I've been migrating data from NTFS drives to EXT4 drives and receive the same error as OP when I try to wipe the NTFS drive.

      Based on another thread, I tried the following command via CLI: export LANG=C; blockdev --rereadpt '/dev/sdg' where sdg is the drive I am trying to wipe.
      The output is: BLKRRPART: Device or resource busy

      I also checked mount and sdg is not mounted.

      Any advice is appreciated!
    • If you want to wipe the drive, just dd if=/dev/zero of=/dev/sdg bs=512 count=100000

      If it tells you that it is still busy, it must be mounted somehow. I would reboot.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!