Wordpress plugin installation problem

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wordpress plugin installation problem

      Dear all, have a strange problem I could not find reason / solution for some time already. Maybe I am missing something.

      OMV 2.2.6, kernel 3.2.0-4-686
      Installed OMV extras 2.13.2
      All updates
      Additionally installed and/or working well: FTP, Samba, OpenVPN, Plex, USBbackup, WEBdav

      Have no idea Pre-release updates and Community-maintained should be on or off for wordpress installation, right now they are off.

      Trying to switch on any of them right now gives an error:

      Brainfuck Source Code

      1. Failed to execute command 'export LANG=C; apt-get update 2>&1': Ign file: Release.gpg Ign file: Release Ign file: Translation-en Ign http://dh2k.omv-extras.org plex-wheezy-mirror Release.gpg Hit http://packages.omv-extras.org stoneburner Release.gpg Hit http://packages.openmediavault.org stoneburner Release.gpg Hit http://ppa.launchpad.net precise Release.gpg Hit .............
      2. etc, etc, etc




      What should I do with this?

      Following:
      Trying to install WordPress

      Source Code

      1. > *************** Error ***************
      2. Failed to execute command 'export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-wordpress 2>&1': Reading package lists...
      3. Building dependency tree...
      4. Reading state information...
      5. Some packages could not be installed. This may mean that you have
      6. requested an impossible situation or if you are using the unstable
      7. distribution that some required packages have not yet been created
      8. or been moved out of Incoming.
      9. The following information may help to resolve the situation:
      10. The following packages have unmet dependencies:
      11. openmediavault-wordpress : Depends: openmediavault-mysql (>= 1.0.5) but it is not going to be installed
      12. E: Unable to correct problems, you have held broken packages.
      13. <<< *************************************
      Display All


      Trying to install mySQL:

      Source Code

      1. >> *************** Error ***************
      2. Failed to execute command 'export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-mysql 2>&1': Reading package lists...
      3. Building dependency tree...
      4. Reading state information...
      5. Some packages could not be installed. This may mean that you have
      6. requested an impossible situation or if you are using the unstable
      7. distribution that some required packages have not yet been created
      8. or been moved out of Incoming.
      9. The following information may help to resolve the situation:
      10. The following packages have unmet dependencies:
      11. openmediavault-mysql : Depends: mywebsql but it is not going to be installed
      12. Depends: php5-mysqlnd but it is not going to be installed or
      13. php5-mysql but it is not going to be installed
      14. E: Unable to correct problems, you have held broken packages.
      15. <<< *************************************
      Display All

      Was trying to install via command line, no success.

      Any help appreciated. NOT an expert in linux. Still know how to connect via command-line and execute primitive commands or replace /edit files, if not too complex :(
    • O.K. now I have no problems with enabling pre-release and community maintained updates.

      Still can't install Wordpress. Wordpress plugin installation asks for MySQL. MySQL installation says there is no MyWebSQL and php5-MySQL:

      Source Code

      1. Some packages could not be installed. This may mean that you have
      2. requested an impossible situation or if you are using the unstable
      3. distribution that some required packages have not yet been created
      4. or been moved out of Incoming.
      5. The following information may help to resolve the situation:
      6. The following packages have unmet dependencies:
      7. openmediavault-mysql : Depends: mywebsql but it is not going to be installed
      8. Depends: php5-mysqlnd but it is not going to be installed or
      9. php5-mysql but it is not going to be installed
      10. E: Unable to correct problems, you have held broken packages.
      11. <<< *************************************
      Display All


      Recommendations?
    • Source Code

      1. root@Server2:~# apt-cache policy php5-mysqlnd php5-mysql
      2. php5-mysqlnd:
      3. Installed: (none)
      4. Candidate: 5.4.45-0+deb7u2
      5. Version table:
      6. 5.4.45-0+deb7u2 0
      7. 500 http://ftp.uk.debian.org/debian/ wheezy/main i386 Packages
      8. php5-mysql:
      9. Installed: (none)
      10. Candidate: 5.4.45-0+deb7u2
      11. Version table:
      12. 5.4.45-0+deb7u2 0
      13. 500 http://ftp.uk.debian.org/debian/ wheezy/main i386 Packages
      14. root@Server2:~#
      Display All
    • Source Code

      1. root@Server2:~# apt-get install openmediavault-mysql mywebsql php5-mysqlnd php5-mysql
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. Some packages could not be installed. This may mean that you have
      6. requested an impossible situation or if you are using the unstable
      7. distribution that some required packages have not yet been created
      8. or been moved out of Incoming.
      9. The following information may help to resolve the situation:
      10. The following packages have unmet dependencies:
      11. mywebsql : Depends: php5-pgsql but it is not going to be installed
      12. Depends: php5-sqlite but it is not going to be installed
      13. php5-mysql : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.4.45-0+deb7u4 is to be installed
      14. Conflicts: php5-mysqlnd but 5.4.45-0+deb7u2 is to be installed
      15. php5-mysqlnd : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.4.45-0+deb7u4 is to be installed
      16. Conflicts: php5-mysql but 5.4.45-0+deb7u2 is to be installed
      17. E: Unable to correct problems, you have held broken packages.
      18. root@Server2:~#
      Display All
    • No success so far.
      After omv-aptclean and apt-get -f install an update for omv-extras came up in web interface. I do not remember which version was before, but now omvextras is 2.13.4.

      Wordpress and MySQL still returns the same error messages in both: web interface and command line.


      Source Code

      1. The following packages have unmet dependencies:
      2. mywebsql : Depends: php5-pgsql but it is not going to be installed
      3. Depends: php5-sqlite but it is not going to be installed
      4. php5-mysql : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.4.45-0+deb7u4 is to be installed
      5. Conflicts: php5-mysqlnd but 5.4.45-0+deb7u2 is to be installed
      6. php5-mysqlnd : Depends: php5-common (= 5.4.45-0+deb7u2) but 5.4.45-0+deb7u4 is to be installed
      7. Conflicts: php5-mysql but 5.4.45-0+deb7u2 is to be installed
      8. E: Unable to correct problems, you have held broken packages.
      Made reboot of the server also after all the operations, didnt help.
    • Source Code

      1. root@Server2:~# cat /etc/apt/sources.list
      2. #
      3. # deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official Snapshot i386 LIVE/INSTALL Binary 20150629-09:31]/ wheezy contrib main non-free
      4. #deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official Snapshot i386 LIVE/INSTALL Binary 20150629-09:31]/ wheezy contrib main non-free
      5. deb http://ftp.uk.debian.org/debian/ wheezy main contrib non-free
      6. deb-src http://ftp.uk.debian.org/debian/ wheezy main contrib non-free
      7. root@Server2:~# ls -al /etc/apt/sources.list.d/
      8. total 24
      9. drwxr-xr-x 2 root root 4096 aug 31 18:59 .
      10. drwxr-xr-x 11 root root 4096 aug 31 18:28 ..
      11. -rw-rw-rw- 1 root root 15 aug 31 18:59 omv-extras-org-custom.list
      12. -rw-rw-rw- 1 root root 454 aug 31 18:59 omv-extras-org-stoneburner.list
      13. -rw-r--r-- 1 root root 686 aug 28 16:20 openmediavault.list
      14. -rw-r--r-- 1 root root 45 nov 2 2011 openmediavault-local.list
      15. root@Server2:~#
      Display All
    • That is your problem. You don't have enough Debian repos enabled. Try my repos

      As root:

      nano /etc/apt/sources.list

      Remove all lines and replace with:

      Source Code

      1. deb http://debian.mirrors.tds.net/debian/ wheezy main
      2. deb-src http://debian.mirrors.tds.net/debian/ wheezy main
      3. deb http://security.debian.org/ wheezy/updates main non-free
      4. deb-src http://security.debian.org/ wheezy/updates main non-free
      5. deb http://debian.mirrors.tds.net/debian/ wheezy-updates main non-free
      6. deb-src http://debian.mirrors.tds.net/debian/ wheezy-updates main non-free
      ctrl-o to save
      ctrl-x to exit

      omv-aptclean

      apt-get install openmediavault-mysql
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!