Missing FileSystem

    • OMV 2.x
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Missing FileSystem

      Good morning, in my "File System" section there is a "n/d" unit (attached jpeg) that I can't remove ?( . It seems it is in use somewhere, but I can't find where or how.
      Can you please help me in removing this undesired ghost unit?
      Thanks
      Massimo
      Images
      • Cattura.PNG

        47.4 kB, 1,009×308, viewed 164 times
    • The problem is that the hard drive failed and I unplugged it without unmounting (I guess, because I did't realize what I was doing...)
      The solution you suggested, in other word is not possible: I need to calcel that "ghost" filesystem in another way: is there a file somewhere that I can "nano"?
    • If the Delete button does not become active when you select the drive, you will have to edit /etc/openmediavault/config.xml.
      omv 4.0.6 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Hello, I tried to nano the file /etc/openmediavault/config.xml, but it seems to be beyond my possibilities: it sounds like a mess to me!
      But I discovered that the phantom-missing filesystem was cited in the SMART tests: so I canceled them (THE TESTS), but the filesystem is yet "cited": as I understand it is yet use in some service.
      iS THAT RIGHT?
      So, is it possible to understand WHERE the filesystem is cited, so I can cancel the service and the conseguent citation and make the "cancel" button in the "filesystem section" appare active again?
      Thanks in advance
      Massimo
    • Good evening, sir and thanks for helpèing me. Appreciated...
      Yes, for sure I looked into the "share folder in use", but alla the shares are located in exinting hard disk regularly mounted.
      I foud the "ghosyt" filesystem in a SMART self test & I canceled, but ... nothing, the gost is still "cited" and the erase button inactive...
      I'm thinking to give up on hunting, because it's coming an useless stubborness of an unexpert computer addicted.
      After all, the "ghost" filesystem is only aestetically annoyimg, but doesn't interfere with OMC functionality...
      Thanks again
    • Hi Massimo,

      I had the same because of not having unmounted a filesystem in time, i.e. as long as disk(s) were online and working.
      After trying out the hints, that ryecoaaron gave, I was able to get rid of the "ghost" filesystem.
      I guess you are more familiar with Windows, aren't you?
      If yes, then in OMV GUI enable SSH (under Services) and there, if not enabled by default, "Permit root login" and "Passwort authentication".
      Now at your Windows client install the freeware "WinSCP" and try to login onto your OMV.
      If you are successful so far, please feed back, and I'll tell you the further steps.

      Best regards
      Privately: Intel S1200 Board + i3-3240 CPU + 4GB ECC RAM + LSI SAS2108 Controller in IT mode + 4x3TB SAS RAID5 + OMV 3.0 booting from single HQ SATA drive
      Enterprise: Asus CS-B Board + i3-4330T CPU + 4GB ECC RAM + HP SC44Ge Controller + 3x3TB SATA RAID5 + 3x2TB SATA RAID5 + OMV 2.1 booting from single SAS drive
    • Ok, then

      1. go to /media. View should be something like picture attached. Look into folders listed - the twin, in this case "cdrom/cdrom0" can be ignored -, there must be one empty. Note its name. Here it is "18e2ee88..."

      2. go to /etc/openmediavault and edit config.xml (F4). Search for "<fstab>" and comment out the corresponding <mntent> section (<fsname>!) by bracketing it with "<!--" and "-->" like this:

      Source Code

      1. <!--
      2. <mntent>
      3. <uuid>fa587f78-8de7-4678-b730-ec7160c92ee0</uuid>
      4. <fsname>18e2ee88-7163-408c-ba50-4d5f6456999a</fsname>
      5. <dir>/media/18e2ee88-7163-408c-ba50-4d5f6456999a</dir>
      6. <type>ext4</type>
      7. <opts>defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl</opts>
      8. <freq>0</freq>
      9. <passno>2</passno>
      10. <hidden>0</hidden>
      11. </mntent>
      12. -->
      Display All

      3. go to /etc and edit fstab. There will be one line with the same name. Comment it out by putting a "#" in front of the line:

      Source Code

      1. # UUID=18e2ee88-7163-408c-ba50-4d5f6456999a /media/18e2ee88-7163-408c-ba50-4d5f6456999a ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2

      4. restart OMV. Your ghost filesystem should be away now. At least mine was away, after I did these steps.

      As I find this out being valid for OMV3, I'm not quite sure, whether it is valid for OMV2 as well. But as I still have an OMV2 at company to compare with, I can look for differences if needed.

      Edit: OMV2 at company does not show any differences.

      Hope it helps.
      Johannes
      Images
      • omv1.jpg

        27.1 kB, 548×199, viewed 72 times
      Privately: Intel S1200 Board + i3-3240 CPU + 4GB ECC RAM + LSI SAS2108 Controller in IT mode + 4x3TB SAS RAID5 + OMV 3.0 booting from single HQ SATA drive
      Enterprise: Asus CS-B Board + i3-4330T CPU + 4GB ECC RAM + HP SC44Ge Controller + 3x3TB SATA RAID5 + 3x2TB SATA RAID5 + OMV 2.1 booting from single SAS drive

      The post was edited 1 time, last by Jopa ().