openmediavault-nut install problem

    • OMV 2.x
    • openmediavault-nut install problem

      Hi, I have a problem installing openmediavault-nut on my system.

      the package is half installed and i can't remove it either.

      Source Code

      1. apt-get remove openmediavault-nut
      2. Lecture des listes de paquets... Fait
      3. Construction de l'arbre des dépendances
      4. Lecture des informations d'état... Fait
      5. Les paquets suivants seront ENLEVÉS :
      6. openmediavault-nut
      7. 0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
      8. 1 partiellement installés ou enlevés.
      9. Après cette opération, 353 ko d'espace disque seront libérés.
      10. Souhaitez-vous continuer [O/n] ? o
      11. dpkg: erreur de traitement de openmediavault-nut (--remove) :
      12. Le paquet est dans un état incohérent - vous devriez
      13. le réinstaller avant d'essayer de le supprimer.
      14. Des erreurs ont été rencontrées pendant l'exécution :
      15. openmediavault-nut
      16. Creating index of upgradeable packages ...
      17. Creating index of openmediavault plugins ...
      18. E: Sub-process /usr/bin/dpkg returned an error code (1)
      Display All




      now each time I run apt-get update or upgrade i got a message about it

      Source Code

      1. apt-get upgrade
      2. Lecture des listes de paquets... Fait
      3. Construction de l'arbre des dépendances
      4. Lecture des informations d'état... Fait
      5. 0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
      6. 1 partiellement installés ou enlevés.
      7. Il est nécessaire de prendre 0 o/28,4 ko dans les archives.
      8. Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
      9. Souhaitez-vous continuer [O/n] ? o
      10. dpkg: erreur de traitement de openmediavault-nut (--configure) :
      11. le paquet openmediavault-nut n'est pas prêt pour la configuration
      12. configuration impossible (état actuel « half-installed »)
      13. Des erreurs ont été rencontrées pendant l'exécution :
      14. openmediavault-nut
      15. Creating index of upgradeable packages ...
      16. Creating index of openmediavault plugins ...
      17. E: Sub-process /usr/bin/dpkg returned an error code (1)
      Display All

      I tried downloading it again from sourceforge and manually install it :


      Source Code

      1. dpkg -i openmediavault-nut_3.2.1_all.deb
      2. Sélection du paquet openmediavault-nut précédemment désélectionné.
      3. (Lecture de la base de données... 73978 fichiers et répertoires déjà installés.)
      4. Préparation du remplacement de openmediavault-nut 2.0 (en utilisant openmediavault-nut_3.2.1_all.deb) ...
      5. Dépaquetage de la mise à jour de openmediavault-nut ...
      6. monit: service 'collectd' -- doesn't exist
      7. dpkg : avertissement : le sous-processus ancien script post-removal a retourné une erreur de sortie d'état 1
      8. dpkg: tentative d'exécution du script du nouveau paquet à la place...
      9. monit: service 'collectd' -- doesn't exist
      10. dpkg: erreur de traitement de openmediavault-nut_3.2.1_all.deb (--install) :
      11. le sous-processus nouveau script post-removal a retourné une erreur de sortie d'état 1
      12. monit: service 'collectd' -- doesn't exist
      13. dpkg : erreur lors du nettoyage :
      14. le sous-processus nouveau script post-removal a retourné une erreur de sortie d'état 1
      15. Traitement des actions différées (« triggers ») pour « openmediavault »...
      16. Restarting engine daemon ...
      17. Stopping OpenMediaVault engine daemon: omv-engined.
      18. Starting OpenMediaVault engine daemon: Des erreurs ont été rencontrées pendant l'exécution :
      19. openmediavault-nut_3.2.1_all.debbut if I try : service collectd status it tells me the service is running.
      Display All

      is there a way to first remove nut then install it again ??

      any help welcome

      thanks

      The post was edited 1 time, last by subzero79 ().

    • The last output you're trying to install an omv3 plugin into a 2.0 server?, you shouldn't do that.


      Please remove the plugin and start again.

      apt-get purge openmediavault-nut

      Check that the apt db is clean apt-get -f install[sup][/sup]

      Please post

      dpkg -l | grep openmedia

      cat /etc/debian_version
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Sorry for the late answer, I managed to remove broken package doing the following :

      rm /var/lib/dpkg/info/openmediavault-nut*
      rm /var/cache/apt/archives/openmediavault-nut_2.0_all.deb
      after this I did
      dpkg -l | grep openmedia
      it still shows openmediavault-nut so I removed it with dpkg --purge openmediavault-nut
      and now it doesn't appear in the list

      now I have no more errors when updating or installing new packages, but I always get an error when I try to install openmediavault-nut, I think I'll skip this one :(


      thanks for your help