Hide Dot-Files, Network Trash Folder and Temporary Items

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hide Dot-Files, Network Trash Folder and Temporary Items

      Hi, first sorry for my bad english.

      i have installed OpenMediaVault 0.4.22 with AFP, SMB/CIFS and FTP...
      All works very good. Thank you very much.

      But one thing i don´t like. The Apple Dot-Files & Folders (.Apple......), the Network Trash Folder and Temporary Items Folder.
      In SMB/CIFS i have put this Line in the "Extra Options" an it works very good:

      Source Code

      1. veto files = /Network Trash Folder/Temporary Items/.*


      But my Problem is in the FTP (ProFTPD).
      It is not possible in the main "Extra Option" from FTP. I need to add manually the line in the /etc/proftpd/proftpd.conf in each Share Directory like this:

      Source Code

      1. <Directory /home/ftp/Webcam>
      2. HideFiles "(^\\..*|Network Trash Folder|Temporary Items)$"
      3. <Limit ALL>
      4. AllowUser OR XXX,XXX
      5. DenyAll
      6. </Limit>
      7. <Limit READ DIRS>
      8. AllowUser OR XXX,XXX
      9. AllowUser OR XXX
      10. DenyAll
      11. </Limit>
      12. </Directory>
      Display All


      Is there a another solution?
      A "Extra Options" in the OpenMediaVaultGui for each Share Folder !?

      In the main "Extra Options" it don´t work.

      Source Code

      1. <Directory />
      2. HideFiles "(^\\..*|Network Trash Folder|Temporary Items)$"
      3. </Directory>


      Thank you very much.

      Dodo
    • Re: Hide Dot-Files, Network Trash Folder and Temporary Items

      for proftpd you don't have to do it for all shared folders.
      you should have this in your config as default

      Source Code

      1. <Directory /home/ftp>
      2. HideFiles (welcome.msg)
      3. </Directory>

      change it to

      Source Code

      1. <Directory /home/ftp>
      2. HideFiles "(welcome.msg|Network Trash Folder|Temporary Items|.Apple*)"
      3. </Directory>

      and it should do the trick for all of them. don't forget to restart proftpd

      an update from volker would be appreciated, which could be set as default or as an option to activate it at least
    • Re: Hide Dot-Files, Network Trash Folder and Temporary Items

      Thank you, this is much better. But the .ds_store and .temporary items is not hide.
      I have it now with this line:


      <Directory /home/ftp>
      HideFiles "(^\\..*|Network Trash Folder|Temporary Items|welcome.msg)$"
      </Directory>


      Thank you very much.

      Would be very good when this comes in a new Version for the "Extra Options".
    • Re: Hide Dot-Files, Network Trash Folder and Temporary Items

      you could have done it like this

      Source Code

      1. HideFiles "(welcome.msg|Network Trash Folder|Temporary Items|.*)"


      but i don't know if this good for everyone, maybe the want to see files which starts with a DOT.
      i would hide the specific files, it's not like there are a ton of them.

      .*DS_Store|.temporary|...

      the reason i use .*DS_Store is because sometimes there is a ._.DS_Store

      by the way i never have seen .temporary
    • Re: Hide Dot-Files, Network Trash Folder and Temporary Items

      i have tried this line:

      Source Code

      1. HideFiles "(welcome.msg|Network Trash Folder|Temporary Items|.*)"
      but with this all Files and Folder are hidden.

      Only with this Line

      Source Code

      1. HideFiles "(^\\..*|Network Trash Folder|Temporary Items|welcome.msg)$"
      it works. All dot files are hidden.
      Or so you have write with .*DS_Store|.temporary|......

      Thank you. I´m very happy with your answer, now i need only chance one line and not for all i have.