OMV 2.2.6 Update fails

    • OMV 2.x
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV 2.2.6 Update fails

      I had OMV 2.2.6 and failing updates.

      From reading from this forum I tried the following:

      Run Putty.exe and tried command apt-get update
      However I got error: A error occurred during the signature verification. Repository is not updated and the previous index files will be used. GPG error: packages.omv-extras.org stoneburner Release: The following signatures couldn't be verified because the available: NO_PUBKEY 7AA630A1EDEE7D73public key is not

      Run twice this command: gpg --recv-keys 7AA630A1EDEE7D73 && gpg --export 7AA630A1EDEE7D73 |apt-key add -
      Requesting Key EDEE7D73 from hkp server keys.gnupg.net however the keyserver receive failed: keyserver error

      Run command: apt-get upgrade
      The following packages will be upgraded:
      libcurl3-gnutls ; libicu48 ; linux-image-3.2.0-4-amd64 ; openmediavualt (2.2.7) ; php5-cgi (5.4.45-0+deb7u5) ; php5-cli (5.4.45-0+deb7u5) ; php5-common (5.4.45-0+deb7u5) ; php5-fpm (5.4.45-0+deb7u5)
      And now I have version OpenMediaVault: 2.2.7 (Stone burner)

      Run command: apt-get update to check the signature is fixed but Failed to fetch packages.omve-extras.org/debian/dists/stoneburner/Release and Some index files failed to download. The has been ingored, or old ones used instead.

      I found this issue on the forum is related with omv-extras and found recommendation to update the signing key due to weakness
      Run command: apt-key adv --keyserver keyserver.ubuntu.com --recv EDEE7D73
      But result here:
      gpg: requesting key EDEE7D73 from hkp server keyserver.ubunutu.com
      gpg: Keyserver timed out
      gpg: keyserver receive failed: keyserver error

      It looks this signature is still not working but I am on OMV 2.2.7 version now

      Any idea how to fix my update?

      Thank you
    • Looks like a network issue since apt-key can't contact the keyserver. So, do the following:

      As root:

      wget http://omv-extras.org/omvextras.deb
      dpkg -i omvextras.deb
      Might need apt-get -f install after that
      omv 4.0.11 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • I run command:
      wget omv-extras.org/omvextras.deb - sucessful
      and then dpkg -i omvextras.deb - OK
      also tried to run apt-get -f install but it said 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      for testing purpose for a piece of mind I run also this command: apt-get update BUT this time NO Error with signature.

      So it looks it is working now.

      Thank you ryecoaaron, your help is appreciated!
    • i had a similar situation, and ran the commands you recommended incl the apt-get -f install above.
      results were:

      0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
      N: Ignoring file 'openmediavault.list.save.1' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

      ran the updates check in the gui and all good!

      I also thank you ryecoaaron!