Failed to execute XPath query '//services/plexmediaserver'.

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Failed to execute XPath query '//services/plexmediaserver'.

      I have deinstalled PLEX. Now I´m trying to reinstall plex, but I get the following error:

      Source Code

      1. Reading package lists...Building dependency tree...Reading state information...The following extra packages will be installed: avahi-utils git git-core git-man liberror-perlSuggested packages: git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svnRecommended packages: patchThe following NEW packages will be installed: avahi-utils git git-core git-man liberror-perl openmediavault-plexmediaserver0 upgraded, 6 newly installed, 0 to remove and 1 not upgraded.1 not fully installed or removed.Need to get 4607 kB/4628 kB of archives.After this operation, 23.8 MB of additional disk space will be used.Get:1 http://ftp.uni-koeln.de/debian/ jessie/main avahi-utils amd64 0.6.31-5 [53.0 kB]Get:2 http://ftp.uni-koeln.de/debian/ jessie/main liberror-perl all 0.17-1.1 [22.4 kB]Get:3 http://ftp.uni-koeln.de/debian/ jessie/main git-man all 1:2.1.4-2.1+deb8u2 [1267 kB]Get:4 http://ftp.uni-koeln.de/debian/ jessie/main git amd64 1:2.1.4-2.1+deb8u2 [3262 kB]Get:5 http://ftp.uni-koeln.de/debian/ jessie/main git-core all 1:2.1.4-2.1+deb8u2 [1496 B]Fetched 4607 kB in 1s (3785 kB/s)Selecting previously unselected package avahi-utils.(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 52803 files and directories currently installed.)Preparing to unpack .../avahi-utils_0.6.31-5_amd64.deb ...Unpacking avahi-utils (0.6.31-5) ...Selecting previously unselected package liberror-perl.Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...Unpacking liberror-perl (0.17-1.1) ...Selecting previously unselected package git-man.Preparing to unpack .../git-man_1%3a2.1.4-2.1+deb8u2_all.deb ...Unpacking git-man (1:2.1.4-2.1+deb8u2) ...Selecting previously unselected package git.Preparing to unpack .../git_1%3a2.1.4-2.1+deb8u2_amd64.deb ...Unpacking git (1:2.1.4-2.1+deb8u2) ...Selecting previously unselected package git-core.Preparing to unpack .../git-core_1%3a2.1.4-2.1+deb8u2_all.deb ...Unpacking git-core (1:2.1.4-2.1+deb8u2) ...Selecting previously unselected package openmediavault-plexmediaserver.Preparing to unpack .../openmediavault-plexmediaserver_3.6_all.deb ...Unpacking openmediavault-plexmediaserver (3.6) ...Processing triggers for man-db (2.7.0.2-5) ...Processing triggers for openmediavault (3.0.36) ...Restarting engine daemon ...Setting up plexmediaserver (1.1.3.2700-6f64a8d) ...OKJob for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.dpkg: error processing package plexmediaserver (--configure): subprocess installed post-installation script returned error exit status 1Setting up avahi-utils (0.6.31-5) ...Setting up liberror-perl (0.17-1.1) ...Setting up git-man (1:2.1.4-2.1+deb8u2) ...Setting up git (1:2.1.4-2.1+deb8u2) ...Setting up git-core (1:2.1.4-2.1+deb8u2) ...dpkg: dependency problems prevent configuration of openmediavault-plexmediaserver: openmediavault-plexmediaserver depends on plexmediaserver; however: Package plexmediaserver is not configured yet.
      2. dpkg: error processing package openmediavault-plexmediaserver (--configure): dependency problems - leaving unconfiguredErrors were encountered while processing: plexmediaserver openmediavault-plexmediaserverCreating index of upgradeable packages ...Creating index of openmediavault plugins ...
      3. >>> *************** Error ***************
      4. <<< *************************************
      5. >>> *************** Error ***************
      6. #






      After installing the Package I get the following error several times in OMVs web interface:


      Shell-Script

      1. Fehler #0: exception 'OMV\Config\DatabaseException' with message 'Failed to execute XPath query '//services/plexmediaserver'.' in /usr/share/php/openmediavault/config/database.inc:78 Stack trace: #0 /usr/share/openmediavault/engined/module/plexmediaserver.inc(58): OMV\Config\Database->get('conf.service.pl...') #1 /usr/share/openmediavault/engined/rpc/services.inc(56): OMVModulePlexMediaServer->getStatus() #2 [internal function]: OMVRpcServiceServices->getStatus(Array, Array) #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array) #4 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('getStatus', Array, Array) #5 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 1) #6 {main}

      Any Ideas how to solve this?
    • I´ve found some additional information in syslog:

      Sep 22 17:18:26 omv sh[3972]: /bin/mkdir: das Verzeichnis „/var/lib/plexmediaserver/Library“ kann nicht angelegt werden: Keine Berechtigung
      Sep 22 17:18:26 omv systemd[1]: plexmediaserver.service: control process exited, code=exited status=1
      Sep 22 17:18:26 omv systemd[1]: Failed to start Plex Media Server for Linux.
      Sep 22 17:18:26 omv systemd[1]: Unit plexmediaserver.service entered failed state.
      Sep 22 17:18:31 omv sh[4013]: /bin/mkdir: das Verzeichnis „/var/lib/plexmediaserver/Library“ kann nicht angelegt werden: Keine Berechtigung
    • Ok I think I got it.

      I give group plex permission to /var/lib/plexmediaserver.
      Then I reconfigured the packages.

      Commands I used:
      chgrp -R plex /var/lib/plexmediaserver
      chmod 777 /var/lib/plexmediaserver

      dpkg --configure plexmediaserver openmediavault-plexmediaserver

      Now the error is gone. Plex is running.
    • Hi,

      same error and solution here - but now I've no access to plex server webpage to configure it (neither http nor https). Unfortunally I don't find any log file with errors to this problem.
      It seems that the plex server is running with an old or a default setting - I can see it on my tv, and omv said "service running"

      Please help. Thx

      Greets, Christoph

      ---------
      Hallo,

      hier war es genau der gleiche Fehler - nach längerer Zeit wieder installiert, und erst nach dem oben beschriebenen Vorgehen läuft der Plex Server. Jetzt habe ich aber keinen Zugriff auf die Plex-Konfig-Oberfläche, weder http noch https. Dummerweise finde ich auch weder ein Logfile noch irgendwelche Einträge in anderen Logs dazu.
      Der Server scheint aber zu laufen, ich kann ihn auf meinem TV als DLNA-Dienst sehen, und lt. OMV ist er auch am laufen.

      Was kann das sein? Bitte um Hilfe. Danke

      Gruß, Christoph
      ProLiant MicroServer Gen8 (Intel(R) Celeron(R) CPU G1610T @ 2.30GHz), 12GB Ram,40GB Bootdisk, 3* 4TB WD Red (Raid5) | omv 3.0.54 erasmus | 64 bit | 4.6.0-0.bpo.1-amd64 | omvextrasorg 3.4.9
    • Hello,

      Here you can find some hints:
      support.plex.tv/hc/en-us/artic…ed-Hidden-Server-Settings

      Find your config file and try to modify port or other options.
      Eventually look in PLEX plugin options :)
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!