OMV - Plex Plugin - Configuration & High Load

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV - Plex Plugin - Configuration & High Load

      Good Day everyone !!

      I have been using OMV for the last two years, but only as a simple NAS. Mostly just using the SMB and Rsync features. Amazing software that has been working great for me once I had everything configured. Runs without hiccups and provides great performance.

      I have several other machines running proxmox on which I run all my VM's. One of those VM's is Plex Server, but due to some other issues I have had that Proxmox machine shut down recently.
      Also my NAS machine was severely under utilized, so I decided to try the plex plugin for OMV last night.
      Which brings me to several questions and issue I woke up to this morning.

      First the specs of the OMV machine:
      OVM 2.2.9 - everything updated
      Dual Xenon E5606 Quad Cores - 2.13 GHz
      24 gigs ECC DDR3-1333 Ram
      4 x 1 gig NIC running LACP aggregation
      32 gig SSD running OMV
      2 x 500 gig drives in Raid 1 - Used for user files and other misc storage
      8 x 2TB drives in Raid 6 - Used for Media, Photos, large work file storage, Proxmox VM snapshots, etc......
      One external enclosure connected through USB which I perform backups of all important data on the OMV machine.


      My questions:

      1) I have installed the plex plugin successfully. My question is when I go into the plugin it asks me to choose the drive on which the database will be created. The next line asks about the database folder, but is not letting me create a custom path. Is this correct?
      Does the plex plugin automatically create the database folder? When I search for the created folder under the path that appears... I don't see anything

      2) From what I saw the plex plugin creates a group Plex and user plex. Am I supposed to give recursive read privileges to the plex user/group on the my Media shares ? Is this supposed to happen automatically ?

      3) I am a plex pass member. The current version of plex in OMV is 1.1.3, but the most current plex version is 1.1.4....... Am I able to install this version? I have tried to follow the instructions in the OMV plex plugin, but I was not able to find the 1.1.4 version.


      My Issue:

      - I gave recursive read privileges to Plex user/group on my Movie storage folder. Setup the plex server and it started pulling the media info and everything seemed to be working correctly. I tried to stream a movie and that worked correctly.
      The database options within Plex are set to run cleanup & other tasks between 2 and 5 AM
      When I woke up this morning around 6:30AM I found my server was sending me emails since 2AM with regards to the load of the system.
      The load on the system was over 8..... typically the load is .25 to 1
      The Sensors plugin was showing the temperatures of the CPU's jumped from 39c to over 60c
      Plex was the driving the high load. I restarted the service and everything went back to normal..... no issues the rest of the morning so far.

      I have not looked into the logs yet, but has anyone had this kind of experience?
      What do you think would cause this?



      Thank you !!!
    • I am no pass member but due to a very annoying bug (not able to play video on mobile devices "Streaming session doesn't exist"), which is fixed in the current server release, I am also very looking forward to an update.

      How soon can we expect an update via the plugin?

      Thanks!
    • dazzil wrote:

      How soon can we expect an update via the plugin?
      30 seconds ago :)
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!