Ghost syncing

    • OMV 3.x
    • There is the problem. When you removed the drive, the source became / which will sync the job to the same destination. You needed to delete all references to the bad drive before unplugging it. Now, you might have to manually delete the rsync job from /etc/openmediavault/config.xml and execute omv-mkconf rsync
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I have the same issue.
      Every now and then rsync is completly restoring the drive to the state of the beginning.
      There is noc cron or anacron job and rsync server is of and no settings present.
      Ichecked the above but the problem remains.
      If i only knew what causes this.

      SYSTEM INFO

      ================================================================================
      = OS/Debian information
      ================================================================================
      Distributor ID: Debian
      Description: Debian GNU/Linux 9.5 (stretch)
      Release: 9.5
      Codename: stretch


      ================================================================================
      = openmediavault information
      ================================================================================
      Release: 4.1.9
      Codename: Arrakis


      ================================================================================
      = Date
      ================================================================================
      Tue Aug 21 15:25:14 CEST 2018


      ================================================================================
      = Hostname
      ================================================================================
      storage.local
      ================================================================================
      = System information
      ================================================================================
      Linux storage 4.14.0-0.bpo.3-amd64 #1 SMP Debian 4.14.13-1~bpo9+1 (2018-01-14) x86_64 GNU/Linux
      ================================================================================




      ================================================================================
      = openmediavault plugins
      ================================================================================
      Desired=Unknown/Install/Remove/Purge/Hold
      | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
      |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
      ||/ Name Version Architecture Description
      +++-===========================-============-============-======================================================
      ii openmediavault-clamav 4.1.7-1 all OpenMediaVault ClamAV plugin
      ii openmediavault-diskstats 4.0.2-1 all OpenMediaVault disk monitoring plugin
      rc openmediavault-iscsitarget 3.1.6 all OpenMediaVault iSCSI Enterprise Target plugin
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      rc openmediavault-lvm2 3.2.5 all OpenMediaVault Logical Volume Manager (LVM2) plugin
      ii openmediavault-omvextrasorg 4.1.10 all OMV-Extras.org Package Repositories for OpenMediaVault
      ic openmediavault-owncloud 2.0.3 all OpenMediaVault ownCloud plugin
      ii openmediavault-usbbackup 4.0.5-1 all OpenMediaVault USB/eSATA backup plugin
      --------------------------------------------------------------------------------
    • ok after digging for hours i found the problem.

      Aug 21 10:11:38 storage systemd[1]: Starting Execute the rsync backup jobs when /dev/disk/by-label/hive-backup is plugged in...
      Aug 21 10:11:39 storage rsync-92885e69-e67b-479a-9afd-d7c98ef4f1e2: Please wait, syncing '/srv/dev-disk-by-label-HIVE/hive/' to '/srv/1340c93155d2dc297e79165be195dec2/hive' ...\n
      Aug 21 12:09:42 storage openmediavault-usbbackup-1340c93155d2dc297e79165be195dec2[16302]: rsync error: received SIGINT, SIGTERM, or SIGHUP (code 20) at rsync.c(644) [sender=3.1.2]
      Aug 21 12:09:42 storage openmediavault-usbbackup-1340c93155d2dc297e79165be195dec2[16302]: rsync error: received SIGINT, SIGTERM, or SIGHUP (code 20) at io.c(513) [generator=3.1.2]
      Aug 21 12:09:45 storage systemd[1]: Started Execute the rsync backup jobs when /dev/disk/by-label/hive-backup is plugged in.
      Aug 21 13:10:10 storage avahi-daemon[27925]: Loading service file /services/rsync.service.
      Aug 21 13:10:12 storage avahi-daemon[27925]: Service "storage - Rsync" (/services/rsync.service) successfully established.
      Aug 21 15:40:01 storage cron[588]: (*system*openmediavault-rsync) RELOAD (/etc/cron.d/openmediavault-rsync)

      So the usb-backup addon thinks the raid system is a removalble or at least its triggering the rsync command and this is what id all that.
      The dist upgrade from wheezy to jessie and later the upgrade from omv 3 to 4 may have had to extensive changes. For one the change to "disk-by-label"
      and there is a second raid drive presend with the old config. Looks like i have to reinstall.

      If there is anyone who is willing to help and fix it i would appriciate it.
      thx in advance
    • Users Online 1

      1 Guest