nginx / omv frontend issues

    • OMV 3.x
    • nginx / omv frontend issues

      Tried to install under nginx a server with portnr. 8000 (and other ...) ... did everything with the nginx-plugin. But after changig port 8000 to 8080 i oversaw, that the port was already in use (sabnzbd). Don't know how this infected port 80, but for now the omv-frontend is down.

      tried some diagnosis ... what can I do/try?

      Source Code

      1. omv-firstaid
      2. Updating web control panel settings. Please wait ...
      3. ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl restart nginx 2>&1' with exit code '1': Job for nginx.service failed. See 'systemctl status nginx.service' and 'journalctl -xn' for details.



      Source Code

      1. systemctl status nginx.service
      2. ● nginx.service - A high performance web server and a reverse proxy server
      3. Loaded: loaded (/lib/systemd/system/nginx.service; enabled)
      4. Active: failed (Result: exit-code) since Di 2016-10-25 11:35:31 CEST; 14s ago
      5. Process: 3009 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=1/FAILURE)
      6. Process: 3007 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)

      Source Code

      1. journalctl -xn
      2. -- Logs begin at Di 2016-10-25 11:19:21 CEST, end at Di 2016-10-25 11:37:33 CEST
      3. Okt 25 11:37:31 omv systemd[1]: Failed to set cpu.cfs_quota_us on /system.slice/
      4. Okt 25 11:37:31 omv nginx[3074]: nginx: [emerg] bind() to [::]:80 failed (98: Ad
      5. Okt 25 11:37:31 omv nginx[3074]: nginx: [emerg] bind() to [::]:80 failed (98: Ad
      6. Okt 25 11:37:32 omv nginx[3074]: nginx: [emerg] bind() to [::]:80 failed (98: Ad
      7. Okt 25 11:37:32 omv nginx[3074]: nginx: [emerg] bind() to [::]:80 failed (98: Ad
      8. Okt 25 11:37:33 omv nginx[3074]: nginx: [emerg] bind() to [::]:80 failed (98: Ad
      9. Okt 25 11:37:33 omv nginx[3074]: nginx: [emerg] still could not bind()
      10. Okt 25 11:37:33 omv systemd[1]: nginx.service: control process exited, code=exit
      11. Okt 25 11:37:33 omv systemd[1]: Failed to start A high performance web server an
      12. -- Subject: Unit nginx.service has failed
      13. -- Defined-By: systemd
      14. -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
      15. --
      16. -- Unit nginx.service has failed.
      17. --
      18. -- The result is failed.
      19. Okt 25 11:37:33 omv systemd[1]: Unit nginx.service entered failed state.
      Display All
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras
    • If you write a config with a port in use, nginx can't restart taking the OMV web interface down. The plugin is supposed to check for the port in use. Just remove the nginx plugin with apt-get remove openmediavault-nginx
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Good Morning,

      having the following problem:

      I uninstalled today as I was sure I installed this plugin for next cloud in the past..
      After reading I need to restart the NginX-Service I got this message:
      Display Spoiler
      service nginx restartJob for nginx.service failed. See 'systemctl status nginx.service' and 'journalctl -xn' for details.

      Now I have the problem that I cannot reach the WebGUI. I tried the command of ryecoaaron and after that still no WebGUI...

      can anyone help me?

      I have currently no backup from the OMV... my most important thing is plex... can I make a copy/backup via SSH? Access via Ssh is working fine.
      Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
      2GB DDr2 RAM
      OMV 3.0.94
      2x 3TB Seagate
      1x 2TB Hitachi
      1x 250GB Samsung (Main System OMV )
    • Hi Dkb1972

      thank you for your reply.

      When I try this I got this Error:

      Display Spoiler
      ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] invalid IPv6 address in "[[::]]:80" of the "listen" directive in /etc/nginx/sites-enabled/default:3
      nginx: configuration file /etc/nginx/nginx.conf test failed



      Here you have what's inside of the file "nginx.conf"
      Display Spoiler

      user www-data;
      worker_processes 4;
      pid /run/nginx.pid;

      events {
      worker_connections 768;
      # multi_accept on;
      }

      http {

      ##
      # Basic Settings
      ##

      sendfile on;
      tcp_nopush on;
      tcp_nodelay on;
      keepalive_timeout 65;
      types_hash_max_size 2048;
      # server_tokens off;

      # server_names_hash_bucket_size 64;
      # server_name_in_redirect off;

      include /etc/nginx/mime.types;
      default_type application/octet-stream;

      ##
      # SSL Settings
      ##

      ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
      ssl_prefer_server_ciphers on;

      ##
      # Logging Settings
      ##

      access_log /var/log/nginx/access.log;
      error_log /var/log/nginx/error.log;

      ##
      # Gzip Settings
      ##

      gzip on;
      gzip_disable "msie6";

      # gzip_vary on;
      # gzip_proxied any;
      # gzip_comp_level 6;
      # gzip_buffers 16 8k;
      # gzip_http_version 1.1;
      # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

      ##
      # Virtual Host Configs
      ##

      include /etc/nginx/conf.d/*.conf;
      include /etc/nginx/sites-enabled/*;
      }


      #mail {
      # # See sample authentication script at:
      # # wiki.nginx.org/ImapAuthenticateWithApachePhpScript
      #
      # # auth_http localhost/auth.php;
      # # pop3_capabilities "TOP" "USER";
      # # imap_capabilities "IMAP4rev1" "UIDPLUS";
      #
      # server {
      #listen localhost:110;
      #protocol pop3;
      #proxy on;
      # }
      #
      # server {
      #listen localhost:143;
      #protocol imap;
      #proxy on;
      # }
      #}


      do you have any clue?
      Intel® Celeron® 420 Prozessor (1.6 GHz, 512 KB, L2 Cache)
      2GB DDr2 RAM
      OMV 3.0.94
      2x 3TB Seagate
      1x 2TB Hitachi
      1x 250GB Samsung (Main System OMV )

      The post was edited 1 time, last by Zeb Aztian ().