HDD Spindown in RAID5

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • HDD Spindown in RAID5

      Hello there,

      I did some testing in order to move my NAS from my living room to my room. I tried to change the advanced power management of all my disk and since it is not working properly.
      I got 8 Western Digital Red 3Tb drives in a RAID5 configuration (5*WD30EFRX-68E and 3*WD30EFRX-68A). Since I've installed these drives in my NAS the APM, AAM and spindown settings were all to "Disabled". I put all of there as below:

      Advanced Power Management : 1 - Minimum power usage with standby (spindown)
      Automatic Acoustic Management : Minimum performance, Minimum acoustic output
      Spindown time : 5 minutes

      After some weeks I find out it was not the settings I wanted (way too lok to wake up after a spindown time). So I decided to change the settings as below :

      Advanced Power Management : 128 - Minimum power usage without standby (no spindown)
      Automatic Acoustic Management : Minimum performance, Minimum acoustic output
      Spindown time : Disabled

      It was better than the previous settings I've put on but still if nothing was using the drives it was like 5-10s to access the data when it was under the "sleep mode". So I've decided to put back the settings my drives were running on all these years :

      Advanced Power Management : Disabled
      Automatic Acoustic Management : Disabled
      Spindown time : Disabled

      Seems like these settings are not applied or something. There is still a "sleep mode" like a soft spindown which make me wait 5 to 15 seconds to access my data through SMB. When I log into the OMV web GUI I got the "File system status" widget on the Dashboard. If my drives are in this "sleep mode" the widget will be refreshing until the data is accessible which tells me that the problem is probably no on the share side but on the drive/filesystem.

      Any thoughts on this situation? How can I be sure that the drives settings are really applied?

      Thanks a lot for your support !

      Ben
    • So I did some other test and find out the linux command to change these values.
      After trying to change it to 0 or anything, here's what I did (using hdparm -M; -B; -s) :

      Advanced Power Management : 254 - Maximum performance, maximum power usage
      Automatic Acoustic Management : Maximum performance, maximum acoustic output
      Spindown time : Disabled

      I've rebooted after and it is working as it was at the beginning ...