Deluge plug-in not working

    • OMV 3.x
    • Deluge plug-in not working

      Hi guys,
      I'm having some trouble with plug-ins :(
      in particulare with deluge: I activated it, but it only started deluge-web, not "deluged "daemon.
      So I tried to start it manually from ssh, and here's the result:

      Source Code

      1. root@Delibird:~# deluged
      2. Traceback (most recent call last):
      3. File "/usr/bin/deluged", line 5, in <module>
      4. from pkg_resources import load_entry_point
      5. File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2927, in <module>
      6. @_call_aside
      7. File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2913, in _call_aside
      8. f(*args, **kwargs)
      9. File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2940, in _initialize_master_working_set
      10. working_set = WorkingSet._build_master()
      11. File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 637, in _build_master
      12. return cls._build_from_requirements(__requires__)
      13. File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 650, in _build_from_requirements
      14. dists = ws.resolve(reqs, Environment())
      15. File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 829, in resolve
      16. raise DistributionNotFound(req, requirers)
      17. pkg_resources.DistributionNotFound: The 'deluge==1.3.13' distribution was not found and is required by the application
      Display All



      I then tried to uninstall and reinstall it from the webgui, but here's what I get:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --auto-remove --purge remove openmediavault-deluge 2>&1': Reading package lists... Building dependency tree... Reading state information... You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: deluged : Depends: deluge-common (= 1.3.13-0~jessie-dip) but 1.3.10-3 is to be installed E : Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

      Source Code

      1. Error #0:
      2. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --auto-remove --purge remove openmediavault-deluge 2>&1': Reading package lists...
      3. Building dependency tree...
      4. Reading state information...
      5. You might want to run 'apt-get -f install' to correct these:
      6. The following packages have unmet dependencies:
      7. deluged : Depends: deluge-common (= 1.3.13-0~jessie-dip) but 1.3.10-3 is to be installed
      8. E
      9. :
      10. Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
      11. ' in /usr/share/openmediavault/engined/rpc/pluginmgmt.inc:151
      12. Stack trace:
      13. #0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMVRpcServicePluginMgmt->{closure}('/tmp/bgstatusKc...', '/tmp/bgoutputjX...')
      14. #1 /usr/share/openmediavault/engined/rpc/pluginmgmt.inc(153): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      15. #2 [internal function]: OMVRpcServicePluginMgmt->remove(Array, Array)
      16. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      17. #4 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('remove', Array, Array)
      18. #5 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('Plugin', 'remove', Array, Array, 1)
      19. #6 {main}
      Display All
      Finally I even tried to install deluge 1.3.13 from here: dipconsultants.com/jessie/
      but when I tried to install deluged, I get this error:

      Source Code

      1. root@Delibird:/media/RAID1/Dati# dpkg -i deluged_1.3.13-0~jessie-dip_all.deb
      2. (Reading database ... 79993 files and directories currently installed.)
      3. Preparing to unpack deluged_1.3.13-0~jessie-dip_all.deb ...
      4. Unpacking deluged (1.3.13-0~jessie-dip) over (1.3.13-0~jessie-dip) ...
      5. dpkg: dependency problems prevent configuration of deluged:
      6. deluged depends on deluge-common (= 1.3.13-0~jessie-dip); however:
      7. Version of deluge-common on system is 1.3.10-3.
      8. dpkg: error processing package deluged (--install):
      9. dependency problems - leaving unconfigured
      10. Processing triggers for man-db (2.7.0.2-5) ...
      11. Errors were encountered while processing:
      12. deluged
      Display All


      What I want to do is install deluge (Deluged+deluge-web) 1.3.13 and have it works, how can I do? :(
      Intel G4400 - Asrock H170M Pro4S - 8GB ram - 2x4TB WD RED in RAID1 - ZFS Mirror 2x6TB Seagate Ironwolf
      OMV 4.1.4 - Kernel 4.14 backport 3 - omvextrasorg 4.1.2
    • You don't say what version of OMV you are running.

      I am on OMV 2.2.13 and am running the following Deluge 1.3.13 components:

      deluge-console
      deluge-web
      deluge-common
      deluge-webui
      deluged

      These were installed without the benefit of any OMV Deluge plugin - and I don't think one is even available for OMV 2.x.

      All I did was enable the Download Mangers repo which pulled these two into /etc/apt/sources.list.d/omv-extras-org-stoneburner.list

      # miller repo
      deb dh2k.omv-extras.org/debian/ stoneburner-miller main
      deb ppa.launchpad.net/deluge-team/ppa/ubuntu precise main

      I have no idea what the OMV Deluge plugin is capable of, and as I have said I have never seen it.

      Deluge does everything I need it to without any problems, on PMV 2.2.13. I did have to cobble together the init script and do the initial configuration by hand, but this is all well documented in the Deluge User Guide:

      dev.deluge-torrent.org/wiki/UserGuide
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380

      The post was edited 2 times, last by gderf ().