Using sym links in samba

    • OMV 3.x
    • Resolved
    • Using sym links in samba

      This will help if you are using sym links.

      follow symlinks = yes
      wide links = yes
      unix extensions = no

      Default install has wide no and unix yes.Once I changed /etc/samba/smb.conf settings to the above sym links worked great.



      Side notes:I could share one folder with a many folders from all over the server. really nice to handle a big sharing sever for media and software for family.I just hit 10TB of Plex Media and 8TB of ISO's. Iso i need to clean up i think .. lol.But plex I moved to a docker container so I would teach myself docker to help me at work.It is doing really well there, Surprised myself. I thought it would suck. But it acts just like it did any other place I have had it.Docker is something to look at and its kinda fun to learn. And $$$ if you work in the industry.

      The post was edited 3 times, last by Ranger ().

    • You should use the environemnt variables in /etc/default/openmediavault to make your changes permanent if the SMB configuration is modified triggered by changes in the WebGUI.

      The variables are called

      OMV_SAMBA_SHARE_FOLLOWSYMLINKS

      see github.com/openmediavault/open…t/mkconf/samba.d/20shares

      and

      OMV_SAMBA_UNIXEXTENSIONS

      see github.com/openmediavault/open…t/mkconf/samba.d/10global
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • votdev wrote:

      You should use the environemnt variables in /etc/default/openmediavault to make your changes permanent if the SMB configuration is modified triggered by changes in the WebGUI.

      The variables are called

      OMV_SAMBA_SHARE_FOLLOWSYMLINKS

      see github.com/openmediavault/open…t/mkconf/samba.d/20shares

      and

      OMV_SAMBA_UNIXEXTENSIONS

      see github.com/openmediavault/open…t/mkconf/samba.d/10global

      Hi votdev,

      Adding next lines, at end of /etc/default/openmediavault file?

      Source Code

      1. OMV_SAMBA_SHARE_FOLLOWSYMLINKS="yes"
      2. OMV_SAMBA_WIDELINKS="yes"
      3. OMV_SAMBA_UNIXEXTENSIONS="no"
      Needs reboot server?



      Thanks
    • Yes, add them to /etc/default/openmediavault. After that execute

      Shell-Script

      1. $ omv-mkconf samba
      2. $ systemctl reload smbd.service
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Does this still work with omv 4.1.6 .. I made the changes , omv-mkconf ..and systemctl reload smbd.service

      but still not visible from windows 7 .

      I tried also to put these options it web SMB/CIFS configuration .. and it doesn't work !!

      SMB/CIFS extra options:
      unix extensions = no

      Share extra options:
      follow symlinks = yeswide links = yes

      Something is not working as expected, but what ?

      The post was edited 1 time, last by Rizos39: Additional information: I checked the /etc/samba/smb.conf and there are these change: root@omv4vm:~# diff smb-before.txt smb-after.txt 1c1 < root@omv4vm:~# cat /etc/samba/smb.conf > smb-before.txt --- > root@omv4vm:~# cat /etc/samba/smb.conf > smb-after.txt 26,27c26,27 < unix extensions = yes < wide links = no --- > unix extensions = no > wide links = yes root@omv4vm:~# ().

    • Additional info


      I checked the /etc/samba/smb.conf and there are these change:

      root@omv4vm:~# diff smb-before.txt smb-after.txt
      1c1
      < root@omv4vm:~# cat /etc/samba/smb.conf > smb-before.txt
      ---
      > root@omv4vm:~# cat /etc/samba/smb.conf > smb-after.txt
      26,27c26,27
      < unix extensions = yes
      < wide links = no
      ---
      > unix extensions = no
      > wide links = yes
      root@omv4vm:~#
    • I answer to myself, in the hope it is helpfull for others :)

      The problem is that the destination of the symbolic link is inside of

      root@omv4vm:~# ls -lad /root
      drwx------ 5 root root 4096 Aug 13 20:46 /root
      root@omv4vm:~#

      ARgg ........ why that doesnt say no privileges ? instead it does not appear at all !!!!!!!!!!!