BTRFS on Armbian with OMV 3 fails

    • OMV 3.x
    • BTRFS on Armbian with OMV 3 fails

      Hallo,

      I tried to format my HDD for my Cubietruck running Armbian Jessie and OMV 3.0.52 with BTRFS.
      All I got is an error message:

      Source Code

      1. Fehler #0:
      2. exception 'OMV\Exception' with message 'Failed to read file '/tmp/bgstatussl4fyi' (size=0).' in /usr/share/php/openmediavault/json/file.inc:199
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/json/file.inc(214): OMV\Json\File->getContents()
      5. #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(334): OMV\Json\File->read()
      6. #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(525): OMV\Rpc\ServiceAbstract->updateBgProcStatus('/tmp/bgstatussl...', 'outputfilename', '/tmp/bgoutputbC...')
      7. #3 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(646): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure), NULL, Object(Closure))
      8. #4 [internal function]: OMVRpcServiceFileSystemMgmt->create(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('create', Array, Array)
      11. #7 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('FileSystemMgmt', 'create', Array, Array, 1)
      12. #8 {main}
      Display All
      I just wanted to report the error. As this is a very exotic configuration, I don't know, if this is relevant. ?(
      I used ext4 then instead, and it worked fine.

      Regards, Tomte