UFW or iptables from commandline

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • UFW or iptables from commandline

      I have a fresh installation of OMV 2.0 and tried to setup a firewall, but from console.

      So I apt-get install ufw and set some basic rules:
      ufw allow ssh
      ufw default deny incoming
      ufw default allow outgoing
      ufw enable

      Everything was working normal, but after reboot, there was no internet connection. I had to login to console and disable firewall - then it started working.

      I also tried with iptables from console:
      iptables -A INPUT -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
      iptables -A INPUT -p tcp --dport 22 -j ACCEPT
      iptables -A INPUT -p tcp --dport 80 -j ACCEPT
      iptables -I INPUT 1 -i lo -j ACCEPT
      iptables -P INPUT DROP
      iptables -A INPUT -j DROP

      Again - everything is working fine, but after reboot, no internet from the machine.

      In fact, I am using OpenVPN client on the device, and since there is no internet, it cannot login. After I say iptables -L, openvpn connection is established normally.

      It seems something is disabling internet when I set up firewall manually... maybe OMV is interfereing with comman-line firewalls in some way?
    • Indeed. Check the improvements in OMV3: github.com/openmediavault/open…4284e4f1c2c76845442a77cdb
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • UFW is just a frontend for iptables. OMV does have it's own frontend for iptables in the webGUI under the network tab. It kind of sounds to me that UFW is clashing with OMV for some reason or another. I would remove UFW and just configure your firewall through OMV's webGUI to see if that solves your issues. Also, double check your network settings while you're there.