[OMV Extras] - Is it possible to enable plugin repo's from command line?

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [OMV Extras] - Is it possible to enable plugin repo's from command line?

      Today I bit the bullet and upgraded OMV 2.0 to 3.0.
      Went without a hitch and everything works fine except for the webinterface, which gives me the following error:

      Source Code

      1. Failed to connect to socket: No such file or directory



      Following the problem led me to the following thread: forum.openmediavault.org/index…ket-after-upgrade-to-3-0/
      This led me to the conclusion I have plugins installed which do not work with 3.0 (yet). However running "dpkg -l | grep openm" prints the following list, which by my knowledge should be compatible:



      Source Code

      1. ii openmediavault 3.0.53 all Open network attached storage solution
      2. rc openmediavault-couchpotato 1.0.3 all OpenMediaVault CouchPotatoServer plugin
      3. rc openmediavault-fail2ban 1.1.5 all OpenMediaVault Fail2ban plugin
      4. ii openmediavault-flashmemory 3.4.3 all folder2ram plugin for OpenMediaVault
      5. rc openmediavault-headphones 1.0.2 all OpenMediaVault Headphones plugin
      6. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      7. ii openmediavault-locate 3.3 all locate plugin for OpenMediaVault.
      8. ii openmediavault-mysql 3.0.4 all MySQL plugin for OpenMediaVault.
      9. ii openmediavault-omvextrasorg 3.4.8 all OMV-Extras.org Package Repositories for OpenMediaVault
      10. ii openmediavault-plexmediaserver 3.7 all OpenMediaVault Plex Media Server plugin
      11. rc openmediavault-sensors 1.0.23 all Provides a cpu temperature monitor
      12. ii openmediavault-snapraid 3.3 all snapraid plugin for OpenMediaVault.
      13. ii openmediavault-sonarr 1.1 all OpenMediaVault Sonarr(NzbDrone) plugin
      14. ii openmediavault-transmissionbt 3.0.9 all OpenMediaVault Transmission (BitTorrent client) plugin.
      Display All
      Still had the same web interface error so I tried reinstalling OMV-Extra's with:

      Source Code

      1. wget http://omv-extras.org/openmediavault-omvextrasorg_latest_all3.deb
      2. dpkg -i openmediavault-omvextrasorg_latest_all3.deb
      3. apt-get update
      Still this did not resolve my error. So I tried removing some plugins, which also did not work. Thus I tried reinstalling plugins but when doing an "apt-get install --reinstall openmediavault-...", I get the following message:

      Source Code

      1. Reinstallation of openmediavault-plexmediaserver is not possible, it cannot be downloaded.

      Which lead me to the conclusion that re-installation of omv-extras disabled the plugin repo's I had selected under the OMV-Extra's tab in the web interface. Normally, it would be as easy as logging in and selecting the repo's I want but since the web interface is not working is there a way to manually enable those repo's? Or is my thinking twisted?
    • Yep, you can enable the repos from the command line but you have to edit /etc/openmediavault/config.xml. Just change the enable field to 1 instead of 0. Then omv-mkconf omvextras.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!