Erledigt ! ----> DEUTSCH: Erweiterung des RAID 5

    • OMV 3.x
    • Resolved
    • Erledigt ! ----> DEUTSCH: Erweiterung des RAID 5

      Hallo und Gruß ins Forum !

      Wie mein Name schon sagt, ich bin OMV Neuling.

      Mein Problem: RAID wird nicht erweitert!
      Habe mir vor einiger Zeit ein NAS zurecht geklöppelt und vorerst nur 4 HDD zu einem RAID 5 aufgebaut.

      Nach einiger Zeit war das RAID 5 voll und ich wollte 2 weitere HDD´s hinzufügen.
      Gesagt getan 2 HDD´s rein, RAID erweitert und danach habe ich das Dateisystem erweitert.

      Das es eine Zeit dauert, bis das RAID erweitert ist, ist mir klar aber 2 Tage dauert es jetzt schon.

      Es werden mir diese Meldungen angezeigt:

      Systemprotokoll wrote:

      fs_media_059a030b-86ff-48f0-8ec9-88b37704934d' space usage 99.9% matches resource limit [space usage>80.0%]

      Details in der RAID Verwaltung wrote:

      Update Time : Wed Nov 30 12:16:45 2016
      State : clean
      Active Devices : 4
      Working Devices : 6
      Failed Devices : 0
      Spare Devices :2
      Kann mir jemand helfen, oder muss ich mich nur etwas in Geduld üben ? ;(

      Danke
    • Du hast 2 Platten ins Raid mit reingenommen. Das allerdings als Spare, d.h. wenn eine von deinen 4 Platten ausfällt, springen die anderen direkt ein.
      Wahrscheinlich hast du beim Hinzufügen was übersehen. Aber da kommen die Pros noch...

      HTH so far
      --
      Get a Rose Tattoo...

      HP t5740 with Expansion and USB3, Inateck Case w/ 3TB WD-Green
      OMV 2.2.14 Stone burner i386|3.2.0-4-686-pae
    • Dropkick Murphy wrote:

      .... Das allerdings als Spare, d.h. wenn eine von deinen 4 Platten ausfällt, springen die anderen direkt ein....
      Danke für die Rückmeldung.
      Das habe ich auch so gelesen, doch wie behbe ich das Problem?

      Seit ca. 5 Tagen ist nichts verändert. Ich hatte gedacht, dass das Raid etwas Zeit benötigt um eine Neustrukturierung duchzuführen.

      Ich benötige die Hilfe der Profis.

      EDIT: Es tut sich was ..... muss nur noch ca 589 Minuten warten.
      Gedult war der Schlüssel.

      Sollten Morgen noch Probleme sein, melde ich mich nochmal.

      EDIT_2:

      Hat doch nicht so funktioniert.

      4 HDD´s sind aktiv und 2 HDD´s sind spare ! Über das Webinterface kann ich sie wohl nicht hinzufügen.
      Kann mir jemand sagen, wie ich es per Terminal (SSH) anstellen kann?
      Ich will mir ja auch nicht die Daten zerschießen !

      The post was edited 3 times, last by OMV_newbie: EDIT: Nachtrag ! + Nachtrag 2 !! ().

    • So,

      nachdem ich per ssh das Raid per folgenden Befehlen

      Source Code

      1. sudo mdadm --grow --raid-devices=6 /dev/md0 --backup-file=/tmp/md0.bak
      2. sudo umount /dev/md0
      3. sudo resize2fs /dev/md0
      4. sudo mount /dev/md0
      erweitert hatte, wurden mir auch alle 6 HDDś angezeigt. Diese Anzeige erhalte ich unter der RAID-Verwaltung [IMG:http://www.bilder-upload.eu/thumb/4319bf-1481124623.png]
      Soweit so gut, doch wenn ich dann ins Dateisystem gehe stehen nur 5,6x TB von 21,xx TB zur Verfügung.
      Es sollten aber 27,29 TB sein !
      Da stimmt doch etwas nicht !! :(

      Wenn ich unter Dateisystem die Größe ändern möchte bekomme ich diese Fehlermeldung:
      [IMG:http://www.bilder-upload.eu/thumb/15b4dd-1481125132.png]

      Es ist auch so, das die 6 Platte (sde) auchmal einfach so verschwindet.
      Muss evtl. dazusagen, dass die /dev/sde + /dev/sdf durch einen SATA-Controller betrieben werden.

      Kann/möchte mir den wirklich keiner helfen?
    • Ja, klar ;) :thumbup:
      Ergebnis ----> [IMG:http://www.bilder-upload.eu/thumb/3817ae-1481126308.png]

      Aktuell arbeitet das RAID

      Update Time : Wed Dec 7 17:01:23 2016
      State : clean, degraded, recovering
      Active Devices : 5
      Working Devices : 6
      Failed Devices : 0
      Spare Devices : 1
      Layout : left-symmetric
      Chunk Size : 512K
      Rebuild Status : 3% complete

      The post was edited 1 time, last by OMV_newbie ().