Apple OSX and OMV NFS Shares Absolutely Baffling...

    • OMV 3.x
    • Apple OSX and OMV NFS Shares Absolutely Baffling...

      So I've got NFS set up and everything as perfect as can be under OMV 3.0 and my darn Apple OSX Mac Mini just refuses to browse the NFS shares.

      I've tried all the uid and pid stuff on the shares. My last 2 tries were:

      subtree_check,all_squash,insecure,anongid=100,anonuid=0
      subtree_check,all_squash,insecure

      With no luck. Kodi refuses to browse the NFS server at all, and won't even use the manual adds of shares I added to the sources.xml.

      When I try and just browse to nfs://192.168.X.XXX on the Mac, it says "You do not have permission to access this server".

      So, I'm stumped. I know NFS doesn't have users and passwords, but it's obvious there needs to be some sort of synchonized user account or LAN setting or something here somewhere on the Mac and/or in OMV to get this working.

      I read somewhere that I should just use SMB, which works great in Kodi on my Mac (where I do all my Kodi Library work)...But I seem to always recall that NFS had a much better reputation for speed when it comes to streaming?

      Every other machine in my house, from Kodi on android, to Kodi on Windows 10, can see OMV's NFS shares no problem. It's just the OSX machine that doesn't connect to them, and that's the most important one! Has Apple just borked up NFS?

      Anyone else solved the NFS problem on an OSX machine to talk to OMV NFS shares?
    • You're not accessing the exports correctly. You need this from finder.

      nfs://IP/export/sharename

      For nfs4 or use the pseudo root fs mount you need to drop down to CLI or use NFS manager.

      Kodi also works fine with me using NFS. No idea how are you configuring it. If you're not too much into linux Samba should be enough.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • I'm an idiot. That's what happens when you spend your day totally rebuilding your server. You get dumb after 8 hours.

      I was forgetting the "export" in the path. That fixed Kodi right up for me. Kodi still refuses to browse the server at the root level when I add the source in the GUI, but adding the source manually in sources.xml works perfectly.

      I'm not sure if NFS is still the best solution for streaming in home these days, but my variety of Kodi boxes (openelec, nvidia shield, PCs, etc) all seem to agree on NFS so it's just easier.
    • bbddpp wrote:

      Yes, try setting them up manually using a Kodi sources.xml file. NFS browsing inside of Kodi seems to be broken in OSX.
      This was working before, i don't use in osx, but i did tested a few months ago in osx. Back to testing (since then i ran out of space i export my share in mergerfs folder) now it seems broken, doesn't display folders at all.
      Do you have a similar set up using mergerfs?
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Just to inform you that nfs and OSX is a pain in the ...
      Apple is going the new way and force to use smb (Samba). Even their afp-Protokoll isn't updated anymore since years. More you can read here.
      So my suggestion is to use nfs for Kodi (Linux/Android) and smb for OSX and Windows. Or just use smb for all your devices
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware

      OMV-Server-SW: Debian Stretch with backports-Kernel (always up-to-date), OMV v4 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.2.x), Docker with PlexMediaServer, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • I have so many boxes around my house that use the same SQL database. Fire TVs, Raspberry Pi, HTPC, Nvidia Shield...I always felt NFS made sense because it used to be fastest (maybe SMB beats it now I dunno)...But NFS was universal and worked everywhere and SMB used to not work on all boxes.

      Maybe that has changed since the last time I set this all up.
    • On my setup, nfs and samba both saturate gigabit. I just use samba because it is easier to put content on samba from Windows.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!