RDP to Virtualbox

    • OMV 3.x
    • I didn't know you could do that,

      nice
      omv 3.0.56 erasmus | 64 bit | 4.7 backport kernel
      SM-SC846(24 bay)| H8DME-2 |2x AMD Opteron Hex Core 2431 @ 2.4Ghz |49GB RAM
      PSU: Silencer 760 Watt ATX Power Supply
      IPMI |3xSAT2-MV8 PCI-X |4 NIC : 2x Realteck + 1 Intel Pro Dual port PCI-e card
      OS on 2×120 SSD in RAID-1 |
      DATA: 3x3T| 4x2T | 2x1T
    • ryecoaaron wrote:

      You can enable a Virtualbox rdp server that allows to connect to the guest just like you were setting in front of the machine. This rdp server is disabled by default but can be enabled with:

      su - vbox -c 'VBoxManage modifyvm "VM name" --vrde on'

      The following command will list the VMs on the host:

      su - vbox -c 'VBoxManage list vms'
      So, we run these commands on OMV ?
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10
    • tinh_x7 wrote:

      So, we run these commands on OMV ?
      Yep. as root. I will change my post.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I can't use Virtualbox either. It only tells me "vnc://ip:port". But if I click on it, nothing happens ("site cannot be found"). If I enter this into a vnc-client --> nothing. How can I use RDP over the virtualbox host again? It worked so great with "rdp://ip:port" instead of "vnc://ip:port". I did the --vrde on thing but it didn't help, still get this silly vnc-stuff
    • Hey guys, I've had the same problem today: I'd wanted to install a fresh debian VM but was unable to login to the vrdp-session for using the graphical debian installer.
      I wasn't able to connect via rdp nor via vnc (using Ubuntu with Vinagre Client). After trying different network settings (NAT, bridged...), googling around, reading docs on the omv forum and the virtualbox manual, I found an easy solution for my "issue": When connecting to the machine via rdp, you have to specify a user in the connection window, even if you've choose Authentication Method "None" in the phpVirtualBox settings! Works like a charm! :whistling:

      Maybe I'm just the most stupid user in the world, but maybe this may help anyone with the same foolishness ;)
    • As far as I understand the vrdp option in VirtualBox, you have to see this as a kind of console access to the virtual machine, similar to a physical screen connected to a physical video port (e.g. VGA) on a dedicated machine.
      There is no need for the guest os to support rdp or even less complex: There is no need for a guest os at all!
      VBox will provide video output from the virtual machine via rdp on the port that you choose (default is the port range 9000 to 9100, resulting in port 9000 as long as it is the first vm on your host).
      If you're fast enough, you will probably see the virtual bios (I never tried that out...).
    • Hi,

      I've got the same problem with the last update (5.2.22).
      It is a virtualbox problem an comes with the version 5.2.20 (see here).
      A patch was paste to the svn of virtualbox (see here...) an now we have to wait to the
      new version from debian-backports.

      I think there is nothing we can do to fix it with 'some' settings.

      Regards :)

      P.S.:
      I've posted the problem to the debian-backports mailing-list. Now we must wait for the update... ;)

      The post was edited 3 times, last by Fraiser ().

    • Here are the amd64 packages with the fix compiled in - omv-extras.org/testing/vb/

      Not going to put these in the repo.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!