Quick Wipe Error w/ "Storage/Physical Disks/Wipe/Quick" Function

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Quick Wipe Error w/ "Storage/Physical Disks/Wipe/Quick" Function

      I am actively in the search for a NAS Solution and have been am very impressed with OMV+Community. Thank you to all that are involved here!

      I recently installed OMV Erasmus on a test setup with a cheap SSD as the boot device and 1 WD40EFRX as the sole storage device to learn more about the platform and to play around with the feature set. I installed the "Backports Kernel" and OMV Extras. I tried to do a "Quick Wipe" of the WD40EFRX and got the following error message:

      Error #0:
      exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; blockdev --rereadpt '/dev/sda' 2>&1': BLKRRPART: Device or resource busy' in /usr/share/openmediavault/engined/rpc/diskmgmt.inc:265
      Stack trace:
      #0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMVRpcServiceDiskMgmt->{closure}('/tmp/bgstatusLp...', '/tmp/bgoutput6C...')
      #1 /usr/share/openmediavault/engined/rpc/diskmgmt.inc(267): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      #2 [internal function]: OMVRpcServiceDiskMgmt->wipe(Array, Array)
      #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      #4 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('wipe', Array, Array)
      #5 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('DiskMgmt', 'wipe', Array, Array, 1)
      #6 {main}

      Can someone please tell me what I am doing wrong? Many thanks in advance!
      Images
      • Screen Shot 2016-12-17 at 3.01.46 PM.png

        305.98 kB, 1,440×900, viewed 165 times
      3.0.56 (Erasmus) - OMV Extras 3 (Stable)
      AsRock Rack C72504DI
      64GB Crucial ECC Ram
      8x4TB WD40EFRX
      4X4TB HMS5C4040x
      Crucial 525GB SSD
    • @ryecoaaron Thank you for looking at my case! I installed the OMV ISO on a cheap SSD I had laying around using these instructions:


      The odd thing is that when I just tried do a "Secure Wipe", it does not spit out the error message and runs OK. Should I unmount the drive first?
      3.0.56 (Erasmus) - OMV Extras 3 (Stable)
      AsRock Rack C72504DI
      64GB Crucial ECC Ram
      8x4TB WD40EFRX
      4X4TB HMS5C4040x
      Crucial 525GB SSD